aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2015-04-08 06:28:20 +0800
committerosa <osa@FreeBSD.org>2015-04-08 06:28:20 +0800
commit47e0700234bd2fd7485ffa988fe84025c197b3d1 (patch)
treea810954c728e994e4f3d24383518d27b41608e0f /databases
parentff94330c8371d00399b2259b0eaab3818e62c40e (diff)
downloadfreebsd-ports-gnome-47e0700234bd2fd7485ffa988fe84025c197b3d1.tar.gz
freebsd-ports-gnome-47e0700234bd2fd7485ffa988fe84025c197b3d1.tar.zst
freebsd-ports-gnome-47e0700234bd2fd7485ffa988fe84025c197b3d1.zip
Upgrade from 2.8.19 to 3.0.0.
Merge all changes from databases/redis-devel to databases/redis. <ChangeLog> Redis 3.0 release notes ======================= --[ Redis 3.0.0 ] Release date: 1 Apr 2015 >> What's new in Redis 3.0 compared to Redis 2.8? * Redis Cluster: a distributed implementation of a subset of Redis. * New "embedded string" object encoding resulting in less cache misses. Big speed gain under certain work loads. * AOF child -> parent final data transmission to minimize latency due to "last write" during AOF rewrites. * Much improved LRU approximation algorithm for keys eviction. * WAIT command to block waiting for a write to be transmitted to the specified number of slaves. * MIGRATE connection caching. Much faster keys migraitons. * MIGARTE new options COPY and REPLACE. * CLIENT PAUSE command: stop processing client requests for a specified amount of time. * BITCOUNT performance improvements. * CONFIG SET accepts memory values in different units (for example you can use "CONFIG SET maxmemory 1gb"). * Redis log format slightly changed reporting in each line the role of the instance (master/slave) or if it's a saving child log. * INCR performance improvements. >> Refactoring changes (no new features nor bug fixes) * Blocking operations full refactoring (blocked.c) * Client output buffer memory tracking refactored. </ChangeLog>
Diffstat (limited to 'databases')
-rw-r--r--databases/redis/Makefile4
-rw-r--r--databases/redis/distinfo4
-rw-r--r--databases/redis/files/extra-patch-src-Makefile.lua16
-rw-r--r--databases/redis/files/extra-patch-src-Makefile.luajit16
-rw-r--r--databases/redis/files/patch-deps-hiredis-Makefile4
-rw-r--r--databases/redis/files/patch-deps-linenoise-Makefile4
-rw-r--r--databases/redis/files/patch-src-Makefile29
-rw-r--r--databases/redis/files/patch-src-config.h10
-rw-r--r--databases/redis/files/redis.in9
9 files changed, 47 insertions, 49 deletions
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index 6de54c88e890..0a47591175a9 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redis
-DISTVERSION= 2.8.19
+DISTVERSION= 3.0.0
CATEGORIES= databases
MASTER_SITES= http://download.redis.io/releases/
@@ -44,7 +44,7 @@ USES+= tcl:build
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lm -lexecinfo
-CONFLICTS?= redis-devel-2.*
+CONFLICTS?= redis-devel-3.*
USES+= gmake
MAKE_ENV= "V=yo"
diff --git a/databases/redis/distinfo b/databases/redis/distinfo
index 132fc37f5ad0..e052b7605a05 100644
--- a/databases/redis/distinfo
+++ b/databases/redis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redis-2.8.19.tar.gz) = 29bb08abfc3d392b2f0c3e7f48ec46dd09ab1023f9a5575fc2a93546f4ca5145
-SIZE (redis-2.8.19.tar.gz) = 1254857
+SHA256 (redis-3.0.0.tar.gz) = 654c95c6236692dcb916fccba9a34d0877cc91338c8b6a372511e6eb080e34bf
+SIZE (redis-3.0.0.tar.gz) = 1358081
diff --git a/databases/redis/files/extra-patch-src-Makefile.lua b/databases/redis/files/extra-patch-src-Makefile.lua
index ff8d9ae6bd37..a35e056b405d 100644
--- a/databases/redis/files/extra-patch-src-Makefile.lua
+++ b/databases/redis/files/extra-patch-src-Makefile.lua
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2014-09-10 02:02:41.000000000 +0400
-+++ src/Makefile 2014-09-10 02:05:34.000000000 +0400
+--- src/Makefile.orig 2014-05-26 20:06:48.000000000 +0400
++++ src/Makefile 2014-06-02 00:19:36.000000000 +0400
@@ -15,7 +15,7 @@
release_hdr := $(shell sh -c './mkreleasehdr.sh')
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
@@ -17,8 +17,8 @@
+FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
- #DEBUG=-g -ggdb
-@@ -98,6 +98,9 @@
+ DEBUG=-g -ggdb
+@@ -88,6 +88,9 @@
FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
endif
@@ -28,15 +28,15 @@
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
REDIS_INSTALL=$(QUIET_INSTALL)$(INSTALL)
-@@ -118,6 +121,7 @@
+@@ -108,6 +111,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o migrate.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o hyperloglog.o latency.o sparkline.o
-+REDIS_SERVER_OBJ+= lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o fpconv.o
+ REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o
++REDIS_SERVER_OBJ+=fpconv.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
REDIS_CLI_NAME=redis-cli
REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
REDIS_BENCHMARK_NAME=redis-benchmark
-@@ -172,7 +176,7 @@
+@@ -162,7 +166,7 @@
# redis-server
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
diff --git a/databases/redis/files/extra-patch-src-Makefile.luajit b/databases/redis/files/extra-patch-src-Makefile.luajit
index df9af8565095..50e0ffd92146 100644
--- a/databases/redis/files/extra-patch-src-Makefile.luajit
+++ b/databases/redis/files/extra-patch-src-Makefile.luajit
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2014-09-10 02:02:41.000000000 +0400
-+++ src/Makefile 2014-09-10 02:05:34.000000000 +0400
+--- src/Makefile.orig 2014-07-29 12:17:48.000000000 +0400
++++ src/Makefile 2014-09-10 02:30:38.000000000 +0400
@@ -15,7 +15,7 @@
release_hdr := $(shell sh -c './mkreleasehdr.sh')
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
@@ -17,8 +17,8 @@
+FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
- #DEBUG=-g -ggdb
-@@ -98,6 +98,9 @@
+ DEBUG=-g -ggdb
+@@ -88,6 +88,9 @@
FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
endif
@@ -28,15 +28,15 @@
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
REDIS_LD=$(QUIET_LINK)$(CC) $(FINAL_LDFLAGS)
REDIS_INSTALL=$(QUIET_INSTALL)$(INSTALL)
-@@ -118,6 +121,7 @@
+@@ -108,6 +111,7 @@
REDIS_SERVER_NAME=redis-server
REDIS_SENTINEL_NAME=redis-sentinel
- REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o migrate.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o hyperloglog.o latency.o sparkline.o
-+REDIS_SERVER_OBJ+= lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o fpconv.o
+ REDIS_SERVER_OBJ=adlist.o ae.o anet.o dict.o redis.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o
++REDIS_SERVER_OBJ+=fpconv.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o strbuf.o
REDIS_CLI_NAME=redis-cli
REDIS_CLI_OBJ=anet.o sds.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o
REDIS_BENCHMARK_NAME=redis-benchmark
-@@ -172,7 +176,7 @@
+@@ -162,7 +166,7 @@
# redis-server
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ)
diff --git a/databases/redis/files/patch-deps-hiredis-Makefile b/databases/redis/files/patch-deps-hiredis-Makefile
index 579a02a9aade..fdfc1cb4d4f8 100644
--- a/databases/redis/files/patch-deps-hiredis-Makefile
+++ b/databases/redis/files/patch-deps-hiredis-Makefile
@@ -1,5 +1,5 @@
---- deps/hiredis/Makefile.orig 2014-06-27 05:00:12.000000000 +0400
-+++ deps/hiredis/Makefile 2014-06-27 05:02:00.000000000 +0400
+--- deps/hiredis/Makefile.orig 2014-07-29 12:17:48.000000000 +0400
++++ deps/hiredis/Makefile 2014-09-10 02:32:25.000000000 +0400
@@ -25,10 +25,10 @@
# Fallback to gcc when $CC is not in $PATH.
diff --git a/databases/redis/files/patch-deps-linenoise-Makefile b/databases/redis/files/patch-deps-linenoise-Makefile
index 81bfa9200584..8f39994aa201 100644
--- a/databases/redis/files/patch-deps-linenoise-Makefile
+++ b/databases/redis/files/patch-deps-linenoise-Makefile
@@ -1,5 +1,5 @@
---- deps/linenoise/Makefile.orig 2014-12-12 07:06:18.000000000 +0300
-+++ deps/linenoise/Makefile 2014-12-12 07:06:36.000000000 +0300
+--- deps/linenoise/Makefile.orig 2015-01-17 22:13:25.000000000 +0300
++++ deps/linenoise/Makefile 2015-01-17 22:13:45.000000000 +0300
@@ -1,10 +1,10 @@
STD=
WARN= -Wall
diff --git a/databases/redis/files/patch-src-Makefile b/databases/redis/files/patch-src-Makefile
index c46535e86bd0..bfbe89b2d241 100644
--- a/databases/redis/files/patch-src-Makefile
+++ b/databases/redis/files/patch-src-Makefile
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2014-09-01 19:00:38.000000000 +0400
-+++ src/Makefile 2014-09-09 05:45:32.000000000 +0400
+--- src/Makefile.orig 2015-04-01 17:01:44.000000000 +0300
++++ src/Makefile 2015-04-07 21:30:22.464962000 +0300
@@ -22,7 +22,7 @@
WARN=-Wall -W
OPT=$(OPTIMIZATION)
@@ -9,28 +9,27 @@
INSTALL_BIN=$(PREFIX)/bin
INSTALL=install
-@@ -52,7 +52,7 @@
+@@ -52,7 +52,6 @@
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
FINAL_LIBS=-lm
-DEBUG=-g -ggdb
-+#DEBUG=-g -ggdb
ifeq ($(uname_S),SunOS)
# SunOS
-@@ -67,7 +67,10 @@
- # AIX
- FINAL_LDFLAGS+= -Wl,-bexpall
- FINAL_LIBS+= -pthread -lcrypt -lbsd
--
-+else
+@@ -63,6 +62,11 @@
+ ifeq ($(uname_S),Darwin)
+ # Darwin (nothing to do)
+ else
+ifeq ($(uname_S),FreeBSD)
++ # FreeBSD
+ FINAL_CFLAGS?= $(CFLAGS) $(REDIS_CFLAGS) -I${PREFIX}/include
-+ FINAL_LDFLAGS= $(LDFLAGS)
- else
- # All the other OSes (notably Linux)
- FINAL_LDFLAGS+= -rdynamic
-@@ -75,6 +78,7 @@
++ FINAL_LDFLAGS= $(LDFLAGS) -pthread
++else
+ ifeq ($(uname_S),AIX)
+ # AIX
+ FINAL_LDFLAGS+= -Wl,-bexpall
+@@ -75,6 +79,7 @@
endif
endif
endif
diff --git a/databases/redis/files/patch-src-config.h b/databases/redis/files/patch-src-config.h
index 2225d63d9d36..23666a862b96 100644
--- a/databases/redis/files/patch-src-config.h
+++ b/databases/redis/files/patch-src-config.h
@@ -1,11 +1,11 @@
---- src/config.h.orig 2013-02-11 21:47:44.000000000 +0400
-+++ src/config.h 2013-02-11 21:50:10.000000000 +0400
-@@ -54,7 +54,7 @@
+--- src/config.h.orig 2015-04-07 21:24:36.634829000 +0300
++++ src/config.h 2015-04-07 21:24:53.388849000 +0300
+@@ -62,7 +62,7 @@
#endif
/* Test for backtrace() */
--#if defined(__APPLE__) || defined(__linux__)
-+#if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__)
+-#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__))
++#if defined(__APPLE__) || (defined(__linux__) && defined(__GLIBC__)) || defined(__FreeBSD__)
#define HAVE_BACKTRACE 1
#endif
diff --git a/databases/redis/files/redis.in b/databases/redis/files/redis.in
index a7a8b540821a..386639f2c890 100644
--- a/databases/redis/files/redis.in
+++ b/databases/redis/files/redis.in
@@ -16,20 +16,19 @@
. /etc/rc.subr
name="redis"
-rcvar=redis_enable
+rcvar="${name}_enable"
extra_commands="reload"
command="%%PREFIX%%/bin/redis-server"
+config_file="%%PREFIX%%/etc/$name.conf"
+command_args="${config_file}"
pidfile="%%REDIS_RUNDIR%%/$name.pid"
+required_files="${config_file}"
# read configuration and set defaults
load_rc_config "$name"
: ${redis_enable="NO"}
: ${redis_user="%%REDIS_USER%%"}
-: ${redis_config="%%PREFIX%%/etc/$name.conf"}
-
-command_args="${redis_config}"
-required_files="${redis_config}"
run_rc_command "$1"