aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-07-01 06:13:20 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-07-01 06:13:20 +0800
commit48cc6128dcd2a6b6835ce1e5ed122ee27180b490 (patch)
tree1344c36b2b5bdd08d783ee59c1c704ac266c7371 /databases
parentc779f21a0e7bba52fa1fcbaef7c2b07547be8bc8 (diff)
downloadfreebsd-ports-gnome-48cc6128dcd2a6b6835ce1e5ed122ee27180b490.tar.gz
freebsd-ports-gnome-48cc6128dcd2a6b6835ce1e5ed122ee27180b490.tar.zst
freebsd-ports-gnome-48cc6128dcd2a6b6835ce1e5ed122ee27180b490.zip
Remove Perl core modules
- Add BUILD_DEPENDS - Add LICENSE - Add NO_ARCH - Regenerate patch file with makepatch: - Bump PORTREVISION for dependency change
Diffstat (limited to 'databases')
-rw-r--r--databases/mtop/Makefile12
-rw-r--r--databases/mtop/files/patch-mtop.PL6
2 files changed, 11 insertions, 7 deletions
diff --git a/databases/mtop/Makefile b/databases/mtop/Makefile
index 79952289317d..6b93b485828b 100644
--- a/databases/mtop/Makefile
+++ b/databases/mtop/Makefile
@@ -3,17 +3,21 @@
PORTNAME= mtop
PORTVERSION= 0.6.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= MySQL Monitoring Tool
-RUN_DEPENDS= p5-Curses>=0:devel/p5-Curses \
- p5-DBD-mysql>=0:databases/p5-DBD-mysql \
- p5-Net>=0:net/p5-Net
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= p5-Curses>=0:devel/p5-Curses \
+ p5-DBD-mysql>=0:databases/p5-DBD-mysql
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
USES= perl5
USE_PERL5= configure
diff --git a/databases/mtop/files/patch-mtop.PL b/databases/mtop/files/patch-mtop.PL
index d6a534712b9a..aa8d2cb2f3bb 100644
--- a/databases/mtop/files/patch-mtop.PL
+++ b/databases/mtop/files/patch-mtop.PL
@@ -1,6 +1,6 @@
---- mtop.PL.orig 2004-09-12 22:22:03.000000000 +0000
-+++ mtop.PL 2008-10-04 13:26:58.000000000 +0000
-@@ -1253,7 +1253,7 @@
+--- mtop.PL.orig 2004-09-12 22:22:03 UTC
++++ mtop.PL
+@@ -1253,7 +1253,7 @@ sub refresh_screen {
$data =~ s/\.$DOMAIN//o if $col eq "Host";
if ($col eq "Info") {
$data = strip_comments($data);