aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2015-06-02 12:51:35 +0800
committerkuriyama <kuriyama@FreeBSD.org>2015-06-02 12:51:35 +0800
commit5154dc0f98dc5e41e8b5b82d4554a0ef3a5d1668 (patch)
tree995874c778eecbc04ee951a34cadfa63691fb927 /databases
parent9a10ff69a3c9a25d14801311c243374452cc69f7 (diff)
downloadfreebsd-ports-gnome-5154dc0f98dc5e41e8b5b82d4554a0ef3a5d1668.tar.gz
freebsd-ports-gnome-5154dc0f98dc5e41e8b5b82d4554a0ef3a5d1668.tar.zst
freebsd-ports-gnome-5154dc0f98dc5e41e8b5b82d4554a0ef3a5d1668.zip
GitDDL::Migrator is database migration utility extended GitDDL.
Extended features are: - save migration history - rollback to previous version - specify version - specify SQL (sometimes SQL::Translator's output is wrong) - check differences from versioned SQL and real database WWW: http://search.cpan.org/dist/GitDDL-Migrator/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-GitDDL-Migrator/Makefile26
-rw-r--r--databases/p5-GitDDL-Migrator/distinfo2
-rw-r--r--databases/p5-GitDDL-Migrator/pkg-descr11
-rw-r--r--databases/p5-GitDDL-Migrator/pkg-plist2
5 files changed, 42 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e75eaec6338d..e3d215ce49d9 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -409,6 +409,7 @@
SUBDIR += p5-GDBM
SUBDIR += p5-Genezzo
SUBDIR += p5-GitDDL
+ SUBDIR += p5-GitDDL-Migrator
SUBDIR += p5-GraphViz-DBI
SUBDIR += p5-HTML-FormHandler-Model-DBIC
SUBDIR += p5-Ima-DBI
diff --git a/databases/p5-GitDDL-Migrator/Makefile b/databases/p5-GitDDL-Migrator/Makefile
new file mode 100644
index 000000000000..6cecfe5d1f8c
--- /dev/null
+++ b/databases/p5-GitDDL-Migrator/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= GitDDL-Migrator
+PORTVERSION= 0.07
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SONGMU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to extended p5-GitDDL
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= \
+ p5-GitDDL>=0.03:${PORTSDIR}/databases/p5-GitDDL \
+ p5-Mouse>0:${PORTSDIR}/devel/p5-Mouse \
+ p5-SQL-Translator>0:${PORTSDIR}/databases/p5-SQL-Translator
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild
+NO_ARCH= YES
+
+.include <bsd.port.mk>
diff --git a/databases/p5-GitDDL-Migrator/distinfo b/databases/p5-GitDDL-Migrator/distinfo
new file mode 100644
index 000000000000..6668dac6bb56
--- /dev/null
+++ b/databases/p5-GitDDL-Migrator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (GitDDL-Migrator-0.07.tar.gz) = b78ed88c042f1fa6a1221ad8393c1cef4ef88c27fcb10d6b81429703a4adf8ff
+SIZE (GitDDL-Migrator-0.07.tar.gz) = 13631
diff --git a/databases/p5-GitDDL-Migrator/pkg-descr b/databases/p5-GitDDL-Migrator/pkg-descr
new file mode 100644
index 000000000000..b8c39a51f336
--- /dev/null
+++ b/databases/p5-GitDDL-Migrator/pkg-descr
@@ -0,0 +1,11 @@
+GitDDL::Migrator is database migration utility extended GitDDL.
+
+Extended features are:
+
+- save migration history
+- rollback to previous version
+- specify version
+- specify SQL (sometimes SQL::Translator's output is wrong)
+- check differences from versioned SQL and real database
+
+WWW: http://search.cpan.org/dist/GitDDL-Migrator/
diff --git a/databases/p5-GitDDL-Migrator/pkg-plist b/databases/p5-GitDDL-Migrator/pkg-plist
new file mode 100644
index 000000000000..397b460130ea
--- /dev/null
+++ b/databases/p5-GitDDL-Migrator/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/GitDDL::Migrator.3.gz
+%%SITE_PERL%%/GitDDL/Migrator.pm