aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-07 09:47:56 +0800
committerwen <wen@FreeBSD.org>2010-12-07 09:47:56 +0800
commit5e354949a8bbf892dbe3dae7984508874f2bf469 (patch)
tree4cb4b367a1ba0893bbbdd7f510922cb265a1c4d8 /databases
parent73373caa0bcb4e8c81c2313d9ab3fa2f6f1f6b32 (diff)
downloadfreebsd-ports-gnome-5e354949a8bbf892dbe3dae7984508874f2bf469.tar.gz
freebsd-ports-gnome-5e354949a8bbf892dbe3dae7984508874f2bf469.tar.zst
freebsd-ports-gnome-5e354949a8bbf892dbe3dae7984508874f2bf469.zip
DBIx::NoSQL is a layer over DBI that presents a NoSQLish way to store and
retrieve data. It does this by using a table called __Store__. Once connected to a database, it will detect if this table is missing and create it if necessary. When writing data to the store, the data (a HASH reference) is first serialized using JSON and then inserted/updated via DBIx::Class to (currently) an SQLite backend. Retrieving data from the store is done by key lookup or by searching an SQL-based index. Once found, the data is deserialized via JSON and returned. WWW: http://search.cpan.org/dist/DBIx-NoSQL/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-NoSQL/Makefile31
-rw-r--r--databases/p5-DBIx-NoSQL/distinfo2
-rw-r--r--databases/p5-DBIx-NoSQL/pkg-descr13
-rw-r--r--databases/p5-DBIx-NoSQL/pkg-plist19
5 files changed, 66 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9d8727a361a4..ccadbab3c62f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -364,6 +364,7 @@
SUBDIR += p5-DBIx-HA
SUBDIR += p5-DBIx-Log4perl
SUBDIR += p5-DBIx-MySQLSequence
+ SUBDIR += p5-DBIx-NoSQL
SUBDIR += p5-DBIx-Password
SUBDIR += p5-DBIx-Perlish
SUBDIR += p5-DBIx-Recordset
diff --git a/databases/p5-DBIx-NoSQL/Makefile b/databases/p5-DBIx-NoSQL/Makefile
new file mode 100644
index 000000000000..4087a700bebe
--- /dev/null
+++ b/databases/p5-DBIx-NoSQL/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-DBIx-NoSQL
+# Date created: Dec 07, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-NoSQL
+PORTVERSION= 0.0014
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= NoSQL-ish overlay for an SQL database
+
+RUN_DEPENDS= p5-Any-Moose>0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-DBD-SQLite>0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-Hash-Merge-Simple>0:${PORTSDIR}/devel/p5-Hash-Merge-Simple \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Path-Class>0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-SQL-Translator>0:${PORTSDIR}/databases/p5-SQL-Translator \
+ p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-DBIx-Class>=0.08124:${PORTSDIR}/databases/p5-DBIx-Class
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::NoSQL.3 \
+ DBIx::NoSQLite.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-NoSQL/distinfo b/databases/p5-DBIx-NoSQL/distinfo
new file mode 100644
index 000000000000..d95ed2e90818
--- /dev/null
+++ b/databases/p5-DBIx-NoSQL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-NoSQL-0.0014.tar.gz) = 07fa0c044f4619cd1a9f6189be62e4981203b5614615a128084aa49e95b4ba40
+SIZE (DBIx-NoSQL-0.0014.tar.gz) = 13941
diff --git a/databases/p5-DBIx-NoSQL/pkg-descr b/databases/p5-DBIx-NoSQL/pkg-descr
new file mode 100644
index 000000000000..e236e2ceb5d2
--- /dev/null
+++ b/databases/p5-DBIx-NoSQL/pkg-descr
@@ -0,0 +1,13 @@
+DBIx::NoSQL is a layer over DBI that presents a NoSQLish way to store and
+retrieve data. It does this by using a table called __Store__. Once connected
+to a database, it will detect if this table is missing and create it if
+necessary.
+
+When writing data to the store, the data (a HASH reference) is first
+serialized using JSON and then inserted/updated via DBIx::Class to (currently)
+an SQLite backend.
+
+Retrieving data from the store is done by key lookup or by searching an
+SQL-based index. Once found, the data is deserialized via JSON and returned.
+
+WWW: http://search.cpan.org/dist/DBIx-NoSQL/
diff --git a/databases/p5-DBIx-NoSQL/pkg-plist b/databases/p5-DBIx-NoSQL/pkg-plist
new file mode 100644
index 000000000000..f113bd0781b8
--- /dev/null
+++ b/databases/p5-DBIx-NoSQL/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/DBIx/NoSQL.pm
+%%SITE_PERL%%/DBIx/NoSQLite.pm
+%%SITE_PERL%%/DBIx/NoSQL/Model/Field.pm
+%%SITE_PERL%%/DBIx/NoSQL/Model/Index.pm
+%%SITE_PERL%%/DBIx/NoSQL/Entity.pm
+%%SITE_PERL%%/DBIx/NoSQL/TypeMap.pm
+%%SITE_PERL%%/DBIx/NoSQL/Class.pm
+%%SITE_PERL%%/DBIx/NoSQL/Store.pm
+%%SITE_PERL%%/DBIx/NoSQL/Search.pm
+%%SITE_PERL%%/DBIx/NoSQL/Model.pm
+%%SITE_PERL%%/DBIx/NoSQL/Stash.pm
+%%SITE_PERL%%/DBIx/NoSQL/Storage.pm
+%%SITE_PERL%%/DBIx/NoSQL/ClassScaffold.pm
+@dirrmtry %%SITE_PERL%%/DBIx/NoSQL/Model
+@dirrmtry %%SITE_PERL%%/DBIx/NoSQL
+@dirrmtry %%SITE_PERL%%/DBIx
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/NoSQL/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/NoSQL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx