aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-11-28 08:54:56 +0800
committerlofi <lofi@FreeBSD.org>2004-11-28 08:54:56 +0800
commit6df94fdc6f9fb44605ab91eca6c54ad70c0874cc (patch)
tree6cd50450161834a1de80bd6f31f4fc88cf0b0379 /databases
parent673e26f7ccde3c1e52ab47eff5737bafeb527aeb (diff)
downloadfreebsd-ports-gnome-6df94fdc6f9fb44605ab91eca6c54ad70c0874cc.tar.gz
freebsd-ports-gnome-6df94fdc6f9fb44605ab91eca6c54ad70c0874cc.tar.zst
freebsd-ports-gnome-6df94fdc6f9fb44605ab91eca6c54ad70c0874cc.zip
Fix configure checks for C++ headers on 4.x
PR: ????? (¹) Submitted by: maintainer (¹) PR was cc'd to me six hours ago, but hasn't made it into GNATS yet. Assemble an away team, number one!
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-libpqxx/Makefile5
-rw-r--r--databases/postgresql-libpqxx3/Makefile5
-rw-r--r--databases/postgresql-libpqxx30/Makefile5
3 files changed, 9 insertions, 6 deletions
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 9a7625bd8f51..ce6f12d529c1 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libpqxx
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqxx/stable/
PKGNAMEPREFIX= postgresql-
@@ -34,9 +35,9 @@ POSTGRESQL_PORT?= databases/postgresql7
.if ${OSVERSION} < 500035
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CXXFLAGS+= -I${LOCALBASE}/include/stlport
+CPPFLAGS+= -I${LOCALBASE}/include/stlport
LDFLAGS+= -L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
.endif
.include <bsd.port.post.mk>
diff --git a/databases/postgresql-libpqxx3/Makefile b/databases/postgresql-libpqxx3/Makefile
index 9a7625bd8f51..ce6f12d529c1 100644
--- a/databases/postgresql-libpqxx3/Makefile
+++ b/databases/postgresql-libpqxx3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libpqxx
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqxx/stable/
PKGNAMEPREFIX= postgresql-
@@ -34,9 +35,9 @@ POSTGRESQL_PORT?= databases/postgresql7
.if ${OSVERSION} < 500035
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CXXFLAGS+= -I${LOCALBASE}/include/stlport
+CPPFLAGS+= -I${LOCALBASE}/include/stlport
LDFLAGS+= -L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
.endif
.include <bsd.port.post.mk>
diff --git a/databases/postgresql-libpqxx30/Makefile b/databases/postgresql-libpqxx30/Makefile
index 9a7625bd8f51..ce6f12d529c1 100644
--- a/databases/postgresql-libpqxx30/Makefile
+++ b/databases/postgresql-libpqxx30/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libpqxx
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqxx/stable/
PKGNAMEPREFIX= postgresql-
@@ -34,9 +35,9 @@ POSTGRESQL_PORT?= databases/postgresql7
.if ${OSVERSION} < 500035
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CXXFLAGS+= -I${LOCALBASE}/include/stlport
+CPPFLAGS+= -I${LOCALBASE}/include/stlport
LDFLAGS+= -L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
.endif
.include <bsd.port.post.mk>