aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-01-10 21:40:21 +0800
committerale <ale@FreeBSD.org>2005-01-10 21:40:21 +0800
commita30c0cdc05c39dacbb6de2ef1a82ef9989d86e7c (patch)
tree81d71d204a7ad26a090c674e2a5321f958347c08 /databases
parentccabe9dbb9f0f5f8826715d98c11dbb09000919e (diff)
downloadfreebsd-ports-gnome-a30c0cdc05c39dacbb6de2ef1a82ef9989d86e7c.tar.gz
freebsd-ports-gnome-a30c0cdc05c39dacbb6de2ef1a82ef9989d86e7c.tar.zst
freebsd-ports-gnome-a30c0cdc05c39dacbb6de2ef1a82ef9989d86e7c.zip
Move pre-configure in the common part.
Spotted by: Maxim Maximov <mcsi@mcsi.pp.ru>
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql40-server/Makefile12
-rw-r--r--databases/mysql41-server/Makefile12
-rw-r--r--databases/mysql50-server/Makefile12
-rw-r--r--databases/mysql51-server/Makefile12
-rw-r--r--databases/mysql54-server/Makefile12
-rw-r--r--databases/mysql55-server/Makefile12
-rw-r--r--databases/mysql60-server/Makefile12
-rw-r--r--databases/percona55-server/Makefile12
8 files changed, 48 insertions, 48 deletions
diff --git a/databases/mysql40-server/Makefile b/databases/mysql40-server/Makefile
index 451c688a5806..4152d4cb202f 100644
--- a/databases/mysql40-server/Makefile
+++ b/databases/mysql40-server/Makefile
@@ -145,12 +145,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -229,4 +223,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/mysql41-server/Makefile b/databases/mysql41-server/Makefile
index 47c0382b801e..f229a60744b5 100644
--- a/databases/mysql41-server/Makefile
+++ b/databases/mysql41-server/Makefile
@@ -159,12 +159,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -248,4 +242,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/mysql50-server/Makefile b/databases/mysql50-server/Makefile
index 702f3d9aa9b6..631e1c4bbc8d 100644
--- a/databases/mysql50-server/Makefile
+++ b/databases/mysql50-server/Makefile
@@ -160,12 +160,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -249,4 +243,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 702f3d9aa9b6..631e1c4bbc8d 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -160,12 +160,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -249,4 +243,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index 702f3d9aa9b6..631e1c4bbc8d 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -160,12 +160,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -249,4 +243,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 702f3d9aa9b6..631e1c4bbc8d 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -160,12 +160,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -249,4 +243,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/mysql60-server/Makefile b/databases/mysql60-server/Makefile
index 702f3d9aa9b6..631e1c4bbc8d 100644
--- a/databases/mysql60-server/Makefile
+++ b/databases/mysql60-server/Makefile
@@ -160,12 +160,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -249,4 +243,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 702f3d9aa9b6..631e1c4bbc8d 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -160,12 +160,6 @@ post-patch:
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
-.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
-pre-configure:
- @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
- @${FALSE}
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
.if exists(${DB_DIR}) && defined(OVERWRITE_DB) && ${OVERWRITE_DB:L} != "no"
@@ -249,4 +243,10 @@ post-patch:
post-extract:
@${CP} /usr/include/tcpd.h ${WRKSRC}/sql/mytcpd.h
+.if defined(WITH_OPENSSL) && defined(BUILD_STATIC)
+pre-configure:
+ @${ECHO} "You can't use the BUILD_STATIC option when using OpenSSL."
+ @${FALSE}
+.endif
+
.include <bsd.port.post.mk>