aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-16 14:56:48 +0800
committerwen <wen@FreeBSD.org>2010-03-16 14:56:48 +0800
commita94bfc2dca74336f172e7314145b4cdc525393d5 (patch)
tree2f4b5f108330a60f2b69a802dbd0fc3113362674 /databases
parent9d6c350d084159b520d317f66c6adc495ac123f2 (diff)
downloadfreebsd-ports-gnome-a94bfc2dca74336f172e7314145b4cdc525393d5.tar.gz
freebsd-ports-gnome-a94bfc2dca74336f172e7314145b4cdc525393d5.tar.zst
freebsd-ports-gnome-a94bfc2dca74336f172e7314145b4cdc525393d5.zip
Class::DBI::Lite offers a simple way to deal with databases in an
object-oriented way. One class (the Model class) defines your connection to the database (eg: connectionstring, username and password) and your other classes define interaction with one table each (your entity classes). The Entity classes subclass the Model class and automatically inherit its connection. WWW: http://search.cpan.org/dist/Class-DBI-Lite/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Class-DBI-Lite/Makefile38
-rw-r--r--databases/p5-Class-DBI-Lite/distinfo3
-rw-r--r--databases/p5-Class-DBI-Lite/pkg-descr11
-rw-r--r--databases/p5-Class-DBI-Lite/pkg-plist22
5 files changed, 75 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index aaa3bf2ccf55..177056bf3c91 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -261,6 +261,7 @@
SUBDIR += p5-Class-DBI-DDL
SUBDIR += p5-Class-DBI-FromCGI
SUBDIR += p5-Class-DBI-LazyInflate
+ SUBDIR += p5-Class-DBI-Lite
SUBDIR += p5-Class-DBI-Loader
SUBDIR += p5-Class-DBI-Loader-Relationship
SUBDIR += p5-Class-DBI-Oracle
diff --git a/databases/p5-Class-DBI-Lite/Makefile b/databases/p5-Class-DBI-Lite/Makefile
new file mode 100644
index 000000000000..a2d93b20d40e
--- /dev/null
+++ b/databases/p5-Class-DBI-Lite/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Class-DBI-Lite
+# Date created: 16th March, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-DBI-Lite
+PORTVERSION= 1.002
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Lightweight ORM for Perl
+
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBIx-ContextualFetch>=0:${PORTSDIR}/databases/p5-DBIx-ContextualFetch \
+ p5-Ima-DBI>=0:${PORTSDIR}/databases/p5-Ima-DBI \
+ p5-SQL-Abstract-Limit>=0:${PORTSDIR}/databases/p5-SQL-Abstract-Limit \
+ p5-Test-Memory-Cycle>=0:${PORTSDIR}/devel/p5-Test-Memory-Cycle \
+ p5-SQL-Abstract>=0:${PORTSDIR}/databases/p5-SQL-Abstract
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::DBI::Lite.3 \
+ Class::DBI::Lite::Fixture.3 \
+ Class::DBI::Lite::ColumnInfo.3 \
+ Class::DBI::Lite::CacheManager::InMemory.3 \
+ Class::DBI::Lite::CacheManager.3 \
+ Class::DBI::Lite::Tutorial.3 \
+ Class::DBI::Lite::Iterator.3 \
+ Class::DBI::Lite::TableInfo.3 \
+ Class::DBI::Lite::CacheManager::Memcached.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Class-DBI-Lite/distinfo b/databases/p5-Class-DBI-Lite/distinfo
new file mode 100644
index 000000000000..661083496643
--- /dev/null
+++ b/databases/p5-Class-DBI-Lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-DBI-Lite-1.002.tar.gz) = d9d55bfd469445529652b5b501eba30d
+SHA256 (Class-DBI-Lite-1.002.tar.gz) = 458338cacc2d50a17034782cb1ad7bc09733ace82a23abe2f55bf74256c90b5e
+SIZE (Class-DBI-Lite-1.002.tar.gz) = 190213
diff --git a/databases/p5-Class-DBI-Lite/pkg-descr b/databases/p5-Class-DBI-Lite/pkg-descr
new file mode 100644
index 000000000000..d609764f94ed
--- /dev/null
+++ b/databases/p5-Class-DBI-Lite/pkg-descr
@@ -0,0 +1,11 @@
+Class::DBI::Lite offers a simple way to deal with databases in an
+object-oriented way.
+
+One class (the Model class) defines your connection to the database
+(eg: connectionstring, username and password) and your other classes
+define interaction with one table each (your entity classes).
+
+The Entity classes subclass the Model class and automatically inherit
+its connection.
+
+WWW: http://search.cpan.org/dist/Class-DBI-Lite/
diff --git a/databases/p5-Class-DBI-Lite/pkg-plist b/databases/p5-Class-DBI-Lite/pkg-plist
new file mode 100644
index 000000000000..82306c668596
--- /dev/null
+++ b/databases/p5-Class-DBI-Lite/pkg-plist
@@ -0,0 +1,22 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/DBI/Lite/.packlist
+%%SITE_PERL%%/Class/DBI/Lite.pm
+%%SITE_PERL%%/Class/DBI/Lite/Fixture.pm
+%%SITE_PERL%%/Class/DBI/Lite/CacheManager/InMemory.pm
+%%SITE_PERL%%/Class/DBI/Lite/CacheManager/Memcached.pm
+%%SITE_PERL%%/Class/DBI/Lite/EntityMeta.pm
+%%SITE_PERL%%/Class/DBI/Lite/SQLite.pm
+%%SITE_PERL%%/Class/DBI/Lite/ColumnInfo.pm
+%%SITE_PERL%%/Class/DBI/Lite/CacheManager.pm
+%%SITE_PERL%%/Class/DBI/Lite/RootMeta.pm
+%%SITE_PERL%%/Class/DBI/Lite/Tutorial.pod
+%%SITE_PERL%%/Class/DBI/Lite/AdHocEntity.pm
+%%SITE_PERL%%/Class/DBI/Lite/mysql.pm
+%%SITE_PERL%%/Class/DBI/Lite/Iterator.pm
+%%SITE_PERL%%/Class/DBI/Lite/TableInfo.pm
+@dirrm %%SITE_PERL%%/Class/DBI/Lite/CacheManager
+@dirrmtry %%SITE_PERL%%/Class/DBI/Lite
+@dirrmtry %%SITE_PERL%%/Class/DBI
+@dirrmtry %%SITE_PERL%%/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/DBI/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/DBI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class