aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-07-16 15:22:50 +0800
committervanilla <vanilla@FreeBSD.org>2001-07-16 15:22:50 +0800
commitae0d2da4166ec9aedd9aca21854387f7f46355cb (patch)
tree02f2c24a5d4ae30d3bf24d1f6212979260b1d26b /databases
parent5d1c696673781101058cb863406d856ee5838b11 (diff)
downloadfreebsd-ports-gnome-ae0d2da4166ec9aedd9aca21854387f7f46355cb.tar.gz
freebsd-ports-gnome-ae0d2da4166ec9aedd9aca21854387f7f46355cb.tar.zst
freebsd-ports-gnome-ae0d2da4166ec9aedd9aca21854387f7f46355cb.zip
DBIWrapper is the generic database Object for accessing
the DBI database interface. It provides the lowest level of functionality needed by any program wanting to access databases via the DBI. Currently, DBIWrapper is only aware of Pg (PostgreSQL), mysql (MySQL) and ODBC DBD modules and how to work with them correctly. Support for transactions on MySQL is now checked for and if found to be available, the AutoCommit flag is turned off so that transactions will be used. PR: ports/28563 Submitted by: Pete Fritchman
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/dbiwrapper/Makefile26
-rw-r--r--databases/dbiwrapper/distinfo1
-rw-r--r--databases/dbiwrapper/pkg-comment1
-rw-r--r--databases/dbiwrapper/pkg-descr15
-rw-r--r--databases/dbiwrapper/pkg-plist5
-rw-r--r--databases/p5-DBIWrapper/Makefile26
-rw-r--r--databases/p5-DBIWrapper/distinfo1
-rw-r--r--databases/p5-DBIWrapper/pkg-comment1
-rw-r--r--databases/p5-DBIWrapper/pkg-descr15
-rw-r--r--databases/p5-DBIWrapper/pkg-plist5
11 files changed, 97 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 16cd11bdf926..a42a15fa6bfb 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -6,6 +6,7 @@
SUBDIR += db
SUBDIR += db3
SUBDIR += dbf2mysql
+ SUBDIR += dbiwrapper
SUBDIR += dbmetrix
SUBDIR += dbtool
SUBDIR += dbview
diff --git a/databases/dbiwrapper/Makefile b/databases/dbiwrapper/Makefile
new file mode 100644
index 000000000000..b61918ce3c8f
--- /dev/null
+++ b/databases/dbiwrapper/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dbiwrapper
+# Date Created: 30 June 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbiwrapper
+PORTVERSION= 0.11
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= dbi_wrapper-${PORTVERSION}
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+USE_PERL5= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBIWrapper.3
+
+.include <bsd.port.mk>
diff --git a/databases/dbiwrapper/distinfo b/databases/dbiwrapper/distinfo
new file mode 100644
index 000000000000..d96be14446ee
--- /dev/null
+++ b/databases/dbiwrapper/distinfo
@@ -0,0 +1 @@
+MD5 (dbi_wrapper-0.11.tar.gz) = 17ab176ae4e274a2897ddacfafa3b403
diff --git a/databases/dbiwrapper/pkg-comment b/databases/dbiwrapper/pkg-comment
new file mode 100644
index 000000000000..39f6637f454a
--- /dev/null
+++ b/databases/dbiwrapper/pkg-comment
@@ -0,0 +1 @@
+Perl extension for generic DBI database access
diff --git a/databases/dbiwrapper/pkg-descr b/databases/dbiwrapper/pkg-descr
new file mode 100644
index 000000000000..d1993c66954f
--- /dev/null
+++ b/databases/dbiwrapper/pkg-descr
@@ -0,0 +1,15 @@
+DBIWrapper is the generic database Object for accessing
+the DBI database interface. It provides the lowest level
+of functionality needed by any program wanting to access
+databases via the DBI. Currently, DBIWrapper is only
+aware of Pg (PostgreSQL), mysql (MySQL) and ODBC DBD
+modules and how to work with them correctly.
+
+Support for transactions on MySQL is now checked for and
+if found to be available, the AutoCommit flag is turned
+off so that transactions will be used.
+
+WWW: http://dbiwrapper.sourceforge.net/
+
+- Pete
+petef@databits.net
diff --git a/databases/dbiwrapper/pkg-plist b/databases/dbiwrapper/pkg-plist
new file mode 100644
index 000000000000..17a378d1469d
--- /dev/null
+++ b/databases/dbiwrapper/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/DBIWrapper.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIWrapper/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIWrapper
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper
diff --git a/databases/p5-DBIWrapper/Makefile b/databases/p5-DBIWrapper/Makefile
new file mode 100644
index 000000000000..b61918ce3c8f
--- /dev/null
+++ b/databases/p5-DBIWrapper/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dbiwrapper
+# Date Created: 30 June 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbiwrapper
+PORTVERSION= 0.11
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= dbi_wrapper-${PORTVERSION}
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+USE_PERL5= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBIWrapper.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIWrapper/distinfo b/databases/p5-DBIWrapper/distinfo
new file mode 100644
index 000000000000..d96be14446ee
--- /dev/null
+++ b/databases/p5-DBIWrapper/distinfo
@@ -0,0 +1 @@
+MD5 (dbi_wrapper-0.11.tar.gz) = 17ab176ae4e274a2897ddacfafa3b403
diff --git a/databases/p5-DBIWrapper/pkg-comment b/databases/p5-DBIWrapper/pkg-comment
new file mode 100644
index 000000000000..39f6637f454a
--- /dev/null
+++ b/databases/p5-DBIWrapper/pkg-comment
@@ -0,0 +1 @@
+Perl extension for generic DBI database access
diff --git a/databases/p5-DBIWrapper/pkg-descr b/databases/p5-DBIWrapper/pkg-descr
new file mode 100644
index 000000000000..d1993c66954f
--- /dev/null
+++ b/databases/p5-DBIWrapper/pkg-descr
@@ -0,0 +1,15 @@
+DBIWrapper is the generic database Object for accessing
+the DBI database interface. It provides the lowest level
+of functionality needed by any program wanting to access
+databases via the DBI. Currently, DBIWrapper is only
+aware of Pg (PostgreSQL), mysql (MySQL) and ODBC DBD
+modules and how to work with them correctly.
+
+Support for transactions on MySQL is now checked for and
+if found to be available, the AutoCommit flag is turned
+off so that transactions will be used.
+
+WWW: http://dbiwrapper.sourceforge.net/
+
+- Pete
+petef@databits.net
diff --git a/databases/p5-DBIWrapper/pkg-plist b/databases/p5-DBIWrapper/pkg-plist
new file mode 100644
index 000000000000..17a378d1469d
--- /dev/null
+++ b/databases/p5-DBIWrapper/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/DBIWrapper.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIWrapper/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBIWrapper
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/DBIWrapper