aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-13 03:21:04 +0800
committermiwi <miwi@FreeBSD.org>2009-03-13 03:21:04 +0800
commitb816c9e1d2c1df116df1048755c05c3668f777ce (patch)
tree6e777b34edbcbac5cbce41f99537a67c08c90d29 /databases
parentea15010ad3fc07708c4aa715dad34a415197bc10 (diff)
downloadfreebsd-ports-gnome-b816c9e1d2c1df116df1048755c05c3668f777ce.tar.gz
freebsd-ports-gnome-b816c9e1d2c1df116df1048755c05c3668f777ce.tar.zst
freebsd-ports-gnome-b816c9e1d2c1df116df1048755c05c3668f777ce.zip
buzhug is a fast, pure-Python database engine, using a syntax that Python
programmers should find very intuitive. The data is stored and accessed on disk (it is not an in-memory database); the implementation has been designed to make all operations, and especially selection, as fast as possible with an interpreted language. The database is implemented as a Python iterator, yielding objects whose attributes are the fields defined when the base is created ; therefore, requests can be expressed as list comprehensions or generator expressions, instead of SQL queries. WWW: http://buzhug.sourceforge.net/ PR: ports/132278 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/buzhug/Makefile20
-rw-r--r--databases/buzhug/distinfo3
-rw-r--r--databases/buzhug/pkg-descr13
-rw-r--r--databases/buzhug/pkg-plist31
5 files changed, 68 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0d37ce4ba661..e45e9ea13481 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -13,6 +13,7 @@
SUBDIR += aolserver-nsmysql
SUBDIR += aolserver-nspostgres
SUBDIR += bbdb
+ SUBDIR += buzhug
SUBDIR += cdb
SUBDIR += clip
SUBDIR += couchdb
diff --git a/databases/buzhug/Makefile b/databases/buzhug/Makefile
new file mode 100644
index 000000000000..226ded95e10f
--- /dev/null
+++ b/databases/buzhug/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: buzhug
+# Date created: 03 March 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= buzhug
+PORTVERSION= 1.5
+CATEGORIES= databases python
+MASTER_SITES= SF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A pure-Python database engine
+
+USE_ZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/databases/buzhug/distinfo b/databases/buzhug/distinfo
new file mode 100644
index 000000000000..cea88dfb0085
--- /dev/null
+++ b/databases/buzhug/distinfo
@@ -0,0 +1,3 @@
+MD5 (buzhug-1.5.zip) = 49738182992dd26ad1fa07d9e1133172
+SHA256 (buzhug-1.5.zip) = 8ef62e19729eebaebf051333c7d84f8d87177671c829b5a824291f789adc18a2
+SIZE (buzhug-1.5.zip) = 33163
diff --git a/databases/buzhug/pkg-descr b/databases/buzhug/pkg-descr
new file mode 100644
index 000000000000..d2cd81b2e193
--- /dev/null
+++ b/databases/buzhug/pkg-descr
@@ -0,0 +1,13 @@
+buzhug is a fast, pure-Python database engine, using a syntax that Python
+programmers should find very intuitive.
+
+The data is stored and accessed on disk (it is not an in-memory database);
+the implementation has been designed to make all operations, and especially
+selection, as fast as possible with an interpreted language.
+
+The database is implemented as a Python iterator, yielding objects whose
+attributes are the fields defined when the base is created ; therefore,
+requests can be expressed as list comprehensions or generator expressions,
+instead of SQL queries.
+
+WWW: http://buzhug.sourceforge.net/
diff --git a/databases/buzhug/pkg-plist b/databases/buzhug/pkg-plist
new file mode 100644
index 000000000000..7dbdbd6d8bdf
--- /dev/null
+++ b/databases/buzhug/pkg-plist
@@ -0,0 +1,31 @@
+%%PYTHON_SITELIBDIR%%/buzhug/SimpleAsyncHTTPServer.py
+%%PYTHON_SITELIBDIR%%/buzhug/SimpleAsyncHTTPServer.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/SimpleAsyncHTTPServer.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/__init__.py
+%%PYTHON_SITELIBDIR%%/buzhug/__init__.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/__init__.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug.py
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_algos.py
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_algos.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_algos.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_client.py
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_client.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_client.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_files.py
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_files.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_files.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_info.py
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_info.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_info.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_server.py
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_server.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_server.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_test.py
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_test.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/buzhug_test.pyo
+%%PYTHON_SITELIBDIR%%/buzhug/conversion_float.py
+%%PYTHON_SITELIBDIR%%/buzhug/conversion_float.pyc
+%%PYTHON_SITELIBDIR%%/buzhug/conversion_float.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/buzhug