aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-12-25 11:06:43 +0800
committerclsung <clsung@FreeBSD.org>2007-12-25 11:06:43 +0800
commitc6c284496dfcc5b02c9bbfe3c31b1e636d2e389c (patch)
tree45192c496e930a45a9bb30d45da83731949f1028 /databases
parent05c0c2f31f5402d719a805fc23a36b2401805b2b (diff)
downloadfreebsd-ports-gnome-c6c284496dfcc5b02c9bbfe3c31b1e636d2e389c.tar.gz
freebsd-ports-gnome-c6c284496dfcc5b02c9bbfe3c31b1e636d2e389c.tar.zst
freebsd-ports-gnome-c6c284496dfcc5b02c9bbfe3c31b1e636d2e389c.zip
Tokyo Cabinet is a library of routines for managing a database. The
database is a simple data file containing records, each is a pair of a key and a value. Every key and value is serial bytes with variable length. Both binary data and character string can be used as a key and a value. There is neither concept of data tables nor data types. Records are organized in hash table or B+ tree. WWW: http://tokyocabinet.sourceforge.net/ PR: ports/118947 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/tokyocabinet/Makefile32
-rw-r--r--databases/tokyocabinet/distinfo3
-rw-r--r--databases/tokyocabinet/pkg-descr8
-rw-r--r--databases/tokyocabinet/pkg-plist32
5 files changed, 76 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6f9ce7202647..b80c8bb663b9 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -533,6 +533,7 @@
SUBDIR += tcl-Mysql
SUBDIR += tdb
SUBDIR += tinycdb
+ SUBDIR += tokyocabinet
SUBDIR += tora
SUBDIR += typhoon
SUBDIR += unixODBC
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
new file mode 100644
index 000000000000..d3a6bef86318
--- /dev/null
+++ b/databases/tokyocabinet/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tokyocabinet
+# Date created: 2007-12-22
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tokyocabinet
+PORTVERSION= 1.1.6
+CATEGORIES= databases
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A modern implementation of DBM
+
+CONFIGURE_ARGS= --enable-off64
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+MAN1= tcbmgr.1 tcbmttest.1 tcbtest.1 tchmgr.1 tchmttest.1 \
+ tchtest.1 tcucodec.1 tcumttest.1 tcutest.1
+MAN3= tcbdb.3 tchdb.3 tcutil.3 tokyocabinet.3
+
+# Because gnomehack use "(libdir)" and it doesn't work, we need to patch
+# it manually.
+post-patch:
+ ${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|@prefix@/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/databases/tokyocabinet/distinfo b/databases/tokyocabinet/distinfo
new file mode 100644
index 000000000000..159339ee1fa7
--- /dev/null
+++ b/databases/tokyocabinet/distinfo
@@ -0,0 +1,3 @@
+MD5 (tokyocabinet-1.1.6.tar.gz) = 25b86778713ef89d13570b2787815ea3
+SHA256 (tokyocabinet-1.1.6.tar.gz) = 188cecb014935de2fd11aa2e9ca13487378a3f18e35a4a9546489a85f8effa1a
+SIZE (tokyocabinet-1.1.6.tar.gz) = 312557
diff --git a/databases/tokyocabinet/pkg-descr b/databases/tokyocabinet/pkg-descr
new file mode 100644
index 000000000000..d21a454367b8
--- /dev/null
+++ b/databases/tokyocabinet/pkg-descr
@@ -0,0 +1,8 @@
+Tokyo Cabinet is a library of routines for managing a database. The
+database is a simple data file containing records, each is a pair of a
+key and a value. Every key and value is serial bytes with variable
+length. Both binary data and character string can be used as a key and
+a value. There is neither concept of data tables nor data types.
+Records are organized in hash table or B+ tree.
+
+WWW: http://tokyocabinet.sourceforge.net/
diff --git a/databases/tokyocabinet/pkg-plist b/databases/tokyocabinet/pkg-plist
new file mode 100644
index 000000000000..6d16576f770a
--- /dev/null
+++ b/databases/tokyocabinet/pkg-plist
@@ -0,0 +1,32 @@
+@comment $FreeBSD$
+%%DATADIR%%/COPYING
+%%DATADIR%%/ChangeLog
+%%DATADIR%%/THANKS
+%%DATADIR%%/doc/benchmark.pdf
+%%DATADIR%%/doc/common.css
+%%DATADIR%%/doc/icon16.png
+%%DATADIR%%/doc/index.html
+%%DATADIR%%/doc/index.ja.html
+%%DATADIR%%/doc/logo-ja.png
+%%DATADIR%%/doc/logo.png
+%%DATADIR%%/doc/spex-en.html
+%%DATADIR%%/doc/spex-ja.html
+bin/tcbmgr
+bin/tcbmttest
+bin/tcbtest
+bin/tchmgr
+bin/tchmttest
+bin/tchtest
+bin/tcucodec
+bin/tcumttest
+bin/tcutest
+include/tcbdb.h
+include/tchdb.h
+include/tcutil.h
+lib/libtokyocabinet.a
+lib/libtokyocabinet.so
+lib/libtokyocabinet.so.1
+lib/libtokyocabinet.so.1.25.0
+libdata/pkgconfig/tokyocabinet.pc
+@dirrmtry %%DATADIR%%/doc
+@dirrmtry %%DATADIR%%