aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-27 14:54:48 +0800
committerwen <wen@FreeBSD.org>2010-12-27 14:54:48 +0800
commitc755a58d82f17312173223800360854a8c992104 (patch)
treebc1224bd5c7e2dc7c3bf5359139040c435c89b08 /databases
parent117eddd99bf57c5e21d7c096d6ec5d6b0b18f101 (diff)
downloadfreebsd-ports-gnome-c755a58d82f17312173223800360854a8c992104.tar.gz
freebsd-ports-gnome-c755a58d82f17312173223800360854a8c992104.tar.zst
freebsd-ports-gnome-c755a58d82f17312173223800360854a8c992104.zip
The official Python client for Riak.
Riak is a Dynamo-inspired key/value store that scales predictably and easily. Riak also simplifies development by giving developers the ability to quickly prototype, test, and deploy their applications. A truly fault-tolerant system, Riak has no single point of failure. No machines are special or central in Riak, so developers and operations professionals can decide exactly how fault-tolerant they want and need their applications to be. WWW: https://github.com/basho/riak-python-client PR: ports/153342 Submitted by: TJ Ninneman <tj@harperdog.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-riak/Makefile25
-rw-r--r--databases/py-riak/distinfo2
-rw-r--r--databases/py-riak/pkg-descr10
-rw-r--r--databases/py-riak/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 674b9b6d83b4..19a0563a85a7 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -661,6 +661,7 @@
SUBDIR += py-pysqlite23
SUBDIR += py-pytc
SUBDIR += py-qt4-sql
+ SUBDIR += py-riak
SUBDIR += py-rrdpipe
SUBDIR += py-rrdtool_lgpl
SUBDIR += py-simplecouchdb
diff --git a/databases/py-riak/Makefile b/databases/py-riak/Makefile
new file mode 100644
index 000000000000..e8d9a08bb7e1
--- /dev/null
+++ b/databases/py-riak/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-riak
+# Date created: 2010-12-10
+# Whom: TJ Ninneman <tj@harperdog.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= riak
+PORTVERSION= 1.1.1
+CATEGORIES= databases python
+MASTER_SITES= http://github.com/downloads/tee-jay/riak-python-client/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-python-client-${PORTVERSION}
+
+MAINTAINER= tj@harperdog.com
+COMMENT= Python API for Riak, a Dynamo-inspired key/value store
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}protobuf>0:${PORTSDIR}/devel/py-protobuf
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+FETCH_ARGS= -pRr
+
+.include <bsd.port.mk>
diff --git a/databases/py-riak/distinfo b/databases/py-riak/distinfo
new file mode 100644
index 000000000000..783aa5389f25
--- /dev/null
+++ b/databases/py-riak/distinfo
@@ -0,0 +1,2 @@
+SHA256 (riak-python-client-1.1.1.tar.gz) = e9bc9349e5798db38739ff35b108bdf4ca104c79f5c16301a0ecf318515c502c
+SIZE (riak-python-client-1.1.1.tar.gz) = 27134
diff --git a/databases/py-riak/pkg-descr b/databases/py-riak/pkg-descr
new file mode 100644
index 000000000000..6bb6f22579d9
--- /dev/null
+++ b/databases/py-riak/pkg-descr
@@ -0,0 +1,10 @@
+The official Python client for Riak.
+
+Riak is a Dynamo-inspired key/value store that scales predictably and easily.
+Riak also simplifies development by giving developers the ability to quickly
+prototype, test, and deploy their applications. A truly fault-tolerant system,
+Riak has no single point of failure. No machines are special or central in
+Riak, so developers and operations professionals can decide exactly how
+fault-tolerant they want and need their applications to be.
+
+WWW: https://github.com/basho/riak-python-client
diff --git a/databases/py-riak/pkg-plist b/databases/py-riak/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/databases/py-riak/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%