aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-12-09 08:42:05 +0800
committerlinimon <linimon@FreeBSD.org>2017-12-09 08:42:05 +0800
commitcb4f0fc92060b736b2ab71fcf12d3a0b727aec49 (patch)
treef9138a3823b570522b524c8e385a453e712c9114 /databases
parentcbe45b0f19645e08dd6f6b65750642036029dbb7 (diff)
downloadfreebsd-ports-gnome-cb4f0fc92060b736b2ab71fcf12d3a0b727aec49.tar.gz
freebsd-ports-gnome-cb4f0fc92060b736b2ab71fcf12d3a0b727aec49.tar.zst
freebsd-ports-gnome-cb4f0fc92060b736b2ab71fcf12d3a0b727aec49.zip
Mark more ports broken that fail on both armv6 and armv7.
Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'databases')
-rw-r--r--databases/percona56-server/Makefile2
-rw-r--r--databases/pg_citus/Makefile3
-rw-r--r--databases/soci/Makefile3
3 files changed, 8 insertions, 0 deletions
diff --git a/databases/percona56-server/Makefile b/databases/percona56-server/Makefile
index 1719d526a2ce..f7c36fb6d3e7 100644
--- a/databases/percona56-server/Makefile
+++ b/databases/percona56-server/Makefile
@@ -12,6 +12,8 @@ DISTNAME= percona-server-${DISTVERSION}
MAINTAINER= flo@FreeBSD.org
COMMENT?= Multithreaded SQL database (server)
+BROKEN_armv6= fails to compile: sql/mysqld.cc:198:19: error: cannot combine with previous 'type-name' declaration specifier
+BROKEN_armv7= fails to compile: sql/mysqld.cc:198:19: error: cannot combine with previous 'type-name' declaration specifier
NOT_FOR_ARCHS= powerpc64
NOT_FOR_ARCHS_REASON= unsupported platform
diff --git a/databases/pg_citus/Makefile b/databases/pg_citus/Makefile
index 75f56167eadc..56a77de8d6c2 100644
--- a/databases/pg_citus/Makefile
+++ b/databases/pg_citus/Makefile
@@ -12,6 +12,9 @@ COMMENT= Horizontally scale Postgresql using sharding and replication
LICENSE= AGPLv3
+BROKEN_armv6= fails to compile: transaction/backend_data.c:53:2: error: unknown type name 'pg_atomic_uint64'; did you mean 'pg_atomic_uint32'?
+BROKEN_armv7= fails to compile: transaction/backend_data.c:53:2: error: unknown type name 'pg_atomic_uint64'; did you mean 'pg_atomic_uint32'?
+
USES= gmake pgsql:9.6+ autoreconf readline
WANT_PGSQL= lib server
GNU_CONFIGURE= yes
diff --git a/databases/soci/Makefile b/databases/soci/Makefile
index 36ed4a6ab658..d3cf8d4a39b8 100644
--- a/databases/soci/Makefile
+++ b/databases/soci/Makefile
@@ -13,6 +13,9 @@ COMMENT= The C++ Database Access Library
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
+BROKEN_armv6= fails to compile: backends/mysql/session.cpp:202:22: error: ordered comparison between pointer and zero ('int *' and 'int')
+BROKEN_armv7= fails to compile: backends/mysql/session.cpp:202:22: error: ordered comparison between pointer and zero ('int *' and 'int')
+
USES= cmake zip
CMAKE_ARGS+= -DWITH_ORACLE:BOOL=OFF
USE_LDCONFIG= yes