aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-28 01:17:31 +0800
committermiwi <miwi@FreeBSD.org>2014-06-28 01:17:31 +0800
commitd4627da3f6727bde6637b69c3e9d597e72998e10 (patch)
tree5ed1b30cb02104361fe7030d77061336fd3d22e8 /databases
parentc8d97be13ea91d143df3ee45e5e4b892c2eb4526 (diff)
downloadfreebsd-ports-gnome-d4627da3f6727bde6637b69c3e9d597e72998e10.tar.gz
freebsd-ports-gnome-d4627da3f6727bde6637b69c3e9d597e72998e10.tar.zst
freebsd-ports-gnome-d4627da3f6727bde6637b69c3e9d597e72998e10.zip
- Use proper stripping
- Don't keep la file since shlib got downgraded in r359529 - Bump PORTREVISION
Diffstat (limited to 'databases')
-rw-r--r--databases/sqlite3/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 2133578f0cb8..2ba2c240589f 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sqlite3
PORTVERSION= 3.8.5
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/2014/ http://www2.sqlite.org/2014/ http://www3.sqlite.org/2014/
DISTNAME= sqlite-autoconf-3080500
@@ -17,9 +18,10 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
CONFLICTS= sqlite34-[0-9]* sqlcipher-[0-9]*
-USES= pathfix libtool:keepla
+USES= pathfix libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
@@ -70,9 +72,9 @@ OPTIONS_DEFAULT= FTS4 URI METADATA SECURE_DELETE UNLOCK_NOTIFY THREADS EXTENSION
# RTREE used by graphics/mapnik, databases/spatialite
PLIST_FILES= bin/sqlite3 include/sqlite3.h include/sqlite3ext.h \
- lib/libsqlite3.a lib/libsqlite3.la lib/libsqlite3.so \
- lib/libsqlite3.so.0 lib/libsqlite3.so.0.8.6 \
- libdata/pkgconfig/sqlite3.pc man/man1/sqlite3.1.gz
+ lib/libsqlite3.a lib/libsqlite3.so lib/libsqlite3.so.0 \
+ lib/libsqlite3.so.0.8.6 libdata/pkgconfig/sqlite3.pc \
+ man/man1/sqlite3.1.gz
# The default numeric file permissions for newly created database files under unix.
# If not specified, the default is 0644 which means that the files is globally
@@ -133,7 +135,4 @@ post-build:
@${ECHO_MSG} "===> WARNING: on ${ARCH} don't pass atof1-* tests"
.endif
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsqlite3.so.0.8.6
-
.include <bsd.port.mk>