aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-11-07 21:16:47 +0800
committerwg <wg@FreeBSD.org>2013-11-07 21:16:47 +0800
commite7f208f3369812170fa5144baf4faeea5b2a984a (patch)
tree55e644a7551fac3dd72e89071dce03ea7c6b96d0 /databases
parentd418edd7ed4c335138adfc8c199438fee15bd220 (diff)
downloadfreebsd-ports-gnome-e7f208f3369812170fa5144baf4faeea5b2a984a.tar.gz
freebsd-ports-gnome-e7f208f3369812170fa5144baf4faeea5b2a984a.tar.zst
freebsd-ports-gnome-e7f208f3369812170fa5144baf4faeea5b2a984a.zip
databases/freetds-devel: add option for odbc-wide
PR: ports/182516 Submitted by: Mike Carlson <mike bayphoto.com> Approved by: maintainer
Diffstat (limited to 'databases')
-rw-r--r--databases/freetds-devel/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/databases/freetds-devel/Makefile b/databases/freetds-devel/Makefile
index 9c19bd228b87..e282018d26e0 100644
--- a/databases/freetds-devel/Makefile
+++ b/databases/freetds-devel/Makefile
@@ -28,7 +28,7 @@ MAN1= datacopy.1 freebcp.1 tsql.1 bsqldb.1 bsqlodbc.1 \
MAN5= freetds.conf.5
# OPTIONS_DEFINE= OPENSSL GNUTLS IODBC UNIXODBC MSDBLIB
-OPTIONS_DEFINE= MSDBLIB
+OPTIONS_DEFINE= MSDBLIB ODBCWIDE
OPTIONS_SINGLE= ODBC SSL
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
@@ -41,6 +41,7 @@ GNUTLS_DESC= Use GnuTLS
IODBC_DESC= Depend on iodbc
UNIXODBC_DESC= Depend on unixodbc
MSDBLIB_DESC= MS SQL Server compatibility (breaks databases/sybtcl)
+ODBCWIDE_DESC= Enable Wide ODBC Support
CONFLICTS= freetds-0.64.[0-9]
@@ -52,6 +53,10 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
.endif
+.if ${PORT_OPTIONS:ODBCWIDE}
+CONFIGURE_ARGS+= --enable-odbc-wide
+.endif
+
.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-gnutls