aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-07-23 07:23:59 +0800
committerdougb <dougb@FreeBSD.org>2012-07-23 07:23:59 +0800
commitf1c77bf62fae9c35b8af1d993c00277b5c80860c (patch)
tree4340b2026c7c38e24a07317c8ba6bded8fdc03e8 /databases
parent801feb0362b1fb617ebc8b0be5acef69e99f6d7f (diff)
downloadfreebsd-ports-gnome-f1c77bf62fae9c35b8af1d993c00277b5c80860c.tar.gz
freebsd-ports-gnome-f1c77bf62fae9c35b8af1d993c00277b5c80860c.tar.zst
freebsd-ports-gnome-f1c77bf62fae9c35b8af1d993c00277b5c80860c.zip
For the ports that are maintained by ports@ that have pkgconfig as their
only USE_GNOME feature, convert to a BUILD_DEPENDS. This avoids both the bug of the bogus run depend introduced by bsd.gnome.mk, and also avoids needlessly pulling that file in.
Diffstat (limited to 'databases')
-rw-r--r--databases/hk_classes/Makefile4
-rw-r--r--databases/sqlite2/Makefile3
2 files changed, 4 insertions, 3 deletions
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index 2167c021cbd0..1852a8cf14b4 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -12,14 +12,14 @@ MASTER_SITES= SF/hk-classes/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ Library for rapid development of database applications
-BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
+BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
xml2.5:${PORTSDIR}/textproc/libxml2
USE_BZIP2= yes
USE_ICONV= yes
USE_PYTHON= yes
-USE_GNOME= pkgconfig
USE_GETTEXT= yes
CXXFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index c25d91a0467d..7c4386d65f5b 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -15,8 +15,9 @@ MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= An SQL database engine in a C library
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_GMAKE= YES
-USE_GNOME= pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES