aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-05-02 01:08:01 +0800
committerale <ale@FreeBSD.org>2013-05-02 01:08:01 +0800
commitfb500b67ef21358bf18d47b10eeccd9d0fc01c5f (patch)
treee6aa36239b274792abc64f29506d7df161e92a93 /databases
parent1aa1efc0ff815bf0364814a33b79d73e6b0200e9 (diff)
downloadfreebsd-ports-gnome-fb500b67ef21358bf18d47b10eeccd9d0fc01c5f.tar.gz
freebsd-ports-gnome-fb500b67ef21358bf18d47b10eeccd9d0fc01c5f.tar.zst
freebsd-ports-gnome-fb500b67ef21358bf18d47b10eeccd9d0fc01c5f.zip
Add boost fix for locale.
Diffstat (limited to 'databases')
-rw-r--r--databases/mongodb/Makefile1
-rw-r--r--databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v2_src_v2_path.cpp20
-rw-r--r--databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v3_src_path.cpp20
3 files changed, 41 insertions, 0 deletions
diff --git a/databases/mongodb/Makefile b/databases/mongodb/Makefile
index 8815d5301649..804f260f3cc0 100644
--- a/databases/mongodb/Makefile
+++ b/databases/mongodb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mongodb
PORTVERSION= 2.4.3
+PORTREVISION= 1
CATEGORIES= databases net
MASTER_SITES= http://downloads.mongodb.org/src/
DISTNAME= ${PORTNAME}-src-r${PORTVERSION}
diff --git a/databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v2_src_v2_path.cpp b/databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v2_src_v2_path.cpp
new file mode 100644
index 000000000000..66786523db2e
--- /dev/null
+++ b/databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v2_src_v2_path.cpp
@@ -0,0 +1,20 @@
+--- src/third_party/boost/libs/filesystem/v2/src/v2_path.cpp.orig 2013-05-01 18:59:55.000000000 +0200
++++ src/third_party/boost/libs/filesystem/v2/src/v2_path.cpp 2013-05-01 19:02:01.000000000 +0200
+@@ -30,7 +30,7 @@
+
+ #include <cwchar> // for std::mbstate_t
+
+-#if defined(macintosh) || defined(__APPLE__) || defined(__APPLE_CC__)
++#if defined(macintosh) || defined(__APPLE__) || defined(__APPLE_CC__) || defined(__FreeBSD__)
+ # include <boost/filesystem/detail/utf8_codecvt_facet.hpp>
+ #endif
+
+@@ -43,7 +43,7 @@
+ // occurred before main(), preventing exceptions from being caught.)
+ std::locale & loc()
+ {
+-#if !defined(macintosh) && !defined(__APPLE__) && !defined(__APPLE_CC__)
++#if !defined(macintosh) && !defined(__APPLE__) && !defined(__APPLE_CC__) && !defined(__FreeBSD__)
+ // ISO C calls this "the locale-specific native environment":
+ static std::locale lc("");
+ #else // Mac OS
diff --git a/databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v3_src_path.cpp b/databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v3_src_path.cpp
new file mode 100644
index 000000000000..b8b7f740d21e
--- /dev/null
+++ b/databases/mongodb/files/patch-src_third_party_boost_libs_filesystem_v3_src_path.cpp
@@ -0,0 +1,20 @@
+--- src/third_party/boost/libs/filesystem/v3/src/path.cpp.orig 2013-05-01 19:03:02.000000000 +0200
++++ src/third_party/boost/libs/filesystem/v3/src/path.cpp 2013-05-01 19:03:46.000000000 +0200
+@@ -35,7 +35,7 @@
+ #ifdef BOOST_WINDOWS_API
+ # include "windows_file_codecvt.hpp"
+ # include <windows.h>
+-#elif defined(macintosh) || defined(__APPLE__) || defined(__APPLE_CC__)
++#elif defined(macintosh) || defined(__APPLE__) || defined(__APPLE_CC__) || defined(__FreeBSD__)
+ # include <boost/filesystem/detail/utf8_codecvt_facet.hpp>
+ #endif
+
+@@ -766,7 +766,7 @@
+ codecvt_facet(&std::use_facet<std::codecvt<wchar_t, char, std::mbstate_t> >
+ (path_locale));
+
+-#elif defined(macintosh) || defined(__APPLE__) || defined(__APPLE_CC__)
++#elif defined(macintosh) || defined(__APPLE__) || defined(__APPLE_CC__) || defined(__FreeBSD__)
+
+ // "All BSD system functions expect their string parameters to be in UTF-8 encoding
+ // and nothing else." See