aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-19 21:44:44 +0800
committermiwi <miwi@FreeBSD.org>2007-12-19 21:44:44 +0800
commit12a45d8a2047b5e7ba5e2fb2e7faf3d83fdd0cf6 (patch)
tree4609c736aeae87e2badac64078a83253457aa1a4 /databases
parent76e1ba93ce8135702972edb5a9e8a8a6d3094d60 (diff)
downloadfreebsd-ports-gnome-12a45d8a2047b5e7ba5e2fb2e7faf3d83fdd0cf6.tar.gz
freebsd-ports-gnome-12a45d8a2047b5e7ba5e2fb2e7faf3d83fdd0cf6.tar.zst
freebsd-ports-gnome-12a45d8a2047b5e7ba5e2fb2e7faf3d83fdd0cf6.zip
This is a DataSource driver for Structures_DataGrid using PEAR::DB and an
SQL query. WWW: http://pear.php.net/package/Structures_DataGrid_DataSource_DBQuery/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile28
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBQuery/distinfo3
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBQuery/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index efe05e706f7a..e202a7e469a1 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -338,6 +338,7 @@
SUBDIR += pear-MDB2_Schema
SUBDIR += pear-MDB_QueryTool
SUBDIR += pear-Structures_DataGrid_DataSource_Array
+ SUBDIR += pear-Structures_DataGrid_DataSource_DBQuery
SUBDIR += pear-Structures_DataGrid_DataSource_DBTable
SUBDIR += pecl-memcache
SUBDIR += pecl-sqlite
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
new file mode 100644
index 000000000000..61dd0db16480
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Structures_DataGrid_DataSource_DBQuery
+# Date created: 19 Dec 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Structures_DataGrid_DataSource_DBQuery
+PORTVERSION= 0.1.11
+CATEGORIES= databases www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= DataSource driver using PEAR::DB and an SQL query.
+
+BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
+ ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
+ ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+
+USE_PHP= mysql
+
+CATEGORY= Structures
+
+FILES= DataGrid/DataSource/DBQuery.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBQuery/distinfo b/databases/pear-Structures_DataGrid_DataSource_DBQuery/distinfo
new file mode 100644
index 000000000000..bfb4c05b7cb9
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_DBQuery/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Structures_DataGrid_DataSource_DBQuery-0.1.11.tgz) = 1840626818caac068e1bb4396c0743d0
+SHA256 (PEAR/Structures_DataGrid_DataSource_DBQuery-0.1.11.tgz) = 6de438fd8a45dfab06f65a6870b560178618f6d73c0e8e70e4f860bf2f6d30d9
+SIZE (PEAR/Structures_DataGrid_DataSource_DBQuery-0.1.11.tgz) = 3335
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBQuery/pkg-descr b/databases/pear-Structures_DataGrid_DataSource_DBQuery/pkg-descr
new file mode 100644
index 000000000000..7c482b8207f9
--- /dev/null
+++ b/databases/pear-Structures_DataGrid_DataSource_DBQuery/pkg-descr
@@ -0,0 +1,4 @@
+This is a DataSource driver for Structures_DataGrid using PEAR::DB and an
+SQL query.
+
+WWW: http://pear.php.net/package/Structures_DataGrid_DataSource_DBQuery/