aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2005-05-08 15:44:30 +0800
committernork <nork@FreeBSD.org>2005-05-08 15:44:30 +0800
commit2bfa42dd3811ef0501ba48abf0980fc60f868710 (patch)
tree71e831b7e6b2f06f1e13a51f5142991607c91f87 /databases
parenta8849054f82fad6488b6c684c6aad050ff9b2c33 (diff)
downloadfreebsd-ports-gnome-2bfa42dd3811ef0501ba48abf0980fc60f868710.tar.gz
freebsd-ports-gnome-2bfa42dd3811ef0501ba48abf0980fc60f868710.tar.zst
freebsd-ports-gnome-2bfa42dd3811ef0501ba48abf0980fc60f868710.zip
Chase dependency on p5-DBD-Pg.
(Use p5-DBD-Pg-13 on FreeBSD 4.x and Perl 5.00503)
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql2pgsql/Makefile8
-rw-r--r--databases/p5-Class-DBI-Pg/Makefile12
-rw-r--r--databases/p5-DBD-PgSPI/Makefile9
-rw-r--r--databases/postgresql_autodoc/Makefile12
4 files changed, 30 insertions, 11 deletions
diff --git a/databases/mysql2pgsql/Makefile b/databases/mysql2pgsql/Makefile
index d7e20bddd508..db2e1cf2e876 100644
--- a/databases/mysql2pgsql/Makefile
+++ b/databases/mysql2pgsql/Makefile
@@ -17,7 +17,13 @@ EXTRACT_ONLY= ${PORTNAME}
MAINTAINER= petef@FreeBSD.org
COMMENT= Convert a MySQL dump to a PostgreSQL dump
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg-13
+.else
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.endif
PATCH_WRKSRC= ${WRKDIR}
PLIST_FILES= bin/mysql2pgsql
@@ -31,4 +37,4 @@ do-extract:
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/mysql2pgsql ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Class-DBI-Pg/Makefile b/databases/p5-Class-DBI-Pg/Makefile
index 9da2ab1a9766..d38e729e7367 100644
--- a/databases/p5-Class-DBI-Pg/Makefile
+++ b/databases/p5-Class-DBI-Pg/Makefile
@@ -15,8 +15,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
COMMENT= Extensions to Class::DBI for PostgreSQL
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
- ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg-13
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.endif
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -32,4 +38,4 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBD-PgSPI/Makefile b/databases/p5-DBD-PgSPI/Makefile
index 4fc3cfd96581..91b56c60eb19 100644
--- a/databases/p5-DBD-PgSPI/Makefile
+++ b/databases/p5-DBD-PgSPI/Makefile
@@ -18,8 +18,7 @@ COMMENT= Provides access to PostgreSQL db through DBI within pl/perl functions
BUILD_DEPENDS= ${RUN_DEPENDS} \
${NONEXISTENT}:${PORTSDIR}/${POSTGRESQL_PORT}:configure
-RUN_DEPENDS= ${LOCALBASE}/lib/postgresql/plperl.so:${PORTSDIR}/databases/p5-postgresql-plperl \
- ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS= ${LOCALBASE}/lib/postgresql/plperl.so:${PORTSDIR}/databases/p5-postgresql-plperl
USE_PGSQL= yes
PERL_CONFIGURE= yes
@@ -46,9 +45,11 @@ PGSQL_VER= ${DEFAULT_PGSQL_VER}
.endif
.if ${PERL_LEVEL} < 500600
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137 \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg-13
.else
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
CONFIGURE_ENV= POSTGRES_HOME="`${PGSQL_WRKSRC_CMD}`/src" \
diff --git a/databases/postgresql_autodoc/Makefile b/databases/postgresql_autodoc/Makefile
index c611ca7c0c36..a104c09b2b82 100644
--- a/databases/postgresql_autodoc/Makefile
+++ b/databases/postgresql_autodoc/Makefile
@@ -14,8 +14,14 @@ DIST_SUBDIR= postgresql
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Automatic documentation generator for postgresql databases
-BUILD_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
- ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg-13
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+.endif
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -24,4 +30,4 @@ CONFIGURE_ARGS+= --datadir=${DATADIR}
WRKSRC= ${WRKDIR}/postgresql_autodoc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>