aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2017-11-17 04:02:08 +0800
committerjoneum <joneum@FreeBSD.org>2017-11-17 04:02:08 +0800
commit4340008760d746394a70bf51b4d9f71853848ffc (patch)
tree9a501213d900a8b927337ccec2ddf7b66cbfed3f /databases
parent2e05640a0d3ff6b0c374450977da35190b498c93 (diff)
downloadfreebsd-ports-gnome-4340008760d746394a70bf51b4d9f71853848ffc.tar.gz
freebsd-ports-gnome-4340008760d746394a70bf51b4d9f71853848ffc.tar.zst
freebsd-ports-gnome-4340008760d746394a70bf51b4d9f71853848ffc.zip
New Port: lua-resty-redis - for accessing redis from nginx lua
This Lua library is a Redis client driver for the ngx_lua nginx module: http://wiki.nginx.org/HttpLuaModule This Lua library takes advantage of ngx_lua's cosocket API, which ensures 100% nonblocking behavior. WWW: https://github.com/openresty/lua-resty-redis PR: 191531 Submitted by: arcade@b1t.name (maintainer) Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13121
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/lua-resty-redis/Makefile17
-rw-r--r--databases/lua-resty-redis/distinfo3
-rw-r--r--databases/lua-resty-redis/files/patch-Makefile11
-rw-r--r--databases/lua-resty-redis/pkg-descr8
-rw-r--r--databases/lua-resty-redis/pkg-plist1
6 files changed, 41 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 85548a431072..9c5f0b181ca7 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -164,6 +164,7 @@
SUBDIR += linux-oracle-instantclient-sqlplus
SUBDIR += liquibase
SUBDIR += lmdb
+ SUBDIR += lua-resty-redis
SUBDIR += lua-xapian
SUBDIR += luadbi
SUBDIR += luasql-firebird
diff --git a/databases/lua-resty-redis/Makefile b/databases/lua-resty-redis/Makefile
new file mode 100644
index 000000000000..9690ff9b9a8f
--- /dev/null
+++ b/databases/lua-resty-redis/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= lua-resty-redis
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.26
+CATEGORIES= databases
+
+MAINTAINER= arcade@b1t.name
+COMMENT= Redis client driver for the ngx_lua nginx module
+
+LICENSE= BSD2CLAUSE
+
+USES= lua:51
+USE_GITHUB= yes
+GH_ACCOUNT= openresty
+
+.include <bsd.port.mk>
diff --git a/databases/lua-resty-redis/distinfo b/databases/lua-resty-redis/distinfo
new file mode 100644
index 000000000000..47823fd00582
--- /dev/null
+++ b/databases/lua-resty-redis/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510862473
+SHA256 (openresty-lua-resty-redis-v0.26_GH0.tar.gz) = 8ec3a2b5055776657980fead5dee7651246f4bbb0903db4322dd232209f43b2e
+SIZE (openresty-lua-resty-redis-v0.26_GH0.tar.gz) = 17531
diff --git a/databases/lua-resty-redis/files/patch-Makefile b/databases/lua-resty-redis/files/patch-Makefile
new file mode 100644
index 000000000000..db153d4ee71b
--- /dev/null
+++ b/databases/lua-resty-redis/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-11-04 20:57:34 UTC
++++ Makefile
+@@ -2,7 +2,7 @@ OPENRESTY_PREFIX=/usr/local/openresty-de
+
+ PREFIX ?= /usr/local
+ LUA_INCLUDE_DIR ?= $(PREFIX)/include
+-LUA_LIB_DIR ?= $(PREFIX)/lib/lua/$(LUA_VERSION)
++LUA_LIB_DIR ?= $(PREFIX)/share/lua/$(LUA_VER)
+ INSTALL ?= install
+
+ .PHONY: all test install
diff --git a/databases/lua-resty-redis/pkg-descr b/databases/lua-resty-redis/pkg-descr
new file mode 100644
index 000000000000..bc12d11e620e
--- /dev/null
+++ b/databases/lua-resty-redis/pkg-descr
@@ -0,0 +1,8 @@
+This Lua library is a Redis client driver for the ngx_lua nginx module:
+
+http://wiki.nginx.org/HttpLuaModule
+
+This Lua library takes advantage of ngx_lua's cosocket API, which ensures 100%
+nonblocking behavior.
+
+WWW: https://github.com/openresty/lua-resty-redis
diff --git a/databases/lua-resty-redis/pkg-plist b/databases/lua-resty-redis/pkg-plist
new file mode 100644
index 000000000000..f82dce7c5765
--- /dev/null
+++ b/databases/lua-resty-redis/pkg-plist
@@ -0,0 +1 @@
+%%LUA_MODSHAREDIR%%/resty/redis.lua