aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-25 01:41:14 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-25 01:41:14 +0800
commit783d694a723e1af0fedba720361378d9ece14642 (patch)
treeb0ecd1760b9c4160ea05f7e090b191eef9b95a4f /databases
parentd2b8300b0be8dc58f2e2ee5e3e76bd6692099cd3 (diff)
downloadfreebsd-ports-gnome-783d694a723e1af0fedba720361378d9ece14642.tar.gz
freebsd-ports-gnome-783d694a723e1af0fedba720361378d9ece14642.tar.zst
freebsd-ports-gnome-783d694a723e1af0fedba720361378d9ece14642.zip
Add php71-memcache 3.0.8 (copied from php70-memcache)
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php71-memcache/Makefile34
-rw-r--r--databases/php71-memcache/distinfo3
-rw-r--r--databases/php71-memcache/pkg-descr8
-rw-r--r--databases/php71-memcache/pkg-plist1
5 files changed, 47 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 96187ad309b8..c2c4592989ec 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -634,6 +634,7 @@
SUBDIR += php70-sqlite3
SUBDIR += php71-dba
SUBDIR += php71-interbase
+ SUBDIR += php71-memcache
SUBDIR += php71-mysqli
SUBDIR += php71-odbc
SUBDIR += php71-pdo
diff --git a/databases/php71-memcache/Makefile b/databases/php71-memcache/Makefile
new file mode 100644
index 000000000000..3667fbea1bb7
--- /dev/null
+++ b/databases/php71-memcache/Makefile
@@ -0,0 +1,34 @@
+# Created by: Gerrit Beine <tux@pinguru.net>
+# $FreeBSD$
+
+PORTNAME= memcache
+PORTVERSION= 3.0.8
+PORTREVISION= 1
+CATEGORIES= databases
+PKGNAMEPREFIX= php71-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Memcached extension for PHP 7.1
+
+LICENSE= PHP30
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= EXAMPLES
+
+CONFIGURE_ARGS= --with-zlib-dir=/usr
+IGNORE_WITH_PHP=56 70
+PHP_VER= 71
+USE_CSTD= gnu89
+USE_PHP= session:build zlib:build
+USES= dos2unix php:ext
+
+GH_ACCOUNT= websupport-sk
+GH_PROJECT= pecl-${PORTNAME}
+GH_TAGNAME= 5041d2f
+USE_GITHUB= yes
+
+post-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/example.php ${STAGEDIR}${EXAMPLESDIR}/
+
+.include <bsd.port.mk>
diff --git a/databases/php71-memcache/distinfo b/databases/php71-memcache/distinfo
new file mode 100644
index 000000000000..4602941d9c6f
--- /dev/null
+++ b/databases/php71-memcache/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481566704
+SHA256 (websupport-sk-pecl-memcache-3.0.8-5041d2f_GH0.tar.gz) = b441255305e962cecfbb6e88501374a317aeb4dec706e3c2e7c780bb26bf5a96
+SIZE (websupport-sk-pecl-memcache-3.0.8-5041d2f_GH0.tar.gz) = 110448
diff --git a/databases/php71-memcache/pkg-descr b/databases/php71-memcache/pkg-descr
new file mode 100644
index 000000000000..92a3b7bbd5a6
--- /dev/null
+++ b/databases/php71-memcache/pkg-descr
@@ -0,0 +1,8 @@
+Memcached is a caching daemon designed especially for dynamic web applications
+to decrease database load by storing objects in memory. This extension allows
+you to work with memcached through handy OO and procedural interfaces.
+
+Note that this port uses unofficial development from
+https://github.com/websupport-sk/pecl-memcache (NON_BLOCKING_IO_php7 branch).
+
+WWW: https://pecl.php.net/package/memcache
diff --git a/databases/php71-memcache/pkg-plist b/databases/php71-memcache/pkg-plist
new file mode 100644
index 000000000000..5c859776e721
--- /dev/null
+++ b/databases/php71-memcache/pkg-plist
@@ -0,0 +1 @@
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.php