aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2006-09-21 23:14:21 +0800
committerknu <knu@FreeBSD.org>2006-09-21 23:14:21 +0800
commitb6b85dae57fffea9f530be8920e0be5c63f39fcf (patch)
tree36db336661f63ddd521fd28abca523ca4d5d9072 /databases
parent597a4f9b02ad84516113efddcb77b6b1a96341c7 (diff)
downloadfreebsd-ports-gnome-b6b85dae57fffea9f530be8920e0be5c63f39fcf.tar.gz
freebsd-ports-gnome-b6b85dae57fffea9f530be8920e0be5c63f39fcf.tar.zst
freebsd-ports-gnome-b6b85dae57fffea9f530be8920e0be5c63f39fcf.zip
Add a ad-hoc patch and unbreak.
The problem is in MySQL 5.0.24a, as addressed in the following bug report: http://bugs.mysql.com/bug.php?id=22227
Diffstat (limited to 'databases')
-rw-r--r--databases/ruby-mysql/Makefile4
-rw-r--r--databases/ruby-mysql/files/patch-mysql.c.in10
2 files changed, 11 insertions, 3 deletions
diff --git a/databases/ruby-mysql/Makefile b/databases/ruby-mysql/Makefile
index 7b7610487839..3f4452a3c347 100644
--- a/databases/ruby-mysql/Makefile
+++ b/databases/ruby-mysql/Makefile
@@ -16,13 +16,11 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= Ruby module for accessing MySQL databases with a C API like interface
-BROKEN= Does not compile
-
USE_MYSQL= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-CONFIGURE_ARGS= --with-mysql-dir="${LOCALBASE}"
+CONFIGURE_ARGS= --with-mysql-config
INSTALL_TARGET= site-install
post-install:
diff --git a/databases/ruby-mysql/files/patch-mysql.c.in b/databases/ruby-mysql/files/patch-mysql.c.in
new file mode 100644
index 000000000000..b9201b9ead72
--- /dev/null
+++ b/databases/ruby-mysql/files/patch-mysql.c.in
@@ -0,0 +1,10 @@
+--- mysql.c.in.orig Sun Jun 4 23:29:28 2006
++++ mysql.c.in Fri Sep 22 00:11:03 2006
+@@ -5,6 +5,7 @@
+ #include "ruby.h"
+ #include "version.h"
+ #ifdef HAVE_MYSQL_H
++#include <my_global.h>
+ #include <mysql.h>
+ #include <errmsg.h>
+ #include <mysqld_error.h>