aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-18 11:49:09 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-18 11:49:09 +0800
commitc0440bda6b4b10acfc2e9dcd34f689807f39e66e (patch)
tree011ecedd5c814f5703e586c87086601a7a0634a4 /databases
parentfef3d02fc15ae16547472eb1f71f009a47f998c0 (diff)
downloadfreebsd-ports-gnome-c0440bda6b4b10acfc2e9dcd34f689807f39e66e.tar.gz
freebsd-ports-gnome-c0440bda6b4b10acfc2e9dcd34f689807f39e66e.tar.zst
freebsd-ports-gnome-c0440bda6b4b10acfc2e9dcd34f689807f39e66e.zip
Mark ports broken on powerpc64, categories d-f.
While here, pet portlint and do some other cleanup. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'databases')
-rw-r--r--databases/fastdb/Makefile8
-rw-r--r--databases/galera/Makefile11
-rw-r--r--databases/hamsterdb/Makefile6
-rw-r--r--databases/postgresql-plruby/Makefile6
-rw-r--r--databases/rocksdb/Makefile3
5 files changed, 21 insertions, 13 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 9cf98e3e47b8..658b44686a61 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -12,9 +12,7 @@ COMMENT= Main Memory Relational Database Management System
LICENSE= MIT
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-OPTIONS_DEFINE= DOCS
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-std=gnu++03"
USES= gmake dos2unix
USE_GCC= any
@@ -24,6 +22,10 @@ USE_LDCONFIG= yes
DOS2UNIX_FILES= ${MAKEFILE}
CXXFLAGS+= -D_WANT_SEMUN
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= FastDB.htm
# The port does not build with C++11 or later (bug 219275).
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index 5d6659f6aa4c..56f759042f04 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -3,8 +3,8 @@
PORTNAME= galera
PORTVERSION?= 25.3.23
-PORTREVISION= 1
DISTVERSIONPREFIX?= release_
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= devel@galeracluster.com
@@ -12,15 +12,12 @@ COMMENT= Synchronous multi-master replication engine
LICENSE= GPLv2
-BUILD_DEPENDS= checkmk:devel/check \
- ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
-
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= check that SSL devel headers are installed and usable
BROKEN_aarch64= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
BROKEN_armv6= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
BROKEN_armv7= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
+BROKEN_powerpc64= fails to configure: Checking for C library pthread... no
NOT_FOR_ARCHS= i386
# On i386 older versions of clang produce:
# cannot compile this atomic library call yet ... __atomic_add_fetch
@@ -32,6 +29,10 @@ NOT_FOR_ARCHS= i386
# https://tracker.crystax.net/issues/1263
NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386
+BUILD_DEPENDS= checkmk:devel/check \
+ ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+
USES= python:build scons ssl
USE_LDCONFIG= yes
diff --git a/databases/hamsterdb/Makefile b/databases/hamsterdb/Makefile
index f5b21938ddd4..b602dd363bd5 100644
--- a/databases/hamsterdb/Makefile
+++ b/databases/hamsterdb/Makefile
@@ -12,14 +12,16 @@ COMMENT= Lightweight Embedded Database Engine
LICENSE= APACHE20
+BROKEN_powerpc64= fails to configure: checking for the Boost system library... no
+
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+USES= alias gmake libtool
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-boost=${LOCALBASE}
INSTALL_TARGET= install-strip
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-USES= alias gmake libtool
-USE_LDCONFIG= yes
HAM_DOCS= README INSTALL ChangeLog TODO AUTHORS CREDITS
diff --git a/databases/postgresql-plruby/Makefile b/databases/postgresql-plruby/Makefile
index 700afcca939c..2bd9e7f67c5d 100644
--- a/databases/postgresql-plruby/Makefile
+++ b/databases/postgresql-plruby/Makefile
@@ -13,14 +13,16 @@ COMMENT= PL/Ruby procedural language for the PostgreSQL database system
LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
-USE_GITHUB= yes
-GH_ACCOUNT= devrimgunduz
+BROKEN_powerpc64= fails to build: ruby.h:628:35: call to 'ruby_safe_level_2_error' declared with attribute error: $SAFE=2 to 4 are obsolete
USES= uidfix pgsql
WANT_PGSQL= server
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+USE_GITHUB= yes
+GH_ACCOUNT= devrimgunduz
+
POSTGRESQL_PORT?= databases/postgresql${PGSQL_VER_NODOT}-server
PGSQL_PORTDIR?= ${PORTSDIR}/${POSTGRESQL_PORT}
PGSQL_WRKSRC_CMD= cd ${PGSQL_PORTDIR} && ${MAKE} -V WRKSRC
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index 8e4f53081159..af13cb377217 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
BROKEN_DragonFly= does not build on DragonFly BSD using GCC with -Werror
BROKEN_armv6?= does not build: db/c.cc:2281:44: implicit conversion loses integer precision: 'uint64_t' (aka 'unsigned long long') to 'size_t' (aka 'unsigned int')
BROKEN_armv7?= does not build: /nxb-bin/usr/bin/ld: undefined reference to symbol `__gnu_Unwind_Find_exidx@@FBSD_1.4' (try adding -lc) #'`
+BROKEN_powerpc64= does not build: util/crc32c.cc:435:22: 'arch_ppc_probe' was not declared in this scope
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libgflags.so:devel/gflags \
@@ -25,6 +26,7 @@ LIB_DEPENDS= libgflags.so:devel/gflags \
OPTIONS_DEFINE= DEBUG LZ4 ZSTD
OPTIONS_DEFAULT=LZ4
+USES= compiler:c++11-lib gmake localbase:ldflags shebangfix
ALL_TARGET= shared_lib static_lib all
CFLAGS+= -DOS_FREEBSD
CONFIGURE_ARGS= make_config.mk
@@ -34,7 +36,6 @@ HAS_CONFIGURE= yes
MAKE_ENV= CXX=${CXX} INSTALL_PATH=${STAGEDIR}${PREFIX}
USE_CXXSTD= c++11
USE_LDCONFIG= yes
-USES= compiler:c++11-lib gmake localbase:ldflags shebangfix
PLIST_SUB= PORTVERSION=${PORTVERSION} SHLIB_MAJOR=${PORTVERSION:R:R} SHLIB_MINOR=${PORTVERSION:R:E}
PORTDATA= make_config.mk