aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
commitda74e1e2753beef93258c048d602476b4b4dfd7c (patch)
tree38d55d2134664c2fa5ec17aa6dadae38a1ec9e4f /databases
parent355f300440d2bd9dae6636ba5c8bf4eacacc9567 (diff)
downloadfreebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.gz
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.zst
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Diffstat (limited to 'databases')
-rw-r--r--databases/gnome-db/Makefile15
-rw-r--r--databases/gnome-db/files/patch-po::Makefile.in.in7
-rw-r--r--databases/gnome-db/pkg-plist1
-rw-r--r--databases/gnomedb/Makefile15
-rw-r--r--databases/gnomedb/files/patch-po::Makefile.in.in7
-rw-r--r--databases/gnomedb/pkg-plist1
-rw-r--r--databases/libgda/Makefile16
-rw-r--r--databases/libgda/files/patch-po::Makefile.in.in7
-rw-r--r--databases/libgda/pkg-plist1
9 files changed, 15 insertions, 55 deletions
diff --git a/databases/gnome-db/Makefile b/databases/gnome-db/Makefile
index f0a1ace2ae14..64f633ab3621 100644
--- a/databases/gnome-db/Makefile
+++ b/databases/gnome-db/Makefile
@@ -16,27 +16,20 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gda-client.0:${PORTSDIR}/databases/libgda
-
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier libgda
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-pthread -L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(GNOME_datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(GNOME_datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/databases/gnome-db/files/patch-po::Makefile.in.in b/databases/gnome-db/files/patch-po::Makefile.in.in
deleted file mode 100644
index 490f48af9f3f..000000000000
--- a/databases/gnome-db/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- po/Makefile.in.in.orig Fri Jun 15 15:38:54 2001
-+++ po/Makefile.in.in Tue Jun 19 02:37:06 2001
-@@ -25,3 +25,3 @@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po
diff --git a/databases/gnome-db/pkg-plist b/databases/gnome-db/pkg-plist
index 51f76bec637e..89b9103ae5d0 100644
--- a/databases/gnome-db/pkg-plist
+++ b/databases/gnome-db/pkg-plist
@@ -171,7 +171,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-db.mo
@dirrm share/gnome/help/gnome-db/C/images
@dirrm share/gnome/help/gnome-db/C
@dirrm share/gnome/help/gnome-db
-@dirrm share/gnome/apps/Applications
@dirrm share/doc/gnomedb
@dirrm include/libgnomedb-%%VERSION%%/gnome-db
@dirrm include/libgnomedb-%%VERSION%%
diff --git a/databases/gnomedb/Makefile b/databases/gnomedb/Makefile
index f0a1ace2ae14..64f633ab3621 100644
--- a/databases/gnomedb/Makefile
+++ b/databases/gnomedb/Makefile
@@ -16,27 +16,20 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gda-client.0:${PORTSDIR}/databases/libgda
-
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier libgda
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-pthread -L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(GNOME_datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(GNOME_datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/databases/gnomedb/files/patch-po::Makefile.in.in b/databases/gnomedb/files/patch-po::Makefile.in.in
deleted file mode 100644
index 490f48af9f3f..000000000000
--- a/databases/gnomedb/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- po/Makefile.in.in.orig Fri Jun 15 15:38:54 2001
-+++ po/Makefile.in.in Tue Jun 19 02:37:06 2001
-@@ -25,3 +25,3 @@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po
diff --git a/databases/gnomedb/pkg-plist b/databases/gnomedb/pkg-plist
index 51f76bec637e..89b9103ae5d0 100644
--- a/databases/gnomedb/pkg-plist
+++ b/databases/gnomedb/pkg-plist
@@ -171,7 +171,6 @@ share/locale/zh_TW/LC_MESSAGES/gnome-db.mo
@dirrm share/gnome/help/gnome-db/C/images
@dirrm share/gnome/help/gnome-db/C
@dirrm share/gnome/help/gnome-db
-@dirrm share/gnome/apps/Applications
@dirrm share/doc/gnomedb
@dirrm include/libgnomedb-%%VERSION%%/gnome-db
@dirrm include/libgnomedb-%%VERSION%%
diff --git a/databases/libgda/Makefile b/databases/libgda/Makefile
index 0fb8c4353fdf..8c799a3f1655 100644
--- a/databases/libgda/Makefile
+++ b/databases/libgda/Makefile
@@ -15,12 +15,12 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm \
- bonobo.2:${PORTSDIR}/devel/bonobo
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier gconf bonobo
USE_GMAKE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
@@ -30,12 +30,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|share/idl|share/gnome/idl|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|share/idl|share/gnome/idl|g'
.include <bsd.port.mk>
diff --git a/databases/libgda/files/patch-po::Makefile.in.in b/databases/libgda/files/patch-po::Makefile.in.in
deleted file mode 100644
index 3f425ffda3af..000000000000
--- a/databases/libgda/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- po/Makefile.in.in.orig Wed Jun 13 15:55:50 2001
-+++ po/Makefile.in.in Tue Jun 19 01:14:13 2001
-@@ -25,3 +25,3 @@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po
diff --git a/databases/libgda/pkg-plist b/databases/libgda/pkg-plist
index 60028e4563a1..e3b1215bb7f8 100644
--- a/databases/libgda/pkg-plist
+++ b/databases/libgda/pkg-plist
@@ -206,7 +206,6 @@ share/locale/uk/LC_MESSAGES/libgda.mo
@dirrm share/gnome/help/libgda
@dirrm share/gnome/gda/templates
@dirrm share/gnome/gda
-@dirrm share/doc/libgda
@dirrm include/libgda-%%VERSION%%/gda++
@dirrm include/libgda-%%VERSION%%/gda
@dirrm include/libgda-%%VERSION%%