aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-04-02 07:04:21 +0800
committermi <mi@FreeBSD.org>2002-04-02 07:04:21 +0800
commitfa72215cb62b30acf0e9b604f57d54f583deb3ad (patch)
tree19dc2eddfd80fe5b30c13b5ff7877f605ef6cb40 /databases
parent728a49d9addcb777cb96e88f3bc37ec2cc0c3436 (diff)
downloadfreebsd-ports-gnome-fa72215cb62b30acf0e9b604f57d54f583deb3ad.tar.gz
freebsd-ports-gnome-fa72215cb62b30acf0e9b604f57d54f583deb3ad.tar.zst
freebsd-ports-gnome-fa72215cb62b30acf0e9b604f57d54f583deb3ad.zip
Fix some bitrot for the non-default case of WITH_GETTEXT -- lib-depend
on -lintl instead of build-depending on msgfmt and make sure -lintl is linked into the shared -lpq. Approved by: maintainer
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-devel-server/Makefile3
-rw-r--r--databases/postgresql-devel/Makefile3
-rw-r--r--databases/postgresql7/Makefile3
-rw-r--r--databases/postgresql73-server/Makefile3
-rw-r--r--databases/postgresql73/Makefile3
-rw-r--r--databases/postgresql74-server/Makefile3
-rw-r--r--databases/postgresql80-server/Makefile3
-rw-r--r--databases/postgresql81-server/Makefile3
-rw-r--r--databases/postgresql82-server/Makefile3
-rw-r--r--databases/postgresql83-server/Makefile3
-rw-r--r--databases/postgresql84-server/Makefile3
-rw-r--r--databases/postgresql90-server/Makefile3
-rw-r--r--databases/postgresql91-server/Makefile3
-rw-r--r--databases/postgresql92-server/Makefile3
14 files changed, 28 insertions, 14 deletions
diff --git a/databases/postgresql-devel-server/Makefile b/databases/postgresql-devel-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql-devel-server/Makefile
+++ b/databases/postgresql-devel-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql-devel/Makefile b/databases/postgresql-devel/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql-devel/Makefile
+++ b/databases/postgresql-devel/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql7/Makefile b/databases/postgresql7/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql7/Makefile
+++ b/databases/postgresql7/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql73-server/Makefile b/databases/postgresql73-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql73-server/Makefile
+++ b/databases/postgresql73-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql73/Makefile b/databases/postgresql73/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql73/Makefile
+++ b/databases/postgresql73/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql74-server/Makefile b/databases/postgresql74-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql74-server/Makefile
+++ b/databases/postgresql74-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql80-server/Makefile b/databases/postgresql80-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql80-server/Makefile
+++ b/databases/postgresql80-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql81-server/Makefile b/databases/postgresql81-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql81-server/Makefile
+++ b/databases/postgresql81-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql82-server/Makefile b/databases/postgresql82-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql82-server/Makefile
+++ b/databases/postgresql82-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql83-server/Makefile
+++ b/databases/postgresql83-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index c00cfda1aef4..b6de1b047a54 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -56,8 +56,9 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
# libpq.so, including for example mod_php and tcl.
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+=--enable-nls
+CONFIGURE_ENV+= "LIBS=-lintl"
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-BUILD_DEPENDS+= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext-old
+LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext-old
PLIST_SUB+= GETTEXT=""
.else
PLIST_SUB+= GETTEXT="@comment "