aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2006-12-07 00:47:28 +0800
committergirgen <girgen@FreeBSD.org>2006-12-07 00:47:28 +0800
commit3bb60ebd9b328a37345cbd75dab65c4e0e50dbca (patch)
treeb5b45ce940783a8811f2b659f2dccf0ba400a2c9 /databases
parent6627d2a01a88446163b5892945d233a04079e1f6 (diff)
downloadfreebsd-ports-gnome-3bb60ebd9b328a37345cbd75dab65c4e0e50dbca.tar.gz
freebsd-ports-gnome-3bb60ebd9b328a37345cbd75dab65c4e0e50dbca.tar.zst
freebsd-ports-gnome-3bb60ebd9b328a37345cbd75dab65c4e0e50dbca.zip
More rubust regex to determine which version of postgresql that is
already installed.
Diffstat (limited to 'databases')
-rw-r--r--databases/p5-postgresql-plperl/Makefile2
-rw-r--r--databases/postgresql-plpython/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/databases/p5-postgresql-plperl/Makefile b/databases/p5-postgresql-plperl/Makefile
index f32cb1fdabf9..f523742d0c2a 100644
--- a/databases/p5-postgresql-plperl/Makefile
+++ b/databases/p5-postgresql-plperl/Makefile
@@ -26,7 +26,7 @@ SED?= /usr/bin/sed
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
-PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/postmaster.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
.elif exists(${LOCALBASE}/bin/pg_config)
PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
.else
diff --git a/databases/postgresql-plpython/Makefile b/databases/postgresql-plpython/Makefile
index 1acfa39b6e2a..d91a17955537 100644
--- a/databases/postgresql-plpython/Makefile
+++ b/databases/postgresql-plpython/Makefile
@@ -26,7 +26,7 @@ SED?= /usr/bin/sed
# Setting/finding PostgreSQL version we want.
.if exists(${LOCALBASE}/bin/postmaster)
-PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/postmaster.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
+PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
.elif exists(${LOCALBASE}/bin/pg_config)
PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
.else