aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-03-26 07:27:56 +0800
committermm <mm@FreeBSD.org>2010-03-26 07:27:56 +0800
commit52324628933608e5c4f62f0607040a96cc8da2b9 (patch)
treeadac4bf20522fe2f431705dfc6b0cca96b3c6512 /databases
parent9e559bc118e7dcf47eb96b66d3e98df925e0236a (diff)
downloadfreebsd-ports-gnome-52324628933608e5c4f62f0607040a96cc8da2b9.tar.gz
freebsd-ports-gnome-52324628933608e5c4f62f0607040a96cc8da2b9.tar.zst
freebsd-ports-gnome-52324628933608e5c4f62f0607040a96cc8da2b9.zip
- Use bsd.tcl.mk (implemented suggestion from [1])
- Use system-default PostgreSQL version (82) - Bump PORTREVISION PR: ports/143740 [1] Submitted by: Dan Lukes <dan@obluda.cz> Approved by: maintainer (timeout)
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-pltcl/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
index 0e2c6189caff..e8adabdcc7d2 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql-pltcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgresql
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases tcl
PKGNAMESUFFIX= -pltcl
@@ -16,9 +16,8 @@ COMMENT= A module for using Tcl to write SQL functions
MASTERDIR= ${.CURDIR}/../postgresql${PGSQL_VER}-server
RUN_DEPENDS= postgres:${MASTERDIR}
-LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
-DEFAULT_PGSQL_VER?=74
+DEFAULT_PGSQL_VER?=82
# can't include <bsd.port.pre.mk> in a slave port
# so set these instead:
@@ -34,15 +33,14 @@ PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]
PGSQL_VER= ${DEFAULT_PGSQL_VER}
.endif
-# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
-TCLVERSION?= 8.4
+# you can use "make WITH_TCL_VER=84" or similar for your favourite tcl version
+USE_TCL= 84+
CONFIGURE_ARGS= --with-tcl --without-tk \
- --with-tclconfig="${TCLCONFIG}" \
- --with-includes="${TCL_INCDIR}"
+ --with-tclconfig="${TCL_LIBDIR}" \
+ --with-includes="${TCL_INCLUDEDIR}"
-TCL_INCDIR= ${LOCALBASE}/include/tcl${TCLVERSION}
-TCLCONFIG= ${LOCALBASE}/lib/tcl${TCLVERSION}
-MAKE_ENV+= TCL_INCDIR=${TCL_INCDIR}
+CONFIGURE_ENV+= TCLSH="${TCLSH}"
+MAKE_ENV+= TCL_INCDIR="${TCL_INCLUDEDIR}"
BUILD_DIRS= src/pl/tcl
SLAVE_ONLY= yes