aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2014-12-04 01:05:04 +0800
committermatthew <matthew@FreeBSD.org>2014-12-04 01:05:04 +0800
commit6d186b467ce809073afb80865329e1884ad0bcab (patch)
tree408e72ecbe212008bb7ba6d7f4517bdda7c205da /databases
parent03c3ea9c4f9b7abbefd38db54b5ac8f0d3f4c918 (diff)
downloadfreebsd-ports-gnome-6d186b467ce809073afb80865329e1884ad0bcab.tar.gz
freebsd-ports-gnome-6d186b467ce809073afb80865329e1884ad0bcab.tar.zst
freebsd-ports-gnome-6d186b467ce809073afb80865329e1884ad0bcab.zip
- Install man pages to a location where man(1) can find them
- While here update man pages and speciment barman.conf file to use FreeBSD-ish locations for various things, particularly that our idea of the PostgreSQL default user is 'pgsql' although the database to connect to is 'postgres'
Diffstat (limited to 'databases')
-rw-r--r--databases/pgbarman/Makefile1
-rw-r--r--databases/pgbarman/files/patch-barman_config.py6
-rw-r--r--databases/pgbarman/files/patch-doc_barman.551
-rw-r--r--databases/pgbarman/files/patch-doc_barman.conf35
-rw-r--r--databases/pgbarman/files/patch-setup.py13
5 files changed, 103 insertions, 3 deletions
diff --git a/databases/pgbarman/Makefile b/databases/pgbarman/Makefile
index 89ca38b12233..5ba45c45ee21 100644
--- a/databases/pgbarman/Makefile
+++ b/databases/pgbarman/Makefile
@@ -3,6 +3,7 @@
PORTNAME= barman
DISTVERSION= 1.3.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= SF/${PKGNAMEPREFIX}${PORTNAME}/${DISTVERSION}
PKGNAMEPREFIX= pg
diff --git a/databases/pgbarman/files/patch-barman_config.py b/databases/pgbarman/files/patch-barman_config.py
index b460dd23ad4c..96f47b025ba6 100644
--- a/databases/pgbarman/files/patch-barman_config.py
+++ b/databases/pgbarman/files/patch-barman_config.py
@@ -1,4 +1,4 @@
---- barman/config.py.orig 2014-12-02 14:47:11 UTC
+--- barman/config.py.orig 2014-08-01 13:50:46 UTC
+++ barman/config.py
@@ -341,8 +341,8 @@ class Config(object):
"""
@@ -6,8 +6,8 @@
'~/.barman.conf',
- '/etc/barman.conf',
- '/etc/barman/barman.conf',
-+ '%%PREFIX%%/etc/barman.conf',
-+ '%%PREFIX%%/etc/barman/barman.conf',
++ '/usr/local/etc/barman.conf',
++ '/usr/local/etc/barman/barman.conf',
]
_QUOTE_RE = re.compile(r"""^(["'])(.*)\1$""")
diff --git a/databases/pgbarman/files/patch-doc_barman.5 b/databases/pgbarman/files/patch-doc_barman.5
new file mode 100644
index 000000000000..2f48ff3e4a42
--- /dev/null
+++ b/databases/pgbarman/files/patch-doc_barman.5
@@ -0,0 +1,51 @@
+--- doc/barman.5.orig 2014-08-18 10:29:45 UTC
++++ doc/barman.5
+@@ -37,7 +37,7 @@ The system\-level Barman configuration f
+ .RS 4
+ .\}
+ .nf
+-/etc/barman\&.conf
++/usr/local/etc/barman\&.conf
+ .fi
+ .if n \{\
+ .RE
+@@ -49,7 +49,7 @@ or
+ .RS 4
+ .\}
+ .nf
+-/etc/barman/barman\&.conf
++/usr/local/etc/barman/barman\&.conf
+ .fi
+ .if n \{\
+ .RE
+@@ -71,7 +71,7 @@ $HOME/\&.barman\&.conf
+ The Barman configuration file is a plain ini file\&. There is a general section called [barman] and a section [servername] for each server you want to backup\&. Rows starting with ; are comments\&.
+ .SH "CONFIGURATION FILE DIRECTORY"
+ .sp
+-Barman supports the inclusion of multiple configuration files, through the configuration_files_directory option\&. Included files must contain only server specifications, not global configurations\&. If the value of configuration_files_directory is a directory, Barman reads all files with \&.conf extension that exist in that folder\&. For example, if you set it to /etc/barman\&.d, you can specify your PostgreSQL servers placing each section in a separate \&.conf file inside the /etc/barman\&.d folder\&.
++Barman supports the inclusion of multiple configuration files, through the configuration_files_directory option\&. Included files must contain only server specifications, not global configurations\&. If the value of configuration_files_directory is a directory, Barman reads all files with \&.conf extension that exist in that folder\&. For example, if you set it to /usr/local/etc/barman\&.d, you can specify your PostgreSQL servers placing each section in a separate \&.conf file inside the /usr/local/etc/barman\&.d folder\&.
+ .SH "OPTIONS"
+ .PP
+ \fBactive\fR
+@@ -322,7 +322,7 @@ Example of the configuration file:
+ .nf
+ [barman]
+ ; Main directory
+-barman_home = /var/lib/barman
++barman_home = /var/barman
+
+ ; System user
+ barman_user = barman
+@@ -339,10 +339,10 @@ log_file = /var/log/barman/barman\&.log
+ description = "Main PostgreSQL Database"
+
+ ; SSH options
+-ssh_command = ssh postgres@pg
++ssh_command = ssh pgsql@pg
+
+ ; PostgreSQL connection string
+-conninfo = host=pg user=postgres
++conninfo = host=pg user=pgsql dbname=postgres
+
+ ; Minimum number of required backups (redundancy)
+ minimum_redundancy = 1
diff --git a/databases/pgbarman/files/patch-doc_barman.conf b/databases/pgbarman/files/patch-doc_barman.conf
new file mode 100644
index 000000000000..8a68151e413f
--- /dev/null
+++ b/databases/pgbarman/files/patch-doc_barman.conf
@@ -0,0 +1,35 @@
+--- doc/barman.conf.orig 2014-08-18 10:29:45 UTC
++++ doc/barman.conf
+@@ -5,7 +5,7 @@
+
+ [barman]
+ ; Main directory
+-barman_home = /var/lib/barman
++barman_home = /var/barman
+
+ ; System user
+ barman_user = barman
+@@ -25,8 +25,8 @@ log_file = /var/log/barman/barman.log
+ ;post_archive_script = env | grep ^BARMAN
+
+ ; Directory of configuration files. Place your sections in separate files with .conf extension
+-; For example place the 'main' server section in /etc/barman.d/main.conf
+-;configuration_files_directory = /etc/barman.d
++; For example place the 'main' server section in /usr/local/etc/barman.d/main.conf
++;configuration_files_directory = /usr/local/etc/barman.d
+
+ ; Minimum number of required backups (redundancy) - default 0
+ ;minimum_redundancy = 0
+@@ -68,10 +68,10 @@ log_file = /var/log/barman/barman.log
+ ;; description = "Main PostgreSQL Database"
+ ;;
+ ;; ; SSH options
+-;; ssh_command = ssh postgres@pg
++;; ssh_command = ssh pgsql@pg
+ ;;
+ ;; ; PostgreSQL connection string
+-;; conninfo = host=pg user=postgres
++;; conninfo = host=pg user=pgsql dbname=postgres
+ ;;
+ ;; ; Minimum number of required backups (redundancy)
+ ;; ; minimum_redundancy = 1
diff --git a/databases/pgbarman/files/patch-setup.py b/databases/pgbarman/files/patch-setup.py
new file mode 100644
index 000000000000..44688563e9be
--- /dev/null
+++ b/databases/pgbarman/files/patch-setup.py
@@ -0,0 +1,13 @@
+--- setup.py.orig 2014-12-03 15:50:50 UTC
++++ setup.py
+@@ -74,8 +74,8 @@ setup(
+ packages=['barman', ],
+ scripts=['bin/barman', ],
+ data_files=[
+- ('share/man/man1', ['doc/barman.1']),
+- ('share/man/man5', ['doc/barman.5']),
++ ('man/man1', ['doc/barman.1']),
++ ('man/man5', ['doc/barman.5']),
+ ],
+ license='GPL-3.0',
+ description=__doc__.split("\n")[0],