aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2011-02-03 01:24:59 +0800
committerskreuzer <skreuzer@FreeBSD.org>2011-02-03 01:24:59 +0800
commit703021579917fd32943b03d60965cceb343ee332 (patch)
tree8f9b1f6901470b10e1cbad3d325a213eebeb405d /databases
parent73d59ca9f9b94f88a6c7e1c1c76eb15a9d1b213e (diff)
downloadfreebsd-ports-gnome-703021579917fd32943b03d60965cceb343ee332.tar.gz
freebsd-ports-gnome-703021579917fd32943b03d60965cceb343ee332.tar.zst
freebsd-ports-gnome-703021579917fd32943b03d60965cceb343ee332.zip
Credis is a client library in plain C for communicating with Redis servers
Feature safe: yes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/credis/Makefile21
-rw-r--r--databases/credis/distinfo2
-rw-r--r--databases/credis/files/patch-Makefile50
-rw-r--r--databases/credis/files/patch-credis.c12
-rw-r--r--databases/credis/pkg-descr3
-rw-r--r--databases/credis/pkg-plist6
7 files changed, 95 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 45ba80e2912e..50868b5afe03 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -28,6 +28,7 @@
SUBDIR += courier-authlib-pgsql
SUBDIR += courier-authlib-userdb
SUBDIR += courier-authlib-usergdbm
+ SUBDIR += credis
SUBDIR += cyrus-imspd
SUBDIR += dalmp
SUBDIR += db
diff --git a/databases/credis/Makefile b/databases/credis/Makefile
new file mode 100644
index 000000000000..7634995302fe
--- /dev/null
+++ b/databases/credis/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: credis
+# Date created: 2011-02-02
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= credis
+PORTVERSION= 0.2.3
+CATEGORIES= databases
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Library for communicating with Redis servers
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/databases/credis/distinfo b/databases/credis/distinfo
new file mode 100644
index 000000000000..204c198f84a0
--- /dev/null
+++ b/databases/credis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (credis-0.2.3.tar.gz) = d9ab904be07865bd159ab44ebc45ef1dae71071842a5b7dec321b09c13a770d0
+SIZE (credis-0.2.3.tar.gz) = 17265
diff --git a/databases/credis/files/patch-Makefile b/databases/credis/files/patch-Makefile
new file mode 100644
index 000000000000..e60106725ac2
--- /dev/null
+++ b/databases/credis/files/patch-Makefile
@@ -0,0 +1,50 @@
+--- Makefile.orig 2010-08-27 04:57:25.000000000 -0400
++++ Makefile 2011-02-02 11:38:11.000000000 -0500
+@@ -1,7 +1,21 @@
+-CFLAGS = -g -O2 -Wall
+-LDFLAGS =
++CFLAGS ?= -g -O2 -Wall
++LDFLAGS ?=
+ #CPPFLAGS = -DPRINTDEBUG
+
++VER_MAJOR = 0
++VER_MINOR = 2
++VER_PATCH = 3
++VER=$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH)
++
++prefix ?= /usr/local
++libdir = $(prefix)/lib
++includedir = $(prefix)/include
++DESTDIR ?=
++INSTALL ?= /usr/bin/install -c
++MKDIR_P ?= /bin/mkdir -p
++CP ?= /bin/cp -f
++LN ?= /bin/ln -fs
++
+ # build shared lib under OS X or Linux
+ OS = $(shell uname -s)
+ ifeq ($(OS),Darwin)
+@@ -22,12 +36,19 @@
+ $(AR) -cvq $@ $^
+
+ libcredis.so: credis.o
+- $(CC) $(SHAREDLIB_LINK_OPTIONS)$@ -o $@ $^
++ $(CC) $(SHAREDLIB_LINK_OPTIONS)$@.$(VER_MAJOR) -o $@.$(VER) $^
++ $(LN) $@.$(VER) $@.$(VER_MAJOR)
++ $(LN) $@.$(VER_MAJOR) $@
+
+ credis.o: credis.c credis.h Makefile
+ $(CC) -c -fPIC $(CFLAGS) $(CPPFLAGS) -o $@ credis.c
+
+-install:
+- @echo "Installing library (to be done)"
++install: all installdirs
++ $(INSTALL) -m644 *.h $(DESTDIR)$(includedir)
++ $(CP) *.so* *.a $(DESTDIR)$(libdir)
++
++installdirs:
++ $(MKDIR_P) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
++
+ clean:
+- rm -f *.o *~ $(TARGETS)
++ rm -f *.o *~ *.so* $(TARGETS)
diff --git a/databases/credis/files/patch-credis.c b/databases/credis/files/patch-credis.c
new file mode 100644
index 000000000000..2cc3accf657c
--- /dev/null
+++ b/databases/credis/files/patch-credis.c
@@ -0,0 +1,12 @@
+--- credis.c.orig 2011-02-02 09:38:06.000000000 -0500
++++ credis.c 2011-02-02 09:38:37.000000000 -0500
+@@ -34,6 +34,9 @@
+ #define WIN32_LEAN_AND_MEAN
+ #include <winsock2.h>
+ #else
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <fcntl.h>
diff --git a/databases/credis/pkg-descr b/databases/credis/pkg-descr
new file mode 100644
index 000000000000..819de2708a07
--- /dev/null
+++ b/databases/credis/pkg-descr
@@ -0,0 +1,3 @@
+Credis is a client library in plain C for communicating with Redis servers.
+
+WWW: http://code.google.com/p/credis/
diff --git a/databases/credis/pkg-plist b/databases/credis/pkg-plist
new file mode 100644
index 000000000000..60426048b139
--- /dev/null
+++ b/databases/credis/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+include/credis.h
+lib/libcredis.a
+lib/libcredis.so
+lib/libcredis.so.0
+lib/libcredis.so.%%VERSION%%