aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-02-02 22:23:11 +0800
committergabor <gabor@FreeBSD.org>2007-02-02 22:23:11 +0800
commit86906c4dfb4e25cfecdefb01ebc22323c5654375 (patch)
tree7e03ffa7be9f191fc91620d883bab562f008e96d /databases
parented835561e687b74a167d98501b7a590347ae975a (diff)
downloadfreebsd-ports-gnome-86906c4dfb4e25cfecdefb01ebc22323c5654375.tar.gz
freebsd-ports-gnome-86906c4dfb4e25cfecdefb01ebc22323c5654375.tar.zst
freebsd-ports-gnome-86906c4dfb4e25cfecdefb01ebc22323c5654375.zip
nspostgres is an internal PostgreSQL database driver for AOLserver 3.x and 4.x.
WWW: http://www.aolserver.com/ - Martin Matuska martin@matuska.org PR: ports/105781 Submitted by: Martin Matuska <martin@matuska.org> Approved by: erwin (mentor)
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/aolserver-nspostgres/Makefile46
-rw-r--r--databases/aolserver-nspostgres/distinfo3
-rw-r--r--databases/aolserver-nspostgres/pkg-descr6
-rw-r--r--databases/aolserver-nspostgres/pkg-plist3
5 files changed, 59 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 4cb6958bdb8b..f351954b5a7f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -9,6 +9,7 @@
SUBDIR += animenfo-client
SUBDIR += animenfo-client-gtk
SUBDIR += aolserver-nsmysql
+ SUBDIR += aolserver-nspostgres
SUBDIR += bbdb
SUBDIR += bbdb-emacs20
SUBDIR += cdb
diff --git a/databases/aolserver-nspostgres/Makefile b/databases/aolserver-nspostgres/Makefile
new file mode 100644
index 000000000000..6acc3055ab76
--- /dev/null
+++ b/databases/aolserver-nspostgres/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: aolserver-nspostgres
+# Date created: 12 Oct 2006
+# Whom: Martin Matuska <martin@matuska.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aolserver-nspostgres
+PORTVERSION= 4.0
+CATEGORIES= databases www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= aolserver
+DISTFILES= nspostgres-${PORTVERSION}.tar.gz
+DIST_SUBDIR= aolserver
+
+MAINTAINER= martin@matuska.org
+COMMENT= Internal PostgreSQL driver for AOLserver
+
+WRKSRC= ${WRKDIR}/nspostgres-${PORTVERSION}
+
+AOLSERVERBASE?= ${PREFIX}/aolserver
+BUILD_DEPENDS+= ${AOLSERVERBASE}/bin/nsd:${PORTSDIR}/www/aolserver
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+PLIST_SUB+= AOLSERVERBASE=${AOLSERVERBASE:S/${PREFIX}\///}
+
+USE_PGSQL= yes
+USE_GMAKE= yes
+
+MAKE_ARGS= AOLSERVER=${AOLSERVERBASE} POSTGRES=${LOCALBASE} ACS=1
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog README
+.endif
+
+post-patch:
+ @ ${REINPLACE_CMD} -e 's|OBJS|MODOBJS|' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ @ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/aolserver-nspostgres/distinfo b/databases/aolserver-nspostgres/distinfo
new file mode 100644
index 000000000000..f7b68a2730ec
--- /dev/null
+++ b/databases/aolserver-nspostgres/distinfo
@@ -0,0 +1,3 @@
+MD5 (aolserver/nspostgres-4.0.tar.gz) = ce53fe8231fdd72a114e594d0cdb7629
+SHA256 (aolserver/nspostgres-4.0.tar.gz) = ac428dad695414d439f2685b2ad8619ccccd667d517d1a044a45a343a21f562a
+SIZE (aolserver/nspostgres-4.0.tar.gz) = 20960
diff --git a/databases/aolserver-nspostgres/pkg-descr b/databases/aolserver-nspostgres/pkg-descr
new file mode 100644
index 000000000000..20efafa20cd2
--- /dev/null
+++ b/databases/aolserver-nspostgres/pkg-descr
@@ -0,0 +1,6 @@
+nspostgres is an internal PostgreSQL database driver for AOLserver 3.x and 4.x.
+
+WWW: http://www.aolserver.com/
+
+- Martin Matuska
+martin@matuska.org
diff --git a/databases/aolserver-nspostgres/pkg-plist b/databases/aolserver-nspostgres/pkg-plist
new file mode 100644
index 000000000000..0bea83cae21e
--- /dev/null
+++ b/databases/aolserver-nspostgres/pkg-plist
@@ -0,0 +1,3 @@
+%%AOLSERVERBASE%%/bin/nspostgres.so
+%%AOLSERVERBASE%%/lib/libnspostgres.a
+%%AOLSERVERBASE%%/lib/libnspostgres.so