aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-21 17:01:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-21 17:01:06 +0800
commitfbdc46efa68ca1f11344f9504c513dfc22dcc204 (patch)
treec7720d8e1f941eed79ea020069b7130393ddc89e /databases
parent70a9317f84f856ea7790f27c4e185470fe384522 (diff)
downloadfreebsd-ports-gnome-fbdc46efa68ca1f11344f9504c513dfc22dcc204.tar.gz
freebsd-ports-gnome-fbdc46efa68ca1f11344f9504c513dfc22dcc204.tar.zst
freebsd-ports-gnome-fbdc46efa68ca1f11344f9504c513dfc22dcc204.zip
- Update to 1.2.20111114
Changes: http://code.google.com/p/leveldb/source/list http://code.google.com/p/leveldb/source/detail?r=42fb47f6edab02d4abb814631c6615dd4661d7d2 http://code.google.com/p/leveldb/source/detail?r=36a5f8ed7f9fb3373236d5eace4f5fea369856ee Feature safe: yes
Diffstat (limited to 'databases')
-rw-r--r--databases/leveldb/Makefile3
-rw-r--r--databases/leveldb/distinfo4
-rw-r--r--databases/leveldb/files/patch-Makefile27
3 files changed, 11 insertions, 23 deletions
diff --git a/databases/leveldb/Makefile b/databases/leveldb/Makefile
index 71cafc92912e..292d150df14b 100644
--- a/databases/leveldb/Makefile
+++ b/databases/leveldb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= leveldb
-PORTVERSION= 1.2.20111024
-PORTREVISION= 1
+PORTVERSION= 1.2.20111114
CATEGORIES= databases
MASTER_SITES= LOCAL/sunpoet
diff --git a/databases/leveldb/distinfo b/databases/leveldb/distinfo
index cb201e1d3190..99168b5ff9b5 100644
--- a/databases/leveldb/distinfo
+++ b/databases/leveldb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (leveldb-1.2.20111024.tar.xz) = bf035a366f6a6839b0abd2afa33d17a96a50f1a25c72784c4bbcd19100510313
-SIZE (leveldb-1.2.20111024.tar.xz) = 142316
+SHA256 (leveldb-1.2.20111114.tar.xz) = 139ad4936168c9560d96fe374175808d2bfbeee3aa4b619bd16737b5c4c01fc4
+SIZE (leveldb-1.2.20111114.tar.xz) = 143072
diff --git a/databases/leveldb/files/patch-Makefile b/databases/leveldb/files/patch-Makefile
index 8909a0f7e5d5..72826e21186b 100644
--- a/databases/leveldb/files/patch-Makefile
+++ b/databases/leveldb/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2011-10-24 18:02:13.000000000 +0800
-+++ Makefile 2011-10-28 19:12:16.103454748 +0800
-@@ -2,13 +2,13 @@
+--- Makefile.orig 2011-11-21 14:58:22.000000000 +0800
++++ Makefile 2011-11-21 15:12:50.189222302 +0800
+@@ -2,7 +2,7 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file. See the AUTHORS file for names of contributors.
@@ -9,26 +9,16 @@
#-----------------------------------------------
# Uncomment exactly one of the lines labelled (A), (B), and (C) below
- # to switch between compilation modes.
-
--OPT = -O2 -DNDEBUG # (A) Production use (optimized mode)
-+OPT ?= -O2 -DNDEBUG # (A) Production use (optimized mode)
- # OPT = -g2 # (B) Debug mode, w/ full line-level debugging symbols
- # OPT = -O2 -g2 -DNDEBUG # (C) Profiling mode: opt, but w/debugging symbols
- #-----------------------------------------------
-@@ -36,9 +36,9 @@
+@@ -36,7 +36,7 @@
GOOGLE_PERFTOOLS_LDFLAGS=
endif
-CFLAGS = -c -I. -I./include $(PORT_CFLAGS) $(PLATFORM_CFLAGS) $(OPT) $(SNAPPY_CFLAGS)
-+CFLAGS += -c -fPIC -I. -I./include $(PORT_CFLAGS) $(PLATFORM_CFLAGS) $(OPT) $(SNAPPY_CFLAGS)
++CFLAGS += -c -I. -I./include $(PORT_CFLAGS) $(PLATFORM_CFLAGS) $(OPT) $(SNAPPY_CFLAGS) -fPIC
--LDFLAGS=$(PLATFORM_LDFLAGS) $(SNAPPY_LDFLAGS) $(GOOGLE_PERFTOOLS_LDFLAGS)
-+LDFLAGS += $(PLATFORM_LDFLAGS) $(SNAPPY_LDFLAGS) $(GOOGLE_PERFTOOLS_LDFLAGS)
+ LDFLAGS += $(PLATFORM_LDFLAGS) $(SNAPPY_LDFLAGS) $(GOOGLE_PERFTOOLS_LDFLAGS)
- LIBOBJECTS = \
- ./db/builder.o \
-@@ -103,15 +103,19 @@
+@@ -103,15 +103,18 @@
BENCHMARKS = db_bench_sqlite3 db_bench_tree_db
LIBRARY = libleveldb.a
@@ -38,7 +28,6 @@
-all: $(LIBRARY)
+SHARED_LIBOBJECTS = $(LIBOBJECTS:.o=.so)
-+
+all: $(LIBRARY) $(SHARED_LIBRARY)
check: $(PROGRAMS) $(TESTS)
@@ -50,7 +39,7 @@
-rm -rf ios-x86/* ios-arm/*
-rm build_config.mk
-@@ -119,6 +123,10 @@
+@@ -119,6 +122,10 @@
rm -f $@
$(AR) -rs $@ $(LIBOBJECTS)