aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2012-01-02 15:35:20 +0800
committerkuriyama <kuriyama@FreeBSD.org>2012-01-02 15:35:20 +0800
commit064f7f3ae08241bd47900e29ff675063024695cf (patch)
tree6b2d4a003854c84e66e32fe1bfe0c82e6ce3083e /databases
parentf2acaa800f139bdce46aa88bdc23b79555ea9556 (diff)
downloadfreebsd-ports-gnome-064f7f3ae08241bd47900e29ff675063024695cf.tar.gz
freebsd-ports-gnome-064f7f3ae08241bd47900e29ff675063024695cf.tar.zst
freebsd-ports-gnome-064f7f3ae08241bd47900e29ff675063024695cf.zip
DBIx::QueryLog is logs each execution time and the actual query.
Currently, works on DBD::mysql and DBD::sqlite. WWW: http://search.cpan.org/dist/DBIx-QueryLog/
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-QueryLog/Makefile25
-rw-r--r--databases/p5-DBIx-QueryLog/distinfo2
-rw-r--r--databases/p5-DBIx-QueryLog/pkg-descr5
-rw-r--r--databases/p5-DBIx-QueryLog/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index eb6d21a87659..95b6d8426798 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -371,6 +371,7 @@
SUBDIR += p5-DBIx-NoSQL
SUBDIR += p5-DBIx-Password
SUBDIR += p5-DBIx-Perlish
+ SUBDIR += p5-DBIx-QueryLog
SUBDIR += p5-DBIx-Recordset
SUBDIR += p5-DBIx-RetryOverDisconnects
SUBDIR += p5-DBIx-SQLEngine
diff --git a/databases/p5-DBIx-QueryLog/Makefile b/databases/p5-DBIx-QueryLog/Makefile
new file mode 100644
index 000000000000..6ad911a830f7
--- /dev/null
+++ b/databases/p5-DBIx-QueryLog/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: DBIx::QueryLog
+# Date created: 02 Jan 2012
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-QueryLog
+PORTVERSION= 0.24
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for logging queries for DBI
+
+RUN_DEPENDS= \
+ p5-DBI>0:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::QueryLog.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-QueryLog/distinfo b/databases/p5-DBIx-QueryLog/distinfo
new file mode 100644
index 000000000000..45fb8f724b3f
--- /dev/null
+++ b/databases/p5-DBIx-QueryLog/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-QueryLog-0.24.tar.gz) = 74378e65e9ab18b181f132249b64ca666e585b7dfbc1fdd947112fe16898454f
+SIZE (DBIx-QueryLog-0.24.tar.gz) = 31071
diff --git a/databases/p5-DBIx-QueryLog/pkg-descr b/databases/p5-DBIx-QueryLog/pkg-descr
new file mode 100644
index 000000000000..12f241360383
--- /dev/null
+++ b/databases/p5-DBIx-QueryLog/pkg-descr
@@ -0,0 +1,5 @@
+DBIx::QueryLog is logs each execution time and the actual query.
+
+Currently, works on DBD::mysql and DBD::sqlite.
+
+WWW: http://search.cpan.org/dist/DBIx-QueryLog/
diff --git a/databases/p5-DBIx-QueryLog/pkg-plist b/databases/p5-DBIx-QueryLog/pkg-plist
new file mode 100644
index 000000000000..b4d92c2f98aa
--- /dev/null
+++ b/databases/p5-DBIx-QueryLog/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/QueryLog/.packlist
+%%SITE_PERL%%/DBIx/QueryLog.pm
+@dirrmtry %%SITE_PERL%%/DBIx
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/QueryLog
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx