aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-01-04 15:22:15 +0800
committermiwi <miwi@FreeBSD.org>2016-01-04 15:22:15 +0800
commit1203b0729c62e7283a4427ff2d0383a0e423056c (patch)
tree37f2400eb40fb846a57c3111886e69734a8372c1 /databases
parent14351cc06942eb1de682752d4bfa381b2f74b69a (diff)
downloadfreebsd-ports-gnome-1203b0729c62e7283a4427ff2d0383a0e423056c.tar.gz
freebsd-ports-gnome-1203b0729c62e7283a4427ff2d0383a0e423056c.tar.zst
freebsd-ports-gnome-1203b0729c62e7283a4427ff2d0383a0e423056c.zip
PickleShare - a small 'shelve' like datastore with concurrency support
Like shelve, a PickleShareDB object acts like a normal dictionary. Unlike shelve, many processes can access the database simultaneously. Changing a value in database is immediately visible to other processes accessing the same database. WWW: https://github.com/vivainio/pickleshare/ PR: 205514 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-pickleshare/Makefile21
-rw-r--r--databases/py-pickleshare/distinfo2
-rw-r--r--databases/py-pickleshare/pkg-descr8
4 files changed, 32 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index bce53211e531..ffe508c2ce7f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -744,6 +744,7 @@
SUBDIR += py-pgspecial
SUBDIR += py-pgxnclient
SUBDIR += py-pickledb
+ SUBDIR += py-pickleshare
SUBDIR += py-postgresql
SUBDIR += py-psycogreen
SUBDIR += py-psycopg
diff --git a/databases/py-pickleshare/Makefile b/databases/py-pickleshare/Makefile
new file mode 100644
index 000000000000..afc325b58d6c
--- /dev/null
+++ b/databases/py-pickleshare/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pickleshare
+PORTVERSION= 0.5
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Tiny shelve-like database with concurrency support
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}path.py>0:${PORTSDIR}/devel/py-path.py
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/databases/py-pickleshare/distinfo b/databases/py-pickleshare/distinfo
new file mode 100644
index 000000000000..9c4b05109d16
--- /dev/null
+++ b/databases/py-pickleshare/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pickleshare-0.5.tar.gz) = c0be5745035d437dbf55a96f60b7712345b12423f7d0951bd7d8dc2141ca9286
+SIZE (pickleshare-0.5.tar.gz) = 4441
diff --git a/databases/py-pickleshare/pkg-descr b/databases/py-pickleshare/pkg-descr
new file mode 100644
index 000000000000..50df4d159e8f
--- /dev/null
+++ b/databases/py-pickleshare/pkg-descr
@@ -0,0 +1,8 @@
+PickleShare - a small 'shelve' like datastore with concurrency support
+
+Like shelve, a PickleShareDB object acts like a normal dictionary.
+Unlike shelve, many processes can access the database simultaneously.
+Changing a value in database is immediately visible to other processes
+accessing the same database.
+
+WWW: https://github.com/vivainio/pickleshare/