aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorandrew <andrew@FreeBSD.org>2015-11-09 17:29:07 +0800
committerandrew <andrew@FreeBSD.org>2015-11-09 17:29:07 +0800
commit2e40d0ac4cd8748417783248d69bab99094d7cb5 (patch)
treec6905291b86b99121a298a1ce57415411c9ffefc /databases
parent312ac5a51d7f3ffe4c3731d4b72f5e412d31760c (diff)
downloadfreebsd-ports-gnome-2e40d0ac4cd8748417783248d69bab99094d7cb5.tar.gz
freebsd-ports-gnome-2e40d0ac4cd8748417783248d69bab99094d7cb5.tar.zst
freebsd-ports-gnome-2e40d0ac4cd8748417783248d69bab99094d7cb5.zip
As with armv6 we need to use POSIX mutexes. Without this the ports try to
use fcntl mutexes and fails as they are deprecated. Approved by: mandree (maintainer) Differential Revision: https://reviews.freebsd.org/D4107
Diffstat (limited to 'databases')
-rw-r--r--databases/db48/Makefile2
-rw-r--r--databases/db5/Makefile2
-rw-r--r--databases/db6/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index d8e5c39b1085..3e010b76e8f9 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -35,7 +35,7 @@ USE_LDCONFIG= yes
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db48 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
.endif
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 822a53846031..95187b664bc1 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -39,7 +39,7 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db5 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
.endif
diff --git a/databases/db6/Makefile b/databases/db6/Makefile
index 2c9f3312a047..f5d648573d6f 100644
--- a/databases/db6/Makefile
+++ b/databases/db6/Makefile
@@ -40,7 +40,7 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db6 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
.endif