aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
committeraz <az@FreeBSD.org>2013-08-03 02:21:05 +0800
commit4539b36e07dc5d3a00796c31225b2da419544ef0 (patch)
tree59a0148ef943ecb5bc12a830cc669c801d3c91f8 /databases
parenta7f25a26617517dba99672639956e265390f576a (diff)
downloadfreebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.gz
freebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.tar.zst
freebsd-ports-gnome-4539b36e07dc5d3a00796c31225b2da419544ef0.zip
- Convert to new perl framework
Diffstat (limited to 'databases')
-rw-r--r--databases/WWWdb/Makefile3
-rw-r--r--databases/p5-CDB_File-Generator/Makefile3
-rw-r--r--databases/p5-Class-DBI-mysql/Makefile3
-rw-r--r--databases/p5-DBD-cego/Makefile3
-rw-r--r--databases/p5-DBIx-AnyDBD/Makefile3
-rw-r--r--databases/p5-DBIx-Class-ResultSet-HashRef/Makefile3
-rw-r--r--databases/p5-DBIx-Password/Makefile3
-rw-r--r--databases/p5-DBIx-SQLEngine/Makefile3
-rw-r--r--databases/p5-DBIx-SQLite-Simple/Makefile3
-rw-r--r--databases/p5-DBIx-XML_RDB/Makefile3
-rw-r--r--databases/p5-Iterator-DBI/Makefile3
-rw-r--r--databases/p5-Metadata/Makefile3
-rw-r--r--databases/p5-ORLite-Migrate/Makefile3
-rw-r--r--databases/p5-T2/Makefile3
-rw-r--r--databases/p5-hp200lx-db/Makefile3
15 files changed, 30 insertions, 15 deletions
diff --git a/databases/WWWdb/Makefile b/databases/WWWdb/Makefile
index 254679306c43..530ec210efd3 100644
--- a/databases/WWWdb/Makefile
+++ b/databases/WWWdb/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Perl based generic WWW DB interface / frontend
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWWdb::Base.3 WWWdb::DbSession.3 WWWdb::List.3 \
WWWdb::Session.3 WWWdb::Plugin.3 WWWdb::Hash.3 \
diff --git a/databases/p5-CDB_File-Generator/Makefile b/databases/p5-CDB_File-Generator/Makefile
index 7f82ed4f31b2..9f146063034c 100644
--- a/databases/p5-CDB_File-Generator/Makefile
+++ b/databases/p5-CDB_File-Generator/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/cdbmake:${PORTSDIR}/databases/cdb \
p5-CDB_File>=0:${PORTSDIR}/databases/p5-CDB_File
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CDB_File::Generator.3
diff --git a/databases/p5-Class-DBI-mysql/Makefile b/databases/p5-Class-DBI-mysql/Makefile
index dc8958a5fc14..b96739603938 100644
--- a/databases/p5-Class-DBI-mysql/Makefile
+++ b/databases/p5-Class-DBI-mysql/Makefile
@@ -14,7 +14,8 @@ BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Class::DBI::mysql.3
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index c81ac50234d7..90464c15ba9c 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= cego.1:${PORTSDIR}/databases/cego
USE_GMAKE= yes
.endif
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CC:= ${CXX}
MAN3= DBD::Cego.3
diff --git a/databases/p5-DBIx-AnyDBD/Makefile b/databases/p5-DBIx-AnyDBD/Makefile
index 55987a769306..d6fe0a40c08a 100644
--- a/databases/p5-DBIx-AnyDBD/Makefile
+++ b/databases/p5-DBIx-AnyDBD/Makefile
@@ -17,7 +17,8 @@ COMMENT= DBD independent class
BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::AnyDBD.3
diff --git a/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile b/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile
index f12feb68a583..71275a33dce3 100644
--- a/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile
+++ b/databases/p5-DBIx-Class-ResultSet-HashRef/Makefile
@@ -13,7 +13,8 @@ COMMENT= Adds syntactic sugar to skip the fancy objects
BUILD_DEPENDS= p5-DBIx-Class>=0.04001:${PORTSDIR}/databases/p5-DBIx-Class
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::ResultSet::HashRef.3
diff --git a/databases/p5-DBIx-Password/Makefile b/databases/p5-DBIx-Password/Makefile
index 27d2e4ca5031..a665a916f17d 100644
--- a/databases/p5-DBIx-Password/Makefile
+++ b/databases/p5-DBIx-Password/Makefile
@@ -17,7 +17,8 @@ COMMENT= Allows you to create a global password file for DB passwords
BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Password.3
diff --git a/databases/p5-DBIx-SQLEngine/Makefile b/databases/p5-DBIx-SQLEngine/Makefile
index bb6bbafe3d83..9cf590a6cb1d 100644
--- a/databases/p5-DBIx-SQLEngine/Makefile
+++ b/databases/p5-DBIx-SQLEngine/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-DBIx-AnyDBD>=0:${PORTSDIR}/databases/p5-DBIx-AnyDBD \
p5-Class-MixinFactory>=0:${PORTSDIR}/devel/p5-Class-MixinFactory
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::SQLEngine.3 \
DBIx::SQLEngine::Cache::BasicCache.3 \
diff --git a/databases/p5-DBIx-SQLite-Simple/Makefile b/databases/p5-DBIx-SQLite-Simple/Makefile
index 0c883b33242e..cd1f2b01771b 100644
--- a/databases/p5-DBIx-SQLite-Simple/Makefile
+++ b/databases/p5-DBIx-SQLite-Simple/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Class-Gomor>=0:${PORTSDIR}/devel/p5-Class-Gomor \
p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::SQLite::Simple.3 \
DBIx::SQLite::Simple::Table.3
diff --git a/databases/p5-DBIx-XML_RDB/Makefile b/databases/p5-DBIx-XML_RDB/Makefile
index 6d62ce172fd9..c32869edf685 100644
--- a/databases/p5-DBIx-XML_RDB/Makefile
+++ b/databases/p5-DBIx-XML_RDB/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::XML_RDB.3
diff --git a/databases/p5-Iterator-DBI/Makefile b/databases/p5-Iterator-DBI/Makefile
index 3d9697ae0b4f..4700575d7b2d 100644
--- a/databases/p5-Iterator-DBI/Makefile
+++ b/databases/p5-Iterator-DBI/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Iterator::DBI.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/databases/p5-Metadata/Makefile b/databases/p5-Metadata/Makefile
index 6a5bb38d35b6..50b30f031ab6 100644
--- a/databases/p5-Metadata/Makefile
+++ b/databases/p5-Metadata/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl implementation of Dublin Core compatible metadata
BUILD_DEPENDS= p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Metadata::Base.3 \
Metadata::HTTP.3 \
diff --git a/databases/p5-ORLite-Migrate/Makefile b/databases/p5-ORLite-Migrate/Makefile
index 1724e568d48a..eb8ac51223f8 100644
--- a/databases/p5-ORLite-Migrate/Makefile
+++ b/databases/p5-ORLite-Migrate/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-File-pushd>=1.00:${PORTSDIR}/devel/p5-File-pushd \
p5-File-Which>=0.05:${PORTSDIR}/sysutils/p5-File-Which
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= ORLite::Migrate.3 \
ORLite::Migrate::Timeline.3
diff --git a/databases/p5-T2/Makefile b/databases/p5-T2/Makefile
index 77689c21b651..0e67ed26a77f 100644
--- a/databases/p5-T2/Makefile
+++ b/databases/p5-T2/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-Set-Object>=0:${PORTSDIR}/devel/p5-Set-Object \
p5-Class-Tangram>=0:${PORTSDIR}/devel/p5-Class-Tangram
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= T2.3 T2::Association.3 T2::Attribute.3 T2::Class.3 \
T2::DBSetup.3 T2::Method.3 T2::Schema.3 T2::Storage.3
diff --git a/databases/p5-hp200lx-db/Makefile b/databases/p5-hp200lx-db/Makefile
index 303f6e66f424..60dbaa7921a0 100644
--- a/databases/p5-hp200lx-db/Makefile
+++ b/databases/p5-hp200lx-db/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 module to handle HP 200LX palmtop computer databases
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HP200LX::DB.3