aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2014-04-03 21:08:22 +0800
committeraz <az@FreeBSD.org>2014-04-03 21:08:22 +0800
commit639fc5d30401f9244900e8e2d2109647361b1a62 (patch)
tree7909c41f44fe763e71db6a4049bcaa3959ab22bb /databases
parentfd369729f77c1bae40fb10085c7a3759fa5f78aa (diff)
downloadfreebsd-ports-gnome-639fc5d30401f9244900e8e2d2109647361b1a62.tar.gz
freebsd-ports-gnome-639fc5d30401f9244900e8e2d2109647361b1a62.tar.zst
freebsd-ports-gnome-639fc5d30401f9244900e8e2d2109647361b1a62.zip
- restore databases/p5-DBD-InterBase
- set maintainership to Yuri Perezhilin <yuri@rivera.ru> PR: ports/187579 Submitted by: Yuri Perezhilin <yuri@rivera.ru>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBD-InterBase/Makefile26
-rw-r--r--databases/p5-DBD-InterBase/distinfo2
-rw-r--r--databases/p5-DBD-InterBase/files/patch-Makefile.PL85
-rw-r--r--databases/p5-DBD-InterBase/files/patch-dbdimp.c31
-rw-r--r--databases/p5-DBD-InterBase/pkg-descr4
-rw-r--r--databases/p5-DBD-InterBase/pkg-plist10
7 files changed, 159 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 4ba0b9427687..f06d5bf06321 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -317,6 +317,7 @@
SUBDIR += p5-DBD-Excel
SUBDIR += p5-DBD-FrontBase
SUBDIR += p5-DBD-Google
+ SUBDIR += p5-DBD-InterBase
SUBDIR += p5-DBD-LDAP
SUBDIR += p5-DBD-Mock
SUBDIR += p5-DBD-Multi
diff --git a/databases/p5-DBD-InterBase/Makefile b/databases/p5-DBD-InterBase/Makefile
new file mode 100644
index 000000000000..fcf66610fee3
--- /dev/null
+++ b/databases/p5-DBD-InterBase/Makefile
@@ -0,0 +1,26 @@
+# Created by: Sergey Skvortsov <skv@protey.ru>
+# $FreeBSD$
+
+PORTNAME= DBD-InterBase
+PORTVERSION= 0.48
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= yuri@rivera.ru
+COMMENT= DBI driver for InterBase/Firebird/Yaffil RDBMS server
+
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_FIREBIRD= yes
+
+USES= perl5
+USE_PERL5= patch configure
+
+post-patch:
+ @${PERL} -pi -e 's,%%IB_BASE%%,${LOCALBASE},g' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-InterBase/distinfo b/databases/p5-DBD-InterBase/distinfo
new file mode 100644
index 000000000000..990e2aa9fab8
--- /dev/null
+++ b/databases/p5-DBD-InterBase/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBD-InterBase-0.48.tar.gz) = 40b1dba601f10c5d66b26bb235424d398882740b3586a30405123735bc4bec44
+SIZE (DBD-InterBase-0.48.tar.gz) = 88658
diff --git a/databases/p5-DBD-InterBase/files/patch-Makefile.PL b/databases/p5-DBD-InterBase/files/patch-Makefile.PL
new file mode 100644
index 000000000000..16ffa097669d
--- /dev/null
+++ b/databases/p5-DBD-InterBase/files/patch-Makefile.PL
@@ -0,0 +1,85 @@
+--- Makefile.PL.orig Sat Nov 22 06:12:11 2003
++++ Makefile.PL Mon Dec 8 20:01:27 2003
+@@ -28,7 +28,7 @@
+ use DBI::DBD; # DBD creation tools
+
+ my $ib_dir_prefix;
+-
++=rem
+ # init stuff
+ my $IB_Bin_path = '';
+ my $isql_name;
+@@ -82,7 +82,12 @@
+ @ib_bin_dirs = (qw(/usr/interbase/bin /opt/interbase/bin /opt/firebird/bin /usr/bin /usr/local/bin));
+ @ib_inc_dirs = (qw(/usr/interbase/include /opt/interbase/include /opt/firebird/include /usr/include));
+ }
+-
++=cut
++my $IB_BASE='%%IB_BASE%%';
++my $IB_Bin_path = $IB_BASE.'/bin';
++my $isql_name = 'isql';
++my $ib_lib_dir = $IB_BASE.'/lib';
++my $ib_inc = $IB_BASE.'/include';
+ sub locate_dbi_arch_dir {
+ my $dbidir = dbd_dbi_dir();
+ my @try = map { "$_/auto/DBI" } @INC;
+@@ -91,7 +96,7 @@
+ Carp::carp( "Multiple copies of Driver.xst found in: @xst") if @xst > 1;
+ return $xst[0];
+ }
+-
++=rem
+ ################################################################################
+ # sub test_files - checks if at least one of the files in the list exists
+ # Paramters:
+@@ -296,13 +301,13 @@
+
+ # prompt for InterBase bin directory
+ $IB_Bin_path = dir_choice("InterBase/Firebird bin directory", [@ib_bin_dirs], [qw(gfix gfix.exe)]);
+-
++=cut
+ unless(-x $IB_Bin_path)
+ {
+ carp "I cannot find your InterBase/Firebird installation.\nDBD::InterBase cannot build or run without InterBase.\n";
+ exit 1;
+ }
+-
++=rem
+ # get InterBase version
+ my $IBVERSION;
+ my $GFIX_PATH = $IB_Bin_path . "/" . test_files($IB_Bin_path, [qw(gfix gfix.exe)]);
+@@ -312,7 +317,7 @@
+
+ # prompt for IB include dir
+ my $ib_inc = dir_choice("InterBase/Firebird include directory", [@ib_inc_dirs], [qw(gds.h ibase.h)]);
+-
++=cut
+
+ # we use a hash for the MakeMaker parameters
+ my %MakeParams = (
+@@ -323,14 +328,14 @@
+ 'CCFLAGS' => '',
+ 'INC' => qq(-I"$ib_inc" -I"${\locate_dbi_arch_dir()}"),
+ 'OBJECT' => "InterBase.o dbdimp.o",
+- 'LIBS' => [''],
++ 'LIBS' => "-L$ib_lib_dir -lgds",
+ 'OPTIMIZE' => $Config::Config{'optimize'},
+ 'XSPROTOARG' => '-noprototypes',
+ 'dist' => {COMPRESS=>'gzip -9f', SUFFIX=>'gz'},
+ 'clean' => {FILES => "*.xsi *.old t/*.old *~ t/*~ trace.txt t/trace.txt lib/DBD/InterBase/*~ lib/DBD/InterBase/*.old lib/Bundle/DBD/*~ lib/Bundle/DBD/*.old"},
+ 'realclean' => {FILES => "t/test.conf"},
+ );
+-
++=rem
+ # the OS specific build environment setup
+ my $os = $Config::Config{'osname'};
+ if ($os eq 'MSWin32')
+@@ -530,7 +535,7 @@
+
+ # create the test config file
+ make_test_conf();
+-
++=cut
+ # and last but not least write the makefile
+ WriteMakefile(%MakeParams);
+
diff --git a/databases/p5-DBD-InterBase/files/patch-dbdimp.c b/databases/p5-DBD-InterBase/files/patch-dbdimp.c
new file mode 100644
index 000000000000..6011ade07ef1
--- /dev/null
+++ b/databases/p5-DBD-InterBase/files/patch-dbdimp.c
@@ -0,0 +1,31 @@
+--- dbdimp.c.orig 2008-01-08 09:02:45.000000000 +0300
++++ dbdimp.c 2014-01-27 13:58:49.202445490 +0400
+@@ -113,7 +113,7 @@
+
+ if (DBIc_TRACE_LEVEL(imp_xxh) >= 2)
+ PerlIO_printf(DBIc_LOGPIO(imp_xxh), "%s error %d recorded: %s\n",
+- what, rc, SvPV(errstr,na));
++ what, rc, SvPV(errstr,PL_na));
+ }
+
+ #define CALC_AVAILABLE(buff) sizeof(buff) - strlen(buff) - 1
+@@ -693,7 +693,7 @@
+ return Nullsv;
+ else
+ {
+- if ((result == &sv_yes) || (result == &sv_no))
++ if ((result == &PL_sv_yes) || (result == &PL_sv_no))
+ return result;
+ else
+ return sv_2mortal(result);
+@@ -1991,8 +1991,8 @@
+ DBIh_EVENT2(drh, ERROR_event, DBIc_ERR(imp_drh), DBIc_ERRSTR(imp_drh));
+ return FALSE;
+ }
+- if (perl_destruct_level)
+- perl_destruct_level = 0;
++ if (PL_perl_destruct_level)
++ PL_perl_destruct_level = 0;
+ return FALSE;
+ }
+
diff --git a/databases/p5-DBD-InterBase/pkg-descr b/databases/p5-DBD-InterBase/pkg-descr
new file mode 100644
index 000000000000..1f96e8941d77
--- /dev/null
+++ b/databases/p5-DBD-InterBase/pkg-descr
@@ -0,0 +1,4 @@
+DBD::InterBase is a Perl module which works with the DBI module to
+provide access to InterBase/Firebird/Yaffil databases.
+
+WWW: http://search.cpan.org/dist/DBD-InterBase/
diff --git a/databases/p5-DBD-InterBase/pkg-plist b/databases/p5-DBD-InterBase/pkg-plist
new file mode 100644
index 000000000000..bfc2cfece751
--- /dev/null
+++ b/databases/p5-DBD-InterBase/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase/GetInfo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase/TypeInfo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase/InterBase.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase/InterBase.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/DBD
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD