aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-10-03 02:14:26 +0800
committerswills <swills@FreeBSD.org>2011-10-03 02:14:26 +0800
commit818e00b9f5c0f396d826cceae782b30f23582d64 (patch)
treeb0fe6c7254817caccd6a635d583ce9ba9e38f3d7 /databases
parentacd28683c9f8555b38546e6a5686a6ddb84e67f4 (diff)
downloadfreebsd-ports-gnome-818e00b9f5c0f396d826cceae782b30f23582d64.tar.gz
freebsd-ports-gnome-818e00b9f5c0f396d826cceae782b30f23582d64.tar.zst
freebsd-ports-gnome-818e00b9f5c0f396d826cceae782b30f23582d64.zip
Amalgalite embeds the SQLite database
engine in a ruby extension. There is no need to install SQLite separately. WWW: http://copiousfreetime.rubyforge.org/amalgalite/ PR: ports/158316 Submitted by: Eric Freeman <freebsdports@chillibear.com>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-amalgalite/Makefile25
-rw-r--r--databases/rubygem-amalgalite/distinfo2
-rw-r--r--databases/rubygem-amalgalite/pkg-descr5
4 files changed, 33 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index edfb5994ba1a..22f3747edca1 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -756,6 +756,7 @@
SUBDIR += rubygem-activerecord
SUBDIR += rubygem-activerecord-jdbc-adapter
SUBDIR += rubygem-activerecord-jdbcmysql-adapter
+ SUBDIR += rubygem-amalgalite
SUBDIR += rubygem-arel
SUBDIR += rubygem-bigrecord
SUBDIR += rubygem-couchrest
diff --git a/databases/rubygem-amalgalite/Makefile b/databases/rubygem-amalgalite/Makefile
new file mode 100644
index 000000000000..cd6e3feba4e1
--- /dev/null
+++ b/databases/rubygem-amalgalite/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: rubygem-amalgalite
+# Date created: 26 June 2011
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amalgalite
+PORTVERSION= 1.1.2
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Embeds the SQLite database engine in a ruby extension
+
+RUN_DEPENDS= rubygem-arrayfields>=4.7.4:${PORTSDIR}/devel/rubygem-arrayfields \
+ rubygem-fastercsv>=1.5.4:${PORTSDIR}/devel/rubygem-fastercsv
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES= bin/amalgalite-pack
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-amalgalite/distinfo b/databases/rubygem-amalgalite/distinfo
new file mode 100644
index 000000000000..64e60da13005
--- /dev/null
+++ b/databases/rubygem-amalgalite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amalgalite-1.1.2.gem) = 133d013d02608ba5713e1c2db8b7280b1e5a5378925ace14ea133e911bc72b22
+SIZE (rubygem/amalgalite-1.1.2.gem) = 1351168
diff --git a/databases/rubygem-amalgalite/pkg-descr b/databases/rubygem-amalgalite/pkg-descr
new file mode 100644
index 000000000000..e3dbde45caf1
--- /dev/null
+++ b/databases/rubygem-amalgalite/pkg-descr
@@ -0,0 +1,5 @@
+Amalgalite embeds the SQLite database
+engine in a ruby extension. There is no
+need to install SQLite separately.
+
+WWW: http://copiousfreetime.rubyforge.org/amalgalite/