aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-03-27 04:40:26 +0800
committerantoine <antoine@FreeBSD.org>2014-03-27 04:40:26 +0800
commit86a9b787b1481678fc9a5097d0786d3ac925a2fb (patch)
tree245b5a8f563a9f5f35558f2a983989fc75ffd4bc /databases
parentbec806260dc64d6855a075f1e5d1effbd9ff73c3 (diff)
downloadfreebsd-ports-gnome-86a9b787b1481678fc9a5097d0786d3ac925a2fb.tar.gz
freebsd-ports-gnome-86a9b787b1481678fc9a5097d0786d3ac925a2fb.tar.zst
freebsd-ports-gnome-86a9b787b1481678fc9a5097d0786d3ac925a2fb.zip
Stage support
Diffstat (limited to 'databases')
-rw-r--r--databases/ocaml-mysql/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/databases/ocaml-mysql/Makefile b/databases/ocaml-mysql/Makefile
index 746fce2c92d5..fd936d3a2ba4 100644
--- a/databases/ocaml-mysql/Makefile
+++ b/databases/ocaml-mysql/Makefile
@@ -11,9 +11,8 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jyyou@cs.nctu.edu.tw
COMMENT= OCaml bindings to libmysqlclient
-USE_GMAKE= yes
+USES= gmake
USE_MYSQL= yes
-
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAMLFIND_PLIST= yes
@@ -22,16 +21,24 @@ USE_OCAML_LDCONFIG= yes
GNU_CONFIGURE= yes
ALL_TARGET= all opt
-NO_STAGE= yes
-.if !defined(NOPORTDOCS)
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
ALL_TARGET+= htdoc
-PORTDOCS= *
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/mysql/html/* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/mysql/html/* ${STAGEDIR}${DOCSDIR}
.endif
+post-patch:
+ ${REINPLACE_CMD} 's,OCAMLFIND_INSTFLAGS=,OCAMLFIND_INSTFLAGS=-ldconf ignore ,' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>