aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-07-23 21:58:45 +0800
committerfeld <feld@FreeBSD.org>2017-07-23 21:58:45 +0800
commita964ed79a54ea274a436995816a639005ada2478 (patch)
tree61575421d8969da81dc2497935006a7977378ed8 /databases
parentb265ba1b7bc91eaa17b9ce6ddb7961dd88821b04 (diff)
downloadfreebsd-ports-gnome-a964ed79a54ea274a436995816a639005ada2478.tar.gz
freebsd-ports-gnome-a964ed79a54ea274a436995816a639005ada2478.tar.zst
freebsd-ports-gnome-a964ed79a54ea274a436995816a639005ada2478.zip
databases/percona55-server percona56-server:
Fix OPENSSL option to actually enable linking with OpenSSL MFH: 2017Q3 Differential Revision: https://reviews.freebsd.org/D9122
Diffstat (limited to 'databases')
-rw-r--r--databases/percona55-server/Makefile5
-rw-r--r--databases/percona56-server/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 7bd5d98c5ea1..f6e4bf09da30 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -2,7 +2,7 @@
PORTNAME?= percona
DISTVERSION= 5.5.54-38.6
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= databases ipv6
MASTER_SITES= http://www.percona.com/downloads/Percona-Server-5.5/Percona-Server-${DISTVERSION}/source/tarball/
PKGNAMESUFFIX?= 55-server
@@ -48,7 +48,8 @@ SHEBANG_FILES= scripts/*.pl* scripts/*.sh
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENSSL}
-CMAKE_ARGS+= -DWITH_SSL=bundled
+CMAKE_ARGS+= -DWITH_SSL=system
+OPENSSL_USES= ssl
.endif
.if ${PORT_OPTIONS:MFASTMTX}
CMAKE_ARGS+= -DWITH_FAST_MUTEXES=1
diff --git a/databases/percona56-server/Makefile b/databases/percona56-server/Makefile
index 0e532f9fc872..b6afebc2839a 100644
--- a/databases/percona56-server/Makefile
+++ b/databases/percona56-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= percona
DISTVERSION= 5.6.35-80.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= databases ipv6
MASTER_SITES= http://www.percona.com/downloads/Percona-Server-5.6/Percona-Server-${DISTVERSION}/source/tarball/
PKGNAMESUFFIX?= 56-server
@@ -27,7 +27,8 @@ FASTMTX_DESC= Replace mutexes with spinlocks
FASTMTX_CMAKE_ON= -DWITH_FAST_MUTEXES=1
INNODBMEMCACHED_DESC= InnoDB Memcached plugin
INNODBMEMCACHED_CMAKE_ON= -DWITH_INNODB_MEMCACHED=1
-OPENSSL_CMAKE_ON= -DWITH_SSL=bundled
+OPENSSL_CMAKE_ON= -DWITH_SSL=system
+OPENSSL_USES= ssl
TOKUDB_DESC= TokuDB Engine (experimental)
TOKUDB_CMAKE_ON= -DUSE_CTAGS=0
TOKUDB_EXTRA_PATCHES=${PATCHDIR}/extrapatch-tokudb