aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2012-02-20 03:21:02 +0800
committercrees <crees@FreeBSD.org>2012-02-20 03:21:02 +0800
commitbd3e126fd215ed124c7bdd49d4a16eb745938ff9 (patch)
tree27930eb9135d25b907008d599d98befcb9083aa2 /databases
parent227e99a88f52c4b9860c486b1c29672d43002a70 (diff)
downloadfreebsd-ports-gnome-bd3e126fd215ed124c7bdd49d4a16eb745938ff9.tar.gz
freebsd-ports-gnome-bd3e126fd215ed124c7bdd49d4a16eb745938ff9.tar.zst
freebsd-ports-gnome-bd3e126fd215ed124c7bdd49d4a16eb745938ff9.zip
- Replace the p5-postgresql-plperl port with versioned ports. This replaces
the fragile autodetection logic with unambiguous ports, creates packages that work, and also ensures that each version is tested. - Take back maintainership; should be maintained together with postgresql-server - While here, remove p5-prefix; the packages have not had this for years, so we may as well update the port directories now
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile5
-rw-r--r--databases/p5-postgresql-plperl/Makefile43
-rw-r--r--databases/p5-postgresql-plperl/pkg-descr7
-rw-r--r--databases/postgresql83-plperl/Makefile17
-rw-r--r--databases/postgresql84-plperl/Makefile17
-rw-r--r--databases/postgresql90-plperl/Makefile28
-rw-r--r--databases/postgresql91-plperl/Makefile17
7 files changed, 83 insertions, 51 deletions
diff --git a/databases/Makefile b/databases/Makefile
index c187ffd62dea..a4633f21c2ff 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -476,7 +476,6 @@
SUBDIR += p5-TokyoCabinet
SUBDIR += p5-hp200lx-db
SUBDIR += p5-mysql-genocide
- SUBDIR += p5-postgresql-plperl
SUBDIR += p5-qdbm
SUBDIR += p5-tokyotyrant
SUBDIR += pear-DB
@@ -628,15 +627,19 @@
SUBDIR += postgresql82-server
SUBDIR += postgresql83-client
SUBDIR += postgresql83-contrib
+ SUBDIR += postgresql83-plperl
SUBDIR += postgresql83-server
SUBDIR += postgresql84-client
SUBDIR += postgresql84-contrib
+ SUBDIR += postgresql84-plperl
SUBDIR += postgresql84-server
SUBDIR += postgresql90-client
SUBDIR += postgresql90-contrib
+ SUBDIR += postgresql90-plperl
SUBDIR += postgresql90-server
SUBDIR += postgresql91-client
SUBDIR += postgresql91-contrib
+ SUBDIR += postgresql91-plperl
SUBDIR += postgresql91-server
SUBDIR += postgresql_autodoc
SUBDIR += powerarchitect
diff --git a/databases/p5-postgresql-plperl/Makefile b/databases/p5-postgresql-plperl/Makefile
deleted file mode 100644
index d31bd03b51e8..000000000000
--- a/databases/p5-postgresql-plperl/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: PostgreSQL PL/Perl
-# Date created: January 14, 2002
-# Whom: Palle Girgensohn <girgen@partitur.se>
-#
-# $FreeBSD$
-#
-
-PORTNAME= postgresql
-PORTREVISION= 2
-CATEGORIES= databases perl5
-PKGNAMESUFFIX= -plperl
-
-MAINTAINER= perl@FreeBSD.org
-COMMENT= Write SQL functions for PostgreSQL using Perl5
-
-MASTERDIR= ${.CURDIR}/../../databases/postgresql${PGSQL_VER}-server
-
-RUN_DEPENDS= postgres:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
-
-DEFAULT_PGSQL_VER?=84
-
-# can't include <bsd.port.pre.mk> in a slave port
-# so set these instead:
-LOCALBASE?= /usr/local
-SED?= /usr/bin/sed
-
-# Setting/finding PostgreSQL version we want.
-.if exists(${LOCALBASE}/bin/postmaster)
-PGSQL_VER!= ${LOCALBASE}/bin/postmaster -V | ${SED} -n 's/.*PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
-.elif exists(${LOCALBASE}/bin/pg_config)
-PGSQL_VER!= ${LOCALBASE}/bin/pg_config --version | ${SED} -n 's/PostgreSQL[^0-9]*\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\2/p'
-.else
-PGSQL_VER= ${DEFAULT_PGSQL_VER}
-.endif
-
-USE_PERL5= yes
-CONFIGURE_ARGS= --with-perl
-
-BUILD_DIRS= src/backend src/pl/plperl
-INSTALL_DIRS= src/pl/plperl
-SLAVE_ONLY= yes
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/p5-postgresql-plperl/pkg-descr b/databases/p5-postgresql-plperl/pkg-descr
deleted file mode 100644
index 84d32c9d7848..000000000000
--- a/databases/p5-postgresql-plperl/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-PL/Perl allows you to write PostgreSQL functions and procedures in
-Perl. Consult the PostgreSQL User's Guide and the INSTALL file in the
-top-level directory of the source distribution for more information.
-
-This software is part of the standard PostgreSQL distribution.
-
-WWW: http://www.postgresql.org/
diff --git a/databases/postgresql83-plperl/Makefile b/databases/postgresql83-plperl/Makefile
new file mode 100644
index 000000000000..5caa98f431e2
--- /dev/null
+++ b/databases/postgresql83-plperl/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: PostgreSQL PL/Perl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+PKGNAMESUFFIX= -plperl
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Write SQL functions for PostgreSQL using Perl5
+
+WANT_PGSQL_VER= 83
+USE_PERL5= yes
+
+.include "${.CURDIR}/../postgresql90-plperl/Makefile"
diff --git a/databases/postgresql84-plperl/Makefile b/databases/postgresql84-plperl/Makefile
new file mode 100644
index 000000000000..02e9d9a591a4
--- /dev/null
+++ b/databases/postgresql84-plperl/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: PostgreSQL PL/Perl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+PKGNAMESUFFIX= -plperl
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Write SQL functions for PostgreSQL using Perl5
+
+WANT_PGSQL_VER= 84
+USE_PERL5= yes
+
+.include "${.CURDIR}/../postgresql90-plperl/Makefile"
diff --git a/databases/postgresql90-plperl/Makefile b/databases/postgresql90-plperl/Makefile
new file mode 100644
index 000000000000..fdd98fad3822
--- /dev/null
+++ b/databases/postgresql90-plperl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: PostgreSQL PL/Perl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+CATEGORIES= databases perl5
+PKGNAMESUFFIX= -plperl
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Write SQL functions for PostgreSQL using Perl5
+
+MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER}-server
+
+RUN_DEPENDS= postgres:${PORTSDIR}/databases/postgresql${WANT_PGSQL_VER}-server
+
+WANT_PGSQL_VER?=90
+
+USE_PERL5= yes
+CONFIGURE_ARGS= --with-perl
+
+BUILD_DIRS= src/backend src/pl/plperl
+INSTALL_DIRS= src/pl/plperl
+SLAVE_ONLY= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql91-plperl/Makefile b/databases/postgresql91-plperl/Makefile
new file mode 100644
index 000000000000..7c50407c0a6b
--- /dev/null
+++ b/databases/postgresql91-plperl/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: PostgreSQL PL/Perl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+PKGNAMESUFFIX= -plperl
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Write SQL functions for PostgreSQL using Perl5
+
+WANT_PGSQL_VER= 91
+USE_PERL5= yes
+
+.include "${.CURDIR}/../postgresql90-plperl/Makefile"