aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-09-25 08:57:35 +0800
committerjbeich <jbeich@FreeBSD.org>2017-09-25 08:57:35 +0800
commitcda598378455f53e4db24ca1c3b159fb672b743a (patch)
treec7777052bba8ca7077366be25fd4590e5e26ee75 /databases
parentc531208b3440a052700535c3141bf9aa23a32486 (diff)
downloadfreebsd-ports-gnome-cda598378455f53e4db24ca1c3b159fb672b743a.tar.gz
freebsd-ports-gnome-cda598378455f53e4db24ca1c3b159fb672b743a.tar.zst
freebsd-ports-gnome-cda598378455f53e4db24ca1c3b159fb672b743a.zip
databases/clickhouse: mark BROKEN after r450560
In file included from dbms/src/Storages/MergeTree/MergeTreeDataSelectExecutor.cpp:19: In file included from contrib/libboost/boost_1_65_0/boost/rational.hpp:82: contrib/libboost/boost_1_65_0/boost/integer/common_factor_rt.hpp:447:44: error: no member named 'min' in 'std::__1::numeric_limits<__uint128_t>' if(a == (std::numeric_limits<Integer>::min)()) ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^ contrib/libboost/boost_1_65_0/boost/rational.hpp:854:26: note: in instantiation of function template specialization 'boost::integer::gcd<unsigned __int128>' requested here IntType g = integer::gcd(num, den); ^ contrib/libboost/boost_1_65_0/boost/rational.hpp:163:8: note: in instantiation of member function 'boost::rational<unsigned __int128>::normalize' requested here normalize(); ^ contrib/libboost/boost_1_65_0/boost/rational.hpp:251:23: note: in instantiation of function template specialization 'boost::rational<unsigned __int128>::rational<unsigned __int128, unsigned __int128>' requested here return *this = rational<IntType>(static_cast<IntType>(n), static_cast<IntType>(d)); ^ contrib/libboost/boost_1_65_0/boost/rational.hpp:211:8: note: in instantiation of function template specialization 'boost::rational<unsigned __int128>::assign<int, int>' requested here assign(n, static_cast<T>(1)); ^ dbms/src/Storages/MergeTree/MergeTreeDataSelectExecutor.cpp:122:16: note: in instantiation of function template specialization 'boost::rational<unsigned __int128>::rational<int>' requested here return 1; ^ [...] PR: 222439 Pointy hat to: jbeich (bundled boost didn't help)
Diffstat (limited to 'databases')
-rw-r--r--databases/clickhouse/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/clickhouse/Makefile b/databases/clickhouse/Makefile
index 09b6185c3acd..314838944ee5 100644
--- a/databases/clickhouse/Makefile
+++ b/databases/clickhouse/Makefile
@@ -12,6 +12,8 @@ CATEGORIES= databases
MAINTAINER= proler@gmail.com
COMMENT= ClickHouse is an column-oriented database management system
+BROKEN= fails to build with boost 1.65 (bundled & system), see bug 222439
+
LICENSE= APACHE20
BUILD_DEPENDS= bash:shells/bash \
@@ -22,6 +24,7 @@ LIB_DEPENDS= libtcmalloc.so:devel/google-perftools \
libodbc.so:databases/unixODBC \
libltdl.so:devel/libltdl \
libicudata.so:devel/icu \
+ libboost_program_options.so:devel/boost-libs \
libzookeeper_mt.so:devel/libzookeeper \
libre2.so:devel/re2 \
libdouble-conversion.so:devel/libdouble-conversion \
@@ -42,9 +45,7 @@ BROKEN_FreeBSD_10= Builds but does not work
USES= compiler:c++14-lang cmake iconv mysql ssl readline
USE_LDCONFIG= yes
-# Bug 222439: use bundled boost 1.65.0 to avoid 1.65.1 bustage
CMAKE_ARGS= -DUNBUNDLED=1 \
- -DUSE_INTERNAL_BOOST_LIBRARY=1 \
-DUSE_STATIC_LIBRARIES=0 \
-DNO_WERROR=1 \
-DENABLE_TESTS=0 \