aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-12 14:26:43 +0800
committerbapt <bapt@FreeBSD.org>2012-06-12 14:26:43 +0800
commitd4a2fb9e06a4196b79fed7e538f20a9bea4b5f09 (patch)
tree619663c6751e0b5fa38076010b70caaf43759491 /databases
parent5ecb0ce0c5c19d8c2ed89fe6efcf9374dffb6669 (diff)
downloadfreebsd-ports-gnome-d4a2fb9e06a4196b79fed7e538f20a9bea4b5f09.tar.gz
freebsd-ports-gnome-d4a2fb9e06a4196b79fed7e538f20a9bea4b5f09.tar.zst
freebsd-ports-gnome-d4a2fb9e06a4196b79fed7e538f20a9bea4b5f09.zip
Convert to new option framework
Diffstat (limited to 'databases')
-rw-r--r--databases/metakit/Makefile19
-rw-r--r--databases/mysql-workbench51/Makefile5
-rw-r--r--databases/xapian-core10/Makefile9
3 files changed, 18 insertions, 15 deletions
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
index 711e507a9eca..065fa92bc2da 100644
--- a/databases/metakit/Makefile
+++ b/databases/metakit/Makefile
@@ -24,12 +24,12 @@ CONFIGURE_SCRIPT= ../unix/configure
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 alpha amd64
-OPTIONS= PYTHON "Enable Python support" on \
- TCL "Enable Tcl support" off
+OPTIONS_DEFINE= PYTHON TCL DOCS
+OPTIONS_DEFAULT= PYTHON
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
CONFIGURE_ARGS+= --with-python=${LOCALBASE}
@@ -39,12 +39,13 @@ PLIST_SUB+= WITH_PYTHON=""
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.if defined(WITH_TCL)
+.if ${PORT_OPTIONS:MTCL}
CATEGORIES+= tcl
USE_TCL= 83+
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
.endif
+.include <bsd.port.pre.mk>
+
.if defined(USE_TCL)
CONFIGURE_ARGS+= --with-tcl=${TCL_INCLUDEDIR}
CONFIGURE_ENV+= TCL_LIBDIR=${TCL_LIBDIR}
@@ -60,13 +61,13 @@ pre-patch:
${REINPLACE_CMD} -e "s/= tclsh/=tclsh${TCL_VER}/" \
${WRKSRC}/../unix/Makefile.in
.endif
-.if !defined(WITHOUT_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
${REINPLACE_CMD} -e "s=python2.[0-9]=${PYTHON_VERSION}=" \
${WRKSRC}/../unix/Makefile.in ${WRKSRC}/../unix/configure
.endif
post-build:
-.if !defined(WITHOUT_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
${WRKSRC}/../python
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
@@ -77,7 +78,7 @@ post-install:
@${INSTALL_PROGRAM} ${WRKSRC}/libmk4.so \
${PREFIX}/lib/libmk4.so.0
@${LN} -sf libmk4.so.0 ${PREFIX}/lib/libmk4.so
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${TAR} -C ${WRKSRC}/../doc --exclude "*CVS" -cf - . | \
${TAR} -C ${DOCSDIR} --unlink -xf -
diff --git a/databases/mysql-workbench51/Makefile b/databases/mysql-workbench51/Makefile
index f5fbffc36245..88d9e48b00b9 100644
--- a/databases/mysql-workbench51/Makefile
+++ b/databases/mysql-workbench51/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS+= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
MAKE_JOBS_UNSAFE= yes
-OPTIONS= PYTHON "Enable Python scripting and modules" off
+OPTIONS_DEFINE= PYTHON
USE_AUTOTOOLS= autoheader autoconf automake aclocal libtool
AUTOMAKE_ARGS= --add-missing --foreign
@@ -61,9 +61,8 @@ USE_MYSQL= client
DEFAULT_MYSQL_VER= 51
IGNORE_WITH_MYSQL= 41 55
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
CONFIGURE_ARGS+= --enable-python-modules
-WITH_PYTHON= yes
.endif
run-autotools-aclocal:
diff --git a/databases/xapian-core10/Makefile b/databases/xapian-core10/Makefile
index 86ffede8be83..b4efeea3543e 100644
--- a/databases/xapian-core10/Makefile
+++ b/databases/xapian-core10/Makefile
@@ -19,7 +19,8 @@ LICENSE= GPLv2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-OPTIONS= SSE2 "Use SSE2 for floating point" Off
+OPTIONS_DEFINE= SSE2
+SSE2_DESC= Use SSE2 for floating point
MAN1= quartzcheck.1 quartzcompact.1 quartzdump.1 \
xapian-check.1 xapian-compact.1 xapian-config.1 \
@@ -27,7 +28,9 @@ MAN1= quartzcheck.1 quartzcompact.1 quartzdump.1 \
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/10$//}
-.if defined(WITHOUT_SSE2)
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MSSE2)
CONFIGURE_ARGS+= --disable-sse
.endif
@@ -35,7 +38,7 @@ post-install:
.for file in delve quest copydatabase
${INSTALL_PROGRAM} ${WRKSRC}/examples/.libs/${file} ${PREFIX}/bin/xapian-${file}
.endfor
-.ifdef(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
${RM} -rf ${DOCSDIR}
.endif