aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2006-12-12 04:25:03 +0800
committerfjoe <fjoe@FreeBSD.org>2006-12-12 04:25:03 +0800
commite8cf83c899f45a6d915e8d8e3d22eaeeb588b853 (patch)
tree0c06f0231e0459867071bb2aae631288791a98d8 /databases
parentad1fed3ce6ccc364fb8420d0900b3700459d1ccd (diff)
downloadfreebsd-ports-gnome-e8cf83c899f45a6d915e8d8e3d22eaeeb588b853.tar.gz
freebsd-ports-gnome-e8cf83c899f45a6d915e8d8e3d22eaeeb588b853.tar.zst
freebsd-ports-gnome-e8cf83c899f45a6d915e8d8e3d22eaeeb588b853.zip
- OPTION'ify and fix Kerberos support (does not build with Heimdal).
- Add BUILD_DEPENDS on gawk. - Remove debugging junk from startup script. - Bump PORTREVISION.
Diffstat (limited to 'databases')
-rw-r--r--databases/virtuoso/Makefile10
-rw-r--r--databases/virtuoso/files/patch-configure9
-rw-r--r--databases/virtuoso/files/virtuoso.sh.in2
3 files changed, 8 insertions, 13 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 371bc0b498c6..1ec9c6216372 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -7,6 +7,7 @@
PORTNAME= virtuoso
PORTVERSION= 4.5.7
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,13 +20,14 @@ USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-readline\
--with-iodbc=${LOCALBASE}\
--enable-bpel-vad\
- --enable-krb\
--disable-jdbc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"\
LDFLAGS="-L${LOCALBASE}/lib"
+BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
LIB_DEPENDS= iodbc.3:${PORTSDIR}/databases/libiodbc
OPTIONS= IMAGEMAGICK "ImageMagick support" off\
+ KERBEROS "Kerberos extension" off\
OPENLDAP "OpenLDAP support" off
# JDBC "JDBC driver" off\
# PERL "Perl hosting" off
@@ -38,7 +40,6 @@ OPTIONS= IMAGEMAGICK "ImageMagick support" off\
post-patch:
${REINPLACE_CMD}\
-e 's,-lpthreads,${PTHREAD_LIBS},g'\
- -e 's,-lgssapi_krb5 -lk5crypto -lkrb5,-lasn1 -lroken -lcrypto -lcrypt,g'\
-e 's,-lruby,-lruby${RUBY_VER:S,.,,},g'\
${WRKSRC}/configure
@@ -64,6 +65,11 @@ PLIST_SUB+= WITH_IMAGEMAGICK="@comment "
#JAVA_BUILD= yes
#.endif
+.if defined(WITH_KERBEROS)
+CONFIGURE_ARGS+=--enable-krb=${LOCALBASE}
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
+.endif
+
# XXX broken (does not build, requires gc.h)
#.if defined(WITH_MONO)
#CONFIGURE_ARGS+=--enable-mono
diff --git a/databases/virtuoso/files/patch-configure b/databases/virtuoso/files/patch-configure
index 862f3b502711..4f60a1d9d15e 100644
--- a/databases/virtuoso/files/patch-configure
+++ b/databases/virtuoso/files/patch-configure
@@ -1,14 +1,5 @@
--- configure.orig Tue Dec 5 16:15:01 2006
+++ configure Sat Dec 9 19:38:53 2006
-@@ -31317,7 +31317,7 @@
-
-
-
--for ac_header in krb5.h gssapi/gssapi.h gssapi/gssapi_generic.h gssapi/gssapi_krb5.h
-+for ac_header in krb5.h gssapi/gssapi.h gssapi/gssapi_generic.h gssapi/gssapi_krb5.h gssapi.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
@@ -31793,8 +31793,8 @@
openldap_LDFLAGS="-lldap -llber"
LDFLAGS="$LDFLAGS $openldap_LDFLAGS" ;;
diff --git a/databases/virtuoso/files/virtuoso.sh.in b/databases/virtuoso/files/virtuoso.sh.in
index 52043684c912..84e68a3527af 100644
--- a/databases/virtuoso/files/virtuoso.sh.in
+++ b/databases/virtuoso/files/virtuoso.sh.in
@@ -43,8 +43,6 @@ restart_cmd="virtuoso_command restart"
reload_cmd="virtuoso_command reload"
status_cmd="virtuoso_command status"
-initdb_cmd="virtuoso_initdb"
-
virtuoso_command()
{
su -l ${virtuoso_user} -c "exec ${command} ${command_args} ${rc_arg}"