aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-04-04 15:50:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-04-04 15:50:26 +0800
commit14441beda770ce26fee0fb049492a89991ed5d81 (patch)
tree46f2e1d830ccebe72c82e8be3d50ec38fc4f4f4b /databases
parent6ccfeaaf80b0743b6b3d62c43d313ecf2caf010a (diff)
downloadfreebsd-ports-gnome-14441beda770ce26fee0fb049492a89991ed5d81.tar.gz
freebsd-ports-gnome-14441beda770ce26fee0fb049492a89991ed5d81.tar.zst
freebsd-ports-gnome-14441beda770ce26fee0fb049492a89991ed5d81.zip
- Support staging
- Correct LICENSE definition - Specify LICENSE_FILE - Convert USE_BZIP2=yes to USES=tar:bzip2 - Use DEFAULT_VERSIONS instead of DEFAULT_PHP_VER - Use COPYTREE_SHARE istead of CP
Diffstat (limited to 'databases')
-rw-r--r--databases/dalmp/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/databases/dalmp/Makefile b/databases/dalmp/Makefile
index 195dee0fd447..08ffd6a7aab4 100644
--- a/databases/dalmp/Makefile
+++ b/databases/dalmp/Makefile
@@ -9,18 +9,18 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= nbari@dalmp.com
COMMENT= Database Abstraction Layer for MySQL using PHP
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USE_BZIP2= YES
+USES= tar:bzip2
-DEFAULT_PHP_VER=5
+DEFAULT_VERSIONS=php=5
-NO_BUILD= YES
+NO_BUILD= yes
USE_PHP= pcre mysql mysqli session memcache sqlite3 curl
-NO_STAGE= yes
do-install:
- @${MKDIR} ${DATADIR}
- @${CP} -R ${WRKSRC}/ ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>