aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-06-20 00:44:59 +0800
committerswills <swills@FreeBSD.org>2011-06-20 00:44:59 +0800
commit4ccd3c14c1a6cd949929a40bf58282a80f0e1c31 (patch)
tree1f7b1177829d52865545182ca1e0e0741f33f9ac /databases
parent06ec6f1cef507b1b5894f0bc46dcba82f4865eb3 (diff)
downloadfreebsd-ports-gnome-4ccd3c14c1a6cd949929a40bf58282a80f0e1c31.tar.gz
freebsd-ports-gnome-4ccd3c14c1a6cd949929a40bf58282a80f0e1c31.tar.zst
freebsd-ports-gnome-4ccd3c14c1a6cd949929a40bf58282a80f0e1c31.zip
dm-devise adds DataMapper support to devise
(http://github.com/plataformatec/devise) for authentication support for Rails WWW: http://rubygems.org/gems/dm-devise PR: ports/158011 Submitted by: rpsfa at rit.edu
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-dm-devise/Makefile27
-rw-r--r--databases/rubygem-dm-devise/distinfo2
-rw-r--r--databases/rubygem-dm-devise/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 76ebd01dfb59..e132d2ba2e01 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -750,6 +750,7 @@
SUBDIR += rubygem-dm-aggregates
SUBDIR += rubygem-dm-constraints
SUBDIR += rubygem-dm-core
+ SUBDIR += rubygem-dm-devise
SUBDIR += rubygem-dm-do-adapter
SUBDIR += rubygem-dm-migrations
SUBDIR += rubygem-dm-mysql-adapter
diff --git a/databases/rubygem-dm-devise/Makefile b/databases/rubygem-dm-devise/Makefile
new file mode 100644
index 000000000000..a5fc0896b2c2
--- /dev/null
+++ b/databases/rubygem-dm-devise/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: rubygem-dm-devise
+# Date created: 2011-06-16
+# Whom: rpsfa@rit.edu
+#
+# $FreeBSD$
+
+PORTNAME= dm-devise
+PORTVERSION= 1.3.1
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= Adds DataMapper support to devise
+
+RUN_DEPENDS= rubygem-devise>=1.3.0:${PORTSDIR}/devel/rubygem-devise \
+ rubygem-dm-core>=1.0.2:${PORTSDIR}/databases/rubygem-dm-core \
+ rubygem-dm-migrations>=1.0.2:${PORTSDIR}/databases/rubygem-dm-migrations \
+ rubygem-dm-rails>=1.0.3:${PORTSDIR}/databases/rubygem-dm-rails \
+ rubygem-dm-serializer>=1.0.2:${PORTSDIR}/databases/rubygem-dm-serializer \
+ rubygem-dm-timestamps>=1.0.2:${PORTSDIR}/databases/rubygem-dm-timestamps \
+ rubygem-sugar-high>=0.2.10:${PORTSDIR}/devel/rubygem-sugar-high
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-dm-devise/distinfo b/databases/rubygem-dm-devise/distinfo
new file mode 100644
index 000000000000..97032cd36f3c
--- /dev/null
+++ b/databases/rubygem-dm-devise/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/dm-devise-1.3.1.gem) = 0b3acbfa35d2ef63458d61833317f4f0c54f8d18e625d3db142d20338a539609
+SIZE (rubygem/dm-devise-1.3.1.gem) = 15360
diff --git a/databases/rubygem-dm-devise/pkg-descr b/databases/rubygem-dm-devise/pkg-descr
new file mode 100644
index 000000000000..68e02f6a1e78
--- /dev/null
+++ b/databases/rubygem-dm-devise/pkg-descr
@@ -0,0 +1,4 @@
+dm-devise adds DataMapper support to devise
+(http://github.com/plataformatec/devise) for authentication support for Rails
+
+WWW: http://rubygems.org/gems/dm-devise