aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-02-21 21:58:02 +0800
committerpawel <pawel@FreeBSD.org>2015-02-21 21:58:02 +0800
commit4dbb3a689c75b31c2bd4d0a3df5fd4462f1daa7a (patch)
treef8adc6bbe4e001e2d22f39f51c3d0d9a09d81bc8 /databases
parentfe8225b78be1712fc2ed567b95e6df76192bac3d (diff)
downloadfreebsd-ports-gnome-4dbb3a689c75b31c2bd4d0a3df5fd4462f1daa7a.tar.gz
freebsd-ports-gnome-4dbb3a689c75b31c2bd4d0a3df5fd4462f1daa7a.tar.zst
freebsd-ports-gnome-4dbb3a689c75b31c2bd4d0a3df5fd4462f1daa7a.zip
VirtualPG is a loadable dynamic extension to both SQLite and SpatiaLite.
Its intended scope is supporting direct SQL access to PostgreSQL and PostGIS own tables, so to make any possible kind of data exchange between these two popular open source Spatial DBMSes as straightforward and simple as possible. WWW: http://www.gaia-gis.it/fossil/virtualpg/index PR: 197261 Submitted by: Loïc BARTOLETTI <coder@tuxfamily.org>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/virtualpg/Makefile28
-rw-r--r--databases/virtualpg/distinfo2
-rw-r--r--databases/virtualpg/pkg-descr7
4 files changed, 38 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ce2dc5899fa3..077a6ea477b5 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -931,6 +931,7 @@
SUBDIR += useracc
SUBDIR += usogres
SUBDIR += vfront
+ SUBDIR += virtualpg
SUBDIR += virtuoso
SUBDIR += vsqlite
SUBDIR += wfb2sql
diff --git a/databases/virtualpg/Makefile b/databases/virtualpg/Makefile
new file mode 100644
index 000000000000..499a31ddeb9a
--- /dev/null
+++ b/databases/virtualpg/Makefile
@@ -0,0 +1,28 @@
+# Created by: Loïc BARTOLETTI <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= virtualpg
+PORTVERSION= 1.0.1
+CATEGORIES= databases geography
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Loadable dynamic extension to both SQLite and SpatiaLite
+
+LICENSE= MPL LGPL21 GPLv2
+LICENSE_COMB= dual
+
+GNU_CONFIGURE= yes
+USES= gmake iconv pathfix pkgconfig libtool pgsql
+USE_SQLITE= yes
+USE_LDCONFIG= yes
+
+CFLAGS+= -I${WRKSRC}/src/headers -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= lib/mod_virtualpg.so \
+ lib/mod_virtualpg.so.1 \
+ lib/mod_virtualpg.so.1.0.0
+
+.include <bsd.port.mk>
diff --git a/databases/virtualpg/distinfo b/databases/virtualpg/distinfo
new file mode 100644
index 000000000000..fdc589288570
--- /dev/null
+++ b/databases/virtualpg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (virtualpg-1.0.1.tar.gz) = 9e6c4c6c1556b2ea2a1e4deda28909626c3a8b047c81d6b82c042abdb9a99ec8
+SIZE (virtualpg-1.0.1.tar.gz) = 345147
diff --git a/databases/virtualpg/pkg-descr b/databases/virtualpg/pkg-descr
new file mode 100644
index 000000000000..8eafba54235f
--- /dev/null
+++ b/databases/virtualpg/pkg-descr
@@ -0,0 +1,7 @@
+VirtualPG is a loadable dynamic extension to both SQLite and SpatiaLite.
+
+Its intended scope is supporting direct SQL access to PostgreSQL and PostGIS own
+tables, so to make any possible kind of data exchange between these two popular
+open source Spatial DBMSes as straightforward and simple as possible.
+
+WWW: http://www.gaia-gis.it/fossil/virtualpg/index