aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-07-30 03:39:49 +0800
committererwin <erwin@FreeBSD.org>2006-07-30 03:39:49 +0800
commit4e0ba50eedde33e092bc6d35a600ec9cc2a756c0 (patch)
treeee6562a7fba5511e766eb9cd7e3cad46397478fe /databases
parent94dad380df580bd1ee2ce5c7d1432d05691a069d (diff)
downloadfreebsd-ports-gnome-4e0ba50eedde33e092bc6d35a600ec9cc2a756c0.tar.gz
freebsd-ports-gnome-4e0ba50eedde33e092bc6d35a600ec9cc2a756c0.tar.zst
freebsd-ports-gnome-4e0ba50eedde33e092bc6d35a600ec9cc2a756c0.zip
DBIx::Log4perl is a wrapper over DBI which adds logging of your DBI activity
via a Log::Log4perl handle. Log::Log4perl has many advantages for logging but the ones probably most attractive are: The ability to turn logging on or off or change the logging you see without changing your code. Different log levels allowing you to separate warnings, errors and fatals to different files. WWW: http://search.cpan.org/dist/DBIx-Log4perl/ PR: ports/100610 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-DBIx-Log4perl/Makefile32
-rw-r--r--databases/p5-DBIx-Log4perl/distinfo3
-rw-r--r--databases/p5-DBIx-Log4perl/pkg-descr11
-rw-r--r--databases/p5-DBIx-Log4perl/pkg-plist9
5 files changed, 56 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 306a7b020438..b2c4034d4be7 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -232,6 +232,7 @@
SUBDIR += p5-DBIx-DBSchema
SUBDIR += p5-DBIx-DataSource
SUBDIR += p5-DBIx-Ease
+ SUBDIR += p5-DBIx-Log4perl
SUBDIR += p5-DBIx-MySQLSequence
SUBDIR += p5-DBIx-Password
SUBDIR += p5-DBIx-Recordset
diff --git a/databases/p5-DBIx-Log4perl/Makefile b/databases/p5-DBIx-Log4perl/Makefile
new file mode 100644
index 000000000000..efe91dcb6b2c
--- /dev/null
+++ b/databases/p5-DBIx-Log4perl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-DBIx-Log4perl
+# Date created: 2006-07-20
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Log4perl
+PORTVERSION= 0.06
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= For DBI to selectively log SQL, parameters, result-sets, transactions
+
+BUILD_DEPENDS= p5-DBI>=1.50:${PORTSDIR}/databases/p5-DBI \
+ p5-Log-Log4perl>=1.04:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Log4perl.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8.0 Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-Log4perl/distinfo b/databases/p5-DBIx-Log4perl/distinfo
new file mode 100644
index 000000000000..fafcaa7c02ca
--- /dev/null
+++ b/databases/p5-DBIx-Log4perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Log4perl-0.06.tar.gz) = 409788753f77aac87a7b5755093afedb
+SHA256 (DBIx-Log4perl-0.06.tar.gz) = f690100c4bb66d464743d5c4f6e81300f9c49ec606008f3bf926943fe835b66e
+SIZE (DBIx-Log4perl-0.06.tar.gz) = 13894
diff --git a/databases/p5-DBIx-Log4perl/pkg-descr b/databases/p5-DBIx-Log4perl/pkg-descr
new file mode 100644
index 000000000000..a8f70a7663a1
--- /dev/null
+++ b/databases/p5-DBIx-Log4perl/pkg-descr
@@ -0,0 +1,11 @@
+DBIx::Log4perl is a wrapper over DBI which adds logging of your DBI activity
+via a Log::Log4perl handle. Log::Log4perl has many advantages for logging
+but the ones probably most attractive are:
+
+The ability to turn logging on or off or change the logging you see without
+changing your code.
+
+Different log levels allowing you to separate warnings, errors and fatals
+to different files.
+
+WWW: http://search.cpan.org/dist/DBIx-Log4perl/
diff --git a/databases/p5-DBIx-Log4perl/pkg-plist b/databases/p5-DBIx-Log4perl/pkg-plist
new file mode 100644
index 000000000000..6d645aee6b29
--- /dev/null
+++ b/databases/p5-DBIx-Log4perl/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/DBIx/Log4perl.pm
+%%SITE_PERL%%/DBIx/Log4perl/st.pm
+%%SITE_PERL%%/DBIx/Log4perl/Constants.pm
+%%SITE_PERL%%/DBIx/Log4perl/db.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Log4perl/.packlist
+@dirrmtry %%SITE_PERL%%/DBIx/Log4perl
+@dirrmtry %%SITE_PERL%%/DBIx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Log4perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx