aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
committertijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
commit67f12d415fec83113a7ddfbc9655db98b4e70a28 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /databases
parent2088f53b95d04c86b1aece3d66aaca36ec5aaec2 (diff)
downloadfreebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.gz
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.zst
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'databases')
-rw-r--r--databases/dbtool/Makefile2
-rw-r--r--databases/hk_classes/Makefile3
-rw-r--r--databases/libodbc++/Makefile3
-rw-r--r--databases/oracle_odbc_driver/Makefile2
-rw-r--r--databases/pgadmin3/Makefile2
5 files changed, 3 insertions, 9 deletions
diff --git a/databases/dbtool/Makefile b/databases/dbtool/Makefile
index 2eb9c3a3f423..1fe1d3ecbe4e 100644
--- a/databases/dbtool/Makefile
+++ b/databases/dbtool/Makefile
@@ -24,8 +24,8 @@ EXAMPLES_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LICENSE= GPLv2
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USES= gmake
REINPLACE_ARGS= -i ""
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index d02b965d16d2..1a5af6c86bb8 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
USES= pkgconfig gettext iconv tar:bzip2
USE_PYTHON= yes
-CXXFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
+LIBS+= -L${LOCALBASE}/lib -largp -lintl
USE_AUTOTOOLS= libtool
CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S/python//}
CONFIGURE_ARGS+=--with-python-libdir=${PYTHON_LIBDIR} \
diff --git a/databases/libodbc++/Makefile b/databases/libodbc++/Makefile
index 28bcffdacae6..8b2e6cd72407 100644
--- a/databases/libodbc++/Makefile
+++ b/databases/libodbc++/Makefile
@@ -19,9 +19,6 @@ USES= gmake libtool pkgconfig tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-isqlxx
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
-CXXFLAGS+= ${PTHREAD_CFLAGS}
-CPPFLAGS+= -I${LOCALBASE}/include
INSTALL_TARGET= install-strip
LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
diff --git a/databases/oracle_odbc_driver/Makefile b/databases/oracle_odbc_driver/Makefile
index 015ca633643e..6fe1deba1c57 100644
--- a/databases/oracle_odbc_driver/Makefile
+++ b/databases/oracle_odbc_driver/Makefile
@@ -22,8 +22,8 @@ ORACLE_HOME= ${LOCALBASE}/oracle8-client
GNU_CONFIGURE= yes
CONFIGURE_ENV= ORACLE_HOME="${ORACLE_HOME}" \
- LIBS="`${CAT} ${ORACLE_HOME}/lib/sysliblist`"\
AUTOHEADER=true
+LIBS+= `${CAT} ${ORACLE_HOME}/lib/sysliblist`
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index 58139320a43f..267a3568a83b 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -18,8 +18,6 @@ IGNORE_WITH_PGSQL= 82 83
USES= gettext gmake pgsql
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
-CPPFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ARGS= --with-wx-version=${USE_WX} --enable-databasedesigner
USE_GNOME= libxml2 libxslt
USE_WX= 2.8