aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2011-10-28 10:09:23 +0800
committerpgollucci <pgollucci@FreeBSD.org>2011-10-28 10:09:23 +0800
commit80a00f1cadf920cbe30ec3bffd4f0f81eaccbd23 (patch)
tree45fcea965ec5d0f34a11a9369cffe4d9a787e70b /databases
parent22aea46707aace42ab494f6e8e26993c8a4b02d5 (diff)
downloadfreebsd-ports-gnome-80a00f1cadf920cbe30ec3bffd4f0f81eaccbd23.tar.gz
freebsd-ports-gnome-80a00f1cadf920cbe30ec3bffd4f0f81eaccbd23.tar.zst
freebsd-ports-gnome-80a00f1cadf920cbe30ec3bffd4f0f81eaccbd23.zip
lib_mysqludf_preg is a library of mysql UDFs (user-defined-functions) that
provide access to the PCRE (perl compatible-regular-expressions) library for pattern matching. The PCRE library is a set of functions that implement regular expression pattern matching using the same syntax and semantics as Perl 5. This syntax can often handle more complex expressions and capturing than standard regular expression implementations. For more information about PCRE, please see: http://www.pcre.org/ lib_mysqludf_preg is a useful performance optimization for those applications that are already performing these regular expression matches in a high level language (ie. PHP) on the client side. It is also helpful when there is a need to capture a parenthesized subexpression from a regular expression, or simply as a slight performance boost over the builtin RLIKE/REGEXP functions. WWW: http://www.mysqludf.org/lib_mysqludf_preg/index.php
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/mysql-udf-preg/Makefile41
-rw-r--r--databases/mysql-udf-preg/distinfo2
-rw-r--r--databases/mysql-udf-preg/pkg-descr16
-rw-r--r--databases/mysql-udf-preg/pkg-message5
5 files changed, 65 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b81c59c5600f..e71201e8158a 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -216,6 +216,7 @@
SUBDIR += mysql-proxy
SUBDIR += mysql-q4m
SUBDIR += mysql-udf
+ SUBDIR += mysql-udf-preg
SUBDIR += mysql-workbench51
SUBDIR += mysql-workbench52
SUBDIR += mysql-xql
diff --git a/databases/mysql-udf-preg/Makefile b/databases/mysql-udf-preg/Makefile
new file mode 100644
index 000000000000..091d74bdc001
--- /dev/null
+++ b/databases/mysql-udf-preg/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mysql-udf-preg
+# Date created: October 27, 2011
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql-udf-preg
+PORTVERSION= 1.0.1
+CATEGORIES= databases
+MASTER_SITES= http://www.mysqludf.org/lib_mysqludf_preg/
+DISTNAME= lib_mysqludf_preg-${PORTVERSION}
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Library of mysql UDFs providing access to PCRE
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/mysql/plugins
+USE_GMAKE= yes
+USE_MYSQL= yes
+
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/lib_mysqludf_preg-${PORTVERSION}
+
+PLIST_FILES= lib/mysql/plugins/lib_mysqludf_preg.a \
+ lib/mysql/plugins/lib_mysqludf_preg.la \
+ lib/mysql/plugins/lib_mysqludf_preg.so \
+ %%DATADIR%%/installdb.sql \
+ %%DATADIR%%/uninstalldb.sql
+PLIST_DIRS= ${DATADIR_REL} lib/mysql/plugins
+
+post-install:
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/installdb.sql ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/uninstalldb.sql ${DATADIR}/
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/databases/mysql-udf-preg/distinfo b/databases/mysql-udf-preg/distinfo
new file mode 100644
index 000000000000..b2b8c83e769c
--- /dev/null
+++ b/databases/mysql-udf-preg/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lib_mysqludf_preg-1.0.1.tar.gz) = 50c7179b354148d66a2324f1a8ed918b133924c8fc0cd53c28afda70e1768daa
+SIZE (lib_mysqludf_preg-1.0.1.tar.gz) = 321868
diff --git a/databases/mysql-udf-preg/pkg-descr b/databases/mysql-udf-preg/pkg-descr
new file mode 100644
index 000000000000..8733f2a1ea85
--- /dev/null
+++ b/databases/mysql-udf-preg/pkg-descr
@@ -0,0 +1,16 @@
+lib_mysqludf_preg is a library of mysql UDFs (user-defined-functions) that
+provide access to the PCRE (perl compatible-regular-expressions) library
+for pattern matching. The PCRE library is a set of functions that
+implement regular expression pattern matching using the same syntax and
+semantics as Perl 5. This syntax can often handle more complex expressions
+and capturing than standard regular expression implementations. For more
+information about PCRE, please see: http://www.pcre.org/
+
+lib_mysqludf_preg is a useful performance optimization for those
+applications that are already performing these regular expression
+matches in a high level language (ie. PHP) on the client side.
+It is also helpful when there is a need to capture a parenthesized
+subexpression from a regular expression, or simply as a slight
+performance boost over the builtin RLIKE/REGEXP functions.
+
+WWW: http://www.mysqludf.org/lib_mysqludf_preg/index.php
diff --git a/databases/mysql-udf-preg/pkg-message b/databases/mysql-udf-preg/pkg-message
new file mode 100644
index 000000000000..4f6184619a49
--- /dev/null
+++ b/databases/mysql-udf-preg/pkg-message
@@ -0,0 +1,5 @@
+== Install the SQL functions ==
+make installdb
+
+== Uninstall the SQL functions ==
+make uninstalldb