aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-12-09 20:56:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-12-09 20:56:12 +0800
commita89566dee2efed6a47173adcb7ef8890e7bd5e94 (patch)
tree4a00dd020e3a37544ec86d5d0f68640cf486c4e7 /databases
parent753102a31677a95994bc06edf33c70c0ff304ab5 (diff)
downloadfreebsd-ports-gnome-a89566dee2efed6a47173adcb7ef8890e7bd5e94.tar.gz
freebsd-ports-gnome-a89566dee2efed6a47173adcb7ef8890e7bd5e94.tar.zst
freebsd-ports-gnome-a89566dee2efed6a47173adcb7ef8890e7bd5e94.zip
- Add missing LIB_DEPENDS via WANT_PGSQL=lib
- Enable RASTER by default - Fix PLIST - Bump PORTREVISION for package change ====> Running Q/A tests (stage-qa) Error: /usr/local/bin/pgsql2shp is linked to /usr/local/lib/libpq.so.5 from databases/postgresql96-client but it is not declared as a dependency Warning: you need USES+=pgsql
Diffstat (limited to 'databases')
-rw-r--r--databases/postgis20/Makefile6
-rw-r--r--databases/postgis20/pkg-plist6
2 files changed, 9 insertions, 3 deletions
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
index 8358fea75131..158ae7d04cad 100644
--- a/databases/postgis20/Makefile
+++ b/databases/postgis20/Makefile
@@ -2,7 +2,7 @@
PORTNAME= postgis
PORTVERSION= 2.0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases geography
MASTER_SITES= http://download.osgeo.org/postgis/source/
PKGNAMESUFFIX= 20
@@ -20,7 +20,7 @@ LIB_DEPENDS= libgeos.so:graphics/geos \
CONFLICTS_INSTALL= postgis- postgis22- postgis23-
OPTIONS_DEFINE= LOADERGUI NLS RASTER TOPOLOGY
-OPTIONS_DEFAULT=TOPOLOGY
+OPTIONS_DEFAULT=RASTER TOPOLOGY
OPTIONS_SUB= yes
LOADERGUI_DESC= Enable shp2pgsql-gui
RASTER_DESC= Raster support
@@ -39,7 +39,7 @@ USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_PERL5= build
USES= gmake iconv:wchar_t libtool perl5 pgsql pkgconfig shebangfix
-WANT_PGSQL= server
+WANT_PGSQL= lib server
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/databases/postgis20/pkg-plist b/databases/postgis20/pkg-plist
index f2e790d36562..b8fe942a14d5 100644
--- a/databases/postgis20/pkg-plist
+++ b/databases/postgis20/pkg-plist
@@ -95,6 +95,9 @@ share/postgresql/contrib/postgis-2.0/postgis_restore.pl
%%RASTER%%share/postgresql/extension/postgis--2.0.1--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis--2.0.2--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis--2.0.3--%%PORTVERSION%%.sql
+%%RASTER%%share/postgresql/extension/postgis--2.0.4--%%PORTVERSION%%.sql
+%%RASTER%%share/postgresql/extension/postgis--2.0.5--%%PORTVERSION%%.sql
+%%RASTER%%share/postgresql/extension/postgis--2.0.6--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis--unpackaged--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis_topology.control
@@ -106,4 +109,7 @@ share/postgresql/contrib/postgis-2.0/postgis_restore.pl
%%RASTER%%share/postgresql/extension/postgis_topology--2.0.1--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis_topology--2.0.2--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis_topology--2.0.3--%%PORTVERSION%%.sql
+%%RASTER%%share/postgresql/extension/postgis_topology--2.0.4--%%PORTVERSION%%.sql
+%%RASTER%%share/postgresql/extension/postgis_topology--2.0.5--%%PORTVERSION%%.sql
+%%RASTER%%share/postgresql/extension/postgis_topology--2.0.6--%%PORTVERSION%%.sql
%%RASTER%%share/postgresql/extension/postgis_topology--unpackaged--%%PORTVERSION%%.sql