aboutsummaryrefslogtreecommitdiffstats
path: root/databases
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-12-11 17:00:31 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-12-11 17:00:31 +0800
commitb060388df778b80d82b9da476d9079ddd6ab60e9 (patch)
tree73aaf20c3422d428c9ef92cffd276ca508ab0e28 /databases
parent0346676d024b3695a096eda43b2ac5c611a1777b (diff)
downloadfreebsd-ports-gnome-b060388df778b80d82b9da476d9079ddd6ab60e9.tar.gz
freebsd-ports-gnome-b060388df778b80d82b9da476d9079ddd6ab60e9.tar.zst
freebsd-ports-gnome-b060388df778b80d82b9da476d9079ddd6ab60e9.zip
- Add LICENSE
- Add NO_ARCH - Unsilence installation commands - Switch to USES=shebangfix
Diffstat (limited to 'databases')
-rw-r--r--databases/mrtg-mysql-load/Makefile18
-rw-r--r--databases/mrtg-mysql-load/files/patch-mrtg-mysql-load5
2 files changed, 10 insertions, 13 deletions
diff --git a/databases/mrtg-mysql-load/Makefile b/databases/mrtg-mysql-load/Makefile
index 5056dbab9d5b..b71e7b5b695f 100644
--- a/databases/mrtg-mysql-load/Makefile
+++ b/databases/mrtg-mysql-load/Makefile
@@ -11,10 +11,15 @@ MASTER_SITES= http://www.bitbybit.dk/mysql/mrtg-mysql-load/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= MySQL load analysis fetcher for MRTG
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
RUN_DEPENDS= mrtg:net-mgmt/mrtg
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
NO_BUILD= yes
+NO_ARCH= yes
NO_WRKSUBDIR= yes
USE_PERL5= run
USE_MYSQL= yes
@@ -22,14 +27,11 @@ USE_MYSQL= yes
PLIST_FILES= bin/mrtg-mysql-load etc/mrtg/mrtg.cfg-mysql-load.example \
etc/mrtg/mysql-load-cfg.example man/man1/${PORTNAME}.1.gz
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PERL%%|${PERL}|' ${WRKSRC}/${PORTNAME}
-
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/mrtg
- @${INSTALL_DATA} ${WRKSRC}/mrtg-cfg.example ${STAGEDIR}${PREFIX}/etc/mrtg/mrtg.cfg-mysql-load.example
- @${INSTALL_DATA} ${WRKSRC}/mysql-load-cfg.example ${STAGEDIR}${PREFIX}/etc/mrtg/mysql-load-cfg.example
- @${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/mrtg-cfg.example ${STAGEDIR}${PREFIX}/etc/mrtg/mrtg.cfg-mysql-load.example
+ ${INSTALL_DATA} ${WRKSRC}/mysql-load-cfg.example ${STAGEDIR}${PREFIX}/etc/mrtg/mysql-load-cfg.example
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/databases/mrtg-mysql-load/files/patch-mrtg-mysql-load b/databases/mrtg-mysql-load/files/patch-mrtg-mysql-load
deleted file mode 100644
index ebb461b426d1..000000000000
--- a/databases/mrtg-mysql-load/files/patch-mrtg-mysql-load
+++ /dev/null
@@ -1,5 +0,0 @@
---- mrtg-mysql-load.orig Mon Feb 18 11:03:52 2002
-+++ mrtg-mysql-load Thu Apr 8 14:24:57 2004
-@@ -1 +1 @@
--#!/usr/local/bin/perl -w
-+#!%%PERL%% -w